New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 83013)

Getaway issue - all solenoids intermittently stop working


By DML1001

6 years ago



Topic Stats

  • 18 posts
  • 6 Pinsiders participating
  • Latest reply 5 years ago by zaza
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

12v reg7.png

#1 6 years ago

Hi again,

I am experiencing a new issue with my HS2 machine. The game was working fine for a few days after I fixed the ball lock, but now I am having an issue where all solenoids in the machine will just stop working. This has happened 3 times so far. Two were during gameplay where both flippers suddenly stopped working along with all other coils (when the ball drained, the solenoid never fired to kick it into the trough even though the switch was registering.

When I enter the debug menu while this is happening and begin the solenoid test, they don't work from there either. Not a single coil fires during the test. The only thing that works in the solenoid group is the mars lamp motor.

Rebooting the machine does not change anything. After a reboot the game still fails to ever file a coil for as long as the problem persists.

So far, this issue has resolved itself within 5-15 minutes. After a little, the game suddenly starts working again. I've entered the switch diagnostic menu, and everything there seems to be OK. All the expected switches are registering at any given time. If I poke the slingshots, I see the switch register but they do not fire. Same with the pop bumpers, etc...

While this is happening, I don't notice any other odd behavior with the machine. The dot matrix still behaves as expected, the mars lamp still works fine, and all the switches sounds and lights behave normally.

I'm guessing this is some sort of bad connection since the problem comes and goes. Can anyone suggest how to approach diagnosing this? I currently do not have the full wiring diagram for HS2, but I ordered it yesterday. I was unable to find it online after looking for a few minutes.

Thanks,
DML1001

#2 6 years ago

Next time the coils die, quick measure the voltage test point on the power driver board for 50V, might be higher not under load.

That will at least sort out if you have a board issue or connector issue.

Don't rule out ribbon cable from CPU to the power driver board either.

LTG : )

#3 6 years ago

Could the high-power cutoff interlock switch held closed by the coin door be flaky?

RM

#4 6 years ago
Quoted from RussMyers:

Could the high-power cutoff interlock switch held closed by the coin door be flaky?

Good suggestion (that's exactly what I initially thought too), except there's no interlock (at least on my HS2).

It's a death trap - which adds to the overall lawlessness and thrill of the game.

#5 6 years ago

Thanks for the advice. I have my multimeter ready to go, and I will post here if I get the issue to happen and manage to check the voltage before it corrects itself.

1 year later
#6 5 years ago

I wonder if this is ever solved. Have a exact same problem and couldn't figure out what's wrong.

#7 5 years ago

Lloyd's instructions (second post of this thread) are the way to proceed. I just looked at the schematics, here's a step-by-step:

1) Pull out your DMM (voltmeter) and set it to the 200VDC range.

2) Connect the black probe of the DMM to GND. Sometimes you can just slip it under some nearby ground braid, making sure the connection between the braid and the probe is not too loose. Ideally you will have a probe wire that has an alligator clip that can clip onto the braid/ground.

3) Connect the red probe (one measurement at a time) to the following points on the driver board: J907 pins 1, 2, 6, and 7, and J107 pins 2 and 3.

4) As Lloyd mentions you should see 50V or higher on each pin. Make sure you are measuring the voltages when the flippers/solenoids are NOT working. If the problem is intermittent and the flippers/solenoids are currently working, you are guaranteed to see >50V there. We need to know the voltages when they are NOT working.

5) Post your results here and we'll tell you where to look next.

#8 5 years ago

Thanks for the response. I love to do that but another error has popped up.
Check fuses F114 and F115. The game wouldn't start with that error. First thing to look for are the voltages on the boards. Will be back

#9 5 years ago

Got stuck on this one.
quote from pinwiki: Check LED1. If not lit (indicating the absence of “digital” 12V at TP3, then test D1 and D2 (both 1N4004 diodes). If D1/D2 test good, then check continuity from pin 2 of the 7812 voltage regulator at Q2 to J114, pin 1. This verifies the path through F115.

D1 and D2 are good but there is no continuity from pin 2 to pin 1. That should be a problem i guess.
Where to go from here??

#10 5 years ago

Still not changed in the PinWiki ?

This is the latest version of 12Vreg circuit:
12v reg7.png

#11 5 years ago

Thanks zaza

That should be changed then It will help me out to understand the circuit now. I suspect Q2 as the bad guy. Will replace that one this week.

#12 5 years ago

Check also C2, it is known for leaking and destroying the traces of the PCB under the capacitor.

#13 5 years ago

Thanks, yes i will although it looks ok on the backside of the board but i cant look under this C2.

#14 5 years ago
Quoted from zaza:

Check also C2, it is known for leaking and destroying the traces of the PCB under the capacitor.

And that's what happened to mine also. Damn, it looks awfull underneath. I have to use jumper wires to get this fixed Too bad but at least it will be in working state again. Thanks zaza.

#15 5 years ago

: ) that's one,
If you still have problems with the 50Volt circuit, let us know.

#16 5 years ago

Will do. It will be a long weekend

#17 5 years ago

I played and played and played but no errors uptill now. Somehow related to a bad C2 on the powerboard?
I think ( for me) problem solved and thanks for your input.

#18 5 years ago
Quoted from davalve:

Somehow related to a bad C2 on the powerboard?

The flipper coils are related to the C2 because the fliptronicsboard is using this 12V for the LM339 comparators. For the other coils I can't come up with a solid explanation.
But good to know this might be related to each other.

Thanks for the update.

Promoted items from the Pinside Marketplace
$ 15.00
Playfield - Decals
Metal-Mods
$ 50.00
$ 159.99
Lighting - Other
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside