(Topic ID: 78179)

Getaway Club ~ Dispatch, run a make on license plate KINGPIN


By MrSanRamon

5 years ago



Topic Stats

  • 10,052 posts
  • 379 Pinsiders participating
  • Latest reply 5 hours ago by Mr_Tantrum
  • Topic is favorited by 174 Pinsiders

You

Linked Games

Topic poll

“Which S/W Version do you use?”

  • L1 18 votes
    6%
  • L2 140 votes
    51%
  • L3 8 votes
    3%
  • L5 96 votes
    35%
  • P7 8 votes
    3%
  • C-C 7 votes
    3%

(Multiple choice - 277 votes by 276 Pinsiders)

Topic Gallery

There have been 3,087 images uploaded to this topic. (View topic image gallery).

IMG_2606 (resized).jpg
Outlet correct resized (resized).jpg
leaf switch (resized).jpg
0EDA5480-6568-44E8-9CF2-773145607567 (resized).png
20191206_212938 (resized).jpg
Screenshot 2019-12-06 12.28.17 (resized).png
IMG_20191201_141557 (resized).jpg
Capture-2 (resized).PNG
getaway2.jpg
getaway1.jpg
photo_2645234887990155805 (resized).jpg
photo_5792814484576256525 (resized).jpg
20191113_195034 (resized).jpg
20191107_200859 (resized).jpg
20191107_203328 (resized).jpg
20191107_201404 (resized).jpg

You're currently viewing posts by Pinsider pindan3.
Click here to go back to viewing the entire thread.

#2475 3 years ago

I guess I'll join this club now too! I got my restored High Speed 2 a couple of months ago.I have an extra Kenwood Stereo System in my game room and hooked it up to that.....WOW!!....I did not notice that the 5 flashers in the back box were not working until a few days after I had it. And I can not figure out just what the problem is? I tried putting in LED flashers....but they would blow out! Strange....And I am using the kind! So for now...no workie...Also I tried to hook up the Blue flasher mod...but it freaks the game out when activated so its left unhooked for now. Must be a wire shorting....or a bad transistor somewhere??

#2479 3 years ago

Trying to describe the flasher and mod issue is a bit confusing here....I just know when the mod is hooked up it makes the red light on top try to work constantly, like...(yea the like word" lol...).everytime you hit a pop bumper or a sling the topper slightly flashes with it. And if I put a normal flasher in the back box ( where the 5 go ) it will get real bright and make a coil fire where the donut shop mod is. And I'm probably still not getting my message across in right way, So we have this guy in our area "atari Jim " who is REALLY good at tracing this stuff. So I guess I will load it up one day and have hime do his magic, He hates MODs though....LOL...

#2503 3 years ago

Anyone here know where I can find a Mars Light for my game? It just took a crap. its jammed up.

11 months later
#6006 2 years ago

ot ....oh.......my High Speed 2 is giving off a smell...you know....that something frying smell.....seems to happen in multi ball, I can't seem to locate it...but it keeps on playing! I guess I will find out someday someway when it pops!

Promoted items from the Pinside Marketplace
5,500 (OBO)
Machine - For Sale
Lynbrook, NY
$ 9.99
Eproms
Matt's Basement Arcade
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 8.50
Lighting - Led
Pinball Haus

You're currently viewing posts by Pinsider pindan3.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside