(Topic ID: 78179)

Getaway Club ~ Dispatch, run a make on license plate KINGPIN


By MrSanRamon

5 years ago



Topic Stats

  • 9,863 posts
  • 366 Pinsiders participating
  • Latest reply 1 day ago by Mr_Tantrum
  • Topic is favorited by 169 Pinsiders

You

Linked Games

Topic poll

“Which S/W Version do you use?”

  • L1 17 votes
    6%
  • L2 137 votes
    51%
  • L3 8 votes
    3%
  • L5 92 votes
    34%
  • P7 7 votes
    3%
  • C-C 7 votes
    3%

(Multiple choice - 268 votes by 267 Pinsiders)

Topic Gallery

There have been 3,013 images uploaded to this topic. (View topic image gallery).

pasted_image (resized).png
Getaway.JPG.pdf (PDF preview)
pasted_image (resized).png
pasted_image (resized).png
wires2.jpg
wires1.jpg
getaway005 (resized).jpg
IMG_2668.JPG
IMG_2667.JPG
IMG_2666.JPG
IMG_2665.JPG
IMG_2663.JPG
IMG_2657.JPG
CF4BA3F1-8798-42F5-93ED-C868E24872A8 (resized).jpeg
B2805FCB-7FE1-41B2-88BC-F12FD7E77765 (resized).jpeg
8F41C362-51A9-4EAA-904F-5D215BB0EFD8 (resized).jpeg

There are 9863 posts in this topic. You are on page 60 of 198.
#2951 3 years ago
Quoted from indypinhead:

I still have the stoplight mod kit available, if anyone is interested...
https://pinside.com/pinball/forum/topic/hs2-the-getaway-stoplight-mod

Sent you a PM about one of these.

#2952 3 years ago

Couple of shots of the right flipper switches. Anything jump out?

image_(resized).jpeg

image_(resized).jpeg

image_(resized).jpeg

#2953 3 years ago

that middle leaf shouldn´t be twisted like that

#2954 3 years ago

Sure does look twisted !!! Is it close to touching? if so that's what i was thinking may be the issue.

#2955 3 years ago

Unplug the switch and see if you are still having an issue.

#2956 3 years ago

that middle leaf is not supposed to be twisted like that for sure, and the contacts on it should not be touching either of the other 2 leaf contacts at rest... The "lane change" switch (contact furthest from the button) is definitely stuck closed! Is your flipper stuck on? if so, that would be why!
The benefit in your case that you have TWO of these switch assemblies in your game, look carefully at the one that is NOT causing an issue and make this one look exactly like it!

#2957 3 years ago

Good stuff guys thanks. I noticed the touching as well and slightly twisted but I didn't do anything to to them that I recall to make them touch so I wasn't sure if that was the issue.

I bent the switches back giving them space and making sure they touch only when the flipper button is pressed. I played a few games and didn't get that stuck up problem again.

My left flipper came up during play. Maybe I didn't have it tightened enough.

My kickback angle is def off and prob only makes it in the hole 1 out of 7 or 8 times.

The rear ramp assembly is doing this weird knocking/ticking when the game was on.

It looks beautiful and it's getting closer and closer to playing like it was before the teardown and chroming.

image_(resized).jpeg

1 week later
#2958 3 years ago

Hey fellas, my supercharger diverter is feeling a little loose up and down direction. I can tell where it has scraped the ramp a bit and sometimes gets hung up on the side and cant swing since it is hitting the ramp. The coil is also buzzing as it is activated. Has anyone had the same issue before I start a tear down?

#2959 3 years ago

Typically the buzzing sound occurs when the plunger is not able to travel the full stroke to the coil-stop, so something is probably stuck or jamming up.

#2960 3 years ago

Check the coil sleeve and linkage

#2961 3 years ago

Ground up restoration finally completed.

2_(resized).jpg

1_(resized).jpg

3_(resized).jpg

#2962 3 years ago
Quoted from TheOnlyest:

Typically the buzzing sound occurs when the plunger is not able to travel the full stroke to the coil-stop, so something is probably stuck or jamming up.

That's probably it. It's loose and dragging and not activating the end of stoke or whatever is there. Makes sense. I'll update you thanks guys!

#2963 3 years ago

Looks nice, manimal! Any closer shots of the playfield?

#2964 3 years ago
Quoted from Manimal:

Ground up restoration finally completed.

That looks great. How do your mirror blades fit?

#2965 3 years ago
Quoted from jawjaw:

Looks nice, manimal! Any closer shots of the playfield?

I will take some tonight when I get back home.

#2966 3 years ago
Quoted from MustangPaul:

That looks great. How do your mirror blades fit?

Actually, that is a reflection from the new paint. No mirror blades yet.....I am not that big a fan of them, however I have seen one getaway with them and they looked good. I just hate it when they get scratched or dented from playfield lift or airball. Kind of like owning a black car.....they look great clean, but not so much after a while.

#2968 3 years ago
Quoted from MustangPaul:

I see, sure fooled me.

I would think black gloss or semi-gloss paint would be reflective to a degree, I need to touch mine up anyway, so I may try it...

#2969 3 years ago
Quoted from tiltmonster:

I would think black gloss or semi-gloss paint would be reflective to a degree, I need to touch mine up anyway, so I may try it...

Gloss black would give it a black mirror look.

#2970 3 years ago

Any tips for getting the super jackpot? During Getaway to get the jackpot you only need 1 ball in play. I get it basically every time.

It's that super jackpot that is killing me as you need to have 2 balls in play to get it.

#2971 3 years ago
Quoted from Sticky:

Any tips for getting the super jackpot? During Getaway to get the jackpot you only need 1 ball in play. I get it basically every time.
It's that super jackpot that is killing me as you need to have 2 balls in play to get it

"Park" one ball in the tunnel so it's out of your way, and take advantage of the time it sits there to use the right flipper to shoot the super. Or trap two balls on the left flipper, then just lightly tap so that one ball transfers over to the right flipper but the other stays on the left, then use the right to shoot the super--it takes some practice but it's worth it. Good luck!

#2972 3 years ago

I like to catch a ball in the right flipper and go for the left orbit shot before the ball from the supercharger returns. Another option is to get all balls in the supercharger. Hit away all except last ball. Holding the left flipper up and a little nudge gets the ball over to the right flipper for a quick shot.

#2973 3 years ago
Quoted from jawjaw:

Looks nice, manimal! Any closer shots of the playfield?

Pretty much bone stock. Needed a cleaning really really bad, leveled a bunch of inserts,replaced flippers, and sanded and re-cleared shooter lane. (There was some black just too deep to sand, but the lane looks much better than the pic)

2_(resized).jpg
3_(resized).jpg
4_(resized).jpg
5_(resized).jpg
6_(resized).jpg
7_(resized).jpg

1_(resized).jpg

#2974 3 years ago

Well, I think this will fix my diverter problem.

20160809_182117_(resized).jpg

20160810_152910_(resized).jpg

#2975 3 years ago
Quoted from futurepinhead:

Well, I think this will fix my diverter problem.

Yup I would think so.

#2976 3 years ago

what's usually the issue when the ball is hitting the divertor as it opens? is my divertor slow or is the sc too fast?

#2977 3 years ago
Quoted from weaverj:

what's usually the issue when the ball is hitting the divertor as it opens? is my divertor slow or is the sc too fast?

Clean the optos that track the ball on the supercharger circuit. Made a big difference for me.

#2978 3 years ago
Quoted from futurepinhead:

Well, I think this will fix my diverter problem.

If it doesn't, there are diverters still available out there. I ordered one from the parts store in Australia for like $18. Took a while to get here, but works fine.

#2979 3 years ago

tyvm.

#2982 3 years ago

Beautiful Getaway manimal I bet it's a blast to play.

#2984 3 years ago
Quoted from RVApinballer:

Beautiful Getaway manimal I bet it's a blast to play.

Yep, I noticed last night I need to add some wax, but I am having fun with it. That 100mil super Jackpot is fun to get. Only done it once, and it took 5 balls. I'm working on getting that down to 3, but not having much luck! lol

#2985 3 years ago

Damn i miss playing my Getaway! Still waiting on a few parts to hopefully complete my restoration soon.

#2986 3 years ago

I love my Getaway. No where near as pretty as your Getaways, but I've had it for around 5 years. Its been to 4 Expos and been on route basically the whole time. My only issues have been 1 blown fuse, 1 loose coil, 1 loose coil wire, and this diverter. She's my work horse.

#2987 3 years ago

I hear you on the work horse. Mine was an Italian reimport with the lire coin mechs and it was my first game and has been dead solid reliable the whole 5+ years. The cabinet is faded and some bruises but it has a new playfield and plays just as good as it did when I got it. Just a bit shinier and faster.

#2988 3 years ago

i'd feel bad if i ever routed mine. the new cabinet decals would get butchered.

#2989 3 years ago

While im waiting on a few parts to finish my Getaway ive been cleaning all the underside inserts. During this process i realized that there is one insert that is underneath the left scorecard that does not have a light hooked up to it. Never saw this before. Does anyone know why this is there ? Do you all have this insert in your playfield ? weird !! lol

IMG_20160811_195052_(resized).jpg

IMG_20160811_195119_(resized).jpg

#2990 3 years ago

Mine has the same insert. Serves no purpose as far as I know.

#2991 3 years ago

I have heard that inserts like that are a test of the manufacturing process.

#2992 3 years ago

Work horse Getaway is playing 100% again. Time for its new home at my arcade.

#2993 3 years ago

I know there's quite a few posts about the back ramp need adjustment or not working, however i need help with the lifting mechanism. My ramp is binding when going down, opposed to it being a coil issue. It keeps attempting to come down when lock is on. When I try to activate the mechanism manually it still has strong resistance to do a full movement... I'll try and remove the rod that goes in the ramp and do a test to see if it still binds. Otherwise I'm thinking I'll have to rebuild the mechanism...

IMG_20160810_245338795_(resized).jpg

#2994 3 years ago
Quoted from alexred:

I have heard that inserts like that are a test of the manufacturing process.

exactly.

#2995 3 years ago
Quoted from Beef_Supreme:

I know there's quite a few posts about the back ramp need adjustment or not working, however i need help with the lifting mechanism. My ramp is binding when going down, opposed to it being a coil issue. It keeps attempting to come down when lock is on. When I try to activate the mechanism manually it still has strong resistance to do a full movement... I'll try and remove the rod that goes in the ramp and do a test to see if it still binds. Otherwise I'm thinking I'll have to rebuild the mechanism...

There isn't a whole lot to re-build on it. I would still look hard at the coil plunger/sleeve first

I know this is not what you want to hear, but the only real way to work on that assembly any more in depth and to know what is going on, is to pull the playfield out of the cabinet so you can get to the back, and see how the lifting peg is interacting with the ramp. You may have to un-bolt the Supercharger ramp so you can get to the bottom ramp assembly. It's not as bad as it looks. If it is not the coil mech, then it is likely the lifting peg or the ramp pivot shaft getting into a bind. Worst case, one of them is bent....best case, one came lose. Check the ramp pivot shaft. It is where the small ramp attaches like a hinge to the bigger ramp on the lower level. If the keeper came off and the shaft slid out a bit, the ramp will tweak to one side a bit, and that would throw all of the mechanics off, including the release and lock. if you grab the ramp and can wiggle it side to side, then something is not right on the pivot assembly. Like I said, if you pull the playfield, you will see whatever is causing the issue really fast, as there is not much to the assembly. If you are trying to do it with the playfield still in the cabinet, it can be a real pain in the butt to diagnose. Just gravity pulling on the parts in a different direction can throw off your diagnosis.

1 week later
#2996 3 years ago

I am in the process of removing this broken screw from the bottom left of my playfield. Would someone be kind enough to send me a picture of what goes there so that I can go ahead and order the missing piece? Thanks

https://images.pinside.com/c/97/c9786e8040cd09a03e67197a1b8eea8e16edd26c/resized/large/c9786e8040cd09a03e67197a1b8eea8e16edd26c.jpeg

#2997 3 years ago

See the screw at the other end that's still intact? Exact same stuff.... Very common setup on Steve Ritchie games. The #6 wood screw and #4 washers are readily available, but I havn't seen the spacer sleeve available anywhere! Good luck!

#2998 3 years ago

Thanks, but it looks completely different on the opposite side. That's why I'm hoping someone can send me a picture of theirs

#2999 3 years ago
Quoted from tomh52722:

Thanks, but it looks completely different on the opposite side. That's why I'm hoping someone can send me a picture of theirs

The star post? There's a T nut there if so. I recently did a playfield swap in mine. I have more pics than in this thread. https://pinside.com/pinball/forum/topic/hs2-playfield-swap

PM me if you need more.

DSCN3308_sling_t_nut_(resized).jpg

#3000 3 years ago

Thank you so much! Ok, looking at your pictures, I need the piece on the left of the bottom of this picture. Do you know what this is called?

image_(resized).jpg

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Bel Air, MD
There are 9863 posts in this topic. You are on page 60 of 198.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside