(Topic ID: 78179)

Getaway Club ~ Dispatch, run a make on license plate KINGPIN


By MrSanRamon

5 years ago



Topic Stats

  • 10,060 posts
  • 379 Pinsiders participating
  • Latest reply 7 hours ago by pkrobin
  • Topic is favorited by 175 Pinsiders

You

Linked Games

Topic poll

“Which S/W Version do you use?”

  • L1 18 votes
    6%
  • L2 140 votes
    51%
  • L3 8 votes
    3%
  • L5 96 votes
    35%
  • P7 8 votes
    3%
  • C-C 7 votes
    3%

(Multiple choice - 277 votes by 276 Pinsiders)

Topic Gallery

There have been 3,093 images uploaded to this topic. (View topic image gallery).

20191212_172916 (resized).jpg
Screenshot 2019-12-12 21.46.27 (resized).png
A3E46986-81C3-408C-864E-08310B580DE6 (resized).jpeg
76DB5BF3-AB55-435D-9012-C8074FE35331 (resized).jpeg
13DD0908-D2D0-4841-A524-86EE51C3DB35 (resized).jpeg
AA212063-24D9-4E6B-8B8B-09E1F722D803 (resized).jpeg
IMG_2606 (resized).jpg
Outlet correct resized (resized).jpg
leaf switch (resized).jpg
0EDA5480-6568-44E8-9CF2-773145607567 (resized).png
20191206_212938 (resized).jpg
Screenshot 2019-12-06 12.28.17 (resized).png
IMG_20191201_141557 (resized).jpg
Capture-2 (resized).PNG
getaway2.jpg
getaway1.jpg

There are 10060 posts in this topic. You are on page 200 of 202.
#9951 43 days ago
Quoted from red-line:

I finally broke a billion! Love this game. It's such a pure game.[quoted image]

Woah! That's a big number!

#9952 43 days ago

When i start a game the ball auto plunges immedietly without me touching the shifter... any ideas on why?

#9953 43 days ago
Quoted from red-line:

I finally broke a billion! Love this game. It's such a pure game.[quoted image]

Dang, I can barely break 300M. How long did this game take? how many extra balls?

#9954 43 days ago
Quoted from okgrak:

Dang, I can barely break 300M. How long did this game take? how many extra balls?

Not that long really. Maybe 25 or 30 minutes? Prob 5 or 6 EB's, I went to redline mania either 3 or 4 times. On my last ball I hit 3 or 4 super jackpots

Now I have my sights on the 7.3 mil score that's logged on pinside. Maybe in 15 or 20 years I'll get it!!

#9955 43 days ago
Quoted from Dantesmark:

When i start a game the ball auto plunges immedietly without me touching the shifter... any ideas on why?

Help

#9956 43 days ago

Menu,
A2. 04. Timed plunge.

Set to off.

#9957 42 days ago

I installed some plastic protectors and swapped out my mountain plastic and installed the pinduino super charger mod . To do this I removed the super charger cover , installed everything, . After putting everything back together, when I turn on my Getaway I get an error report. The report says to check the optos and left ramp entrance. If I start a game the ball launcher doesn't fire, and the flippers dont work either. Any idea what I could have knocked loose or broke? I'll be cross posting this in the general help as well and will put the solution in both threads too.

I have reseated the plugs at j206 and j209 , and I verified f104 and f105 fuses are good.

#9958 41 days ago

I'm running ROM L-2 in the game. For some reason, at the beginning of a game, 4 of the 5 Freeway lights between the flippers are lit. Does anybody know if there is a setting or option to look at or change so it starts with just the one left light flashing?

#9959 41 days ago
Quoted from schudel5:

I'm running ROM L-2 in the game. For some reason, at the beginning of a game, 4 of the 5 Freeway lights between the flippers are lit. Does anybody know if there is a setting or option to look at or change so it starts with just the one left light flashing?

I think your game is in xtra easy. You should put it in xtra hard : Fonctions : F9 xtra hard.

#9960 41 days ago
Quoted from Kerry_Richard:

Hello Pinsiders... I'm looking for a Getaway HSII
I'm in Northern California (40 miles each of San Francisco).
I like to drive... I can travel North towards Oregon / Washington. East towards Nevada, Idaho or Utah and South down to San Diego. I've driven to all those states to pick up games.
I have many titles I'd consider in trade or cash on the glass too!
Thanks!
Kerry

What Minnesota is to far of a drive for you?

#9961 41 days ago
Quoted from Mr_Tantrum:

Today's Initial Mountain Order Update
All of the mountains are painted and clear coated. Just waiting for paint to dry for a few hours, then I'll install lighting and they are ready to ship as soon as the clear plastics arrive. FYI, clear is still wet in these photos, but will dry to a satin finish.[quoted image][quoted image]

Thank you. I got mine and installed it. It's a tight fit but no problems. Looks great. Really adds something to the machine. Thank you @mr_tantrum

20191102_115436 (resized).jpg20191102_115619 (resized).jpg
#9962 41 days ago
Quoted from ajnin:

Thank you. I got mine and installed it. It's a tight fit but no problems. Looks great. Really adds something to the machine. Thank you @mr_tantrum[quoted image][quoted image]

Looks great!

#9963 40 days ago
Quoted from Malenko:

I installed some plastic protectors and swapped out my mountain plastic and installed the pinduino super charger mod . To do this I removed the super charger cover , installed everything, . After putting everything back together, when I turn on my Getaway I get an error report. The report says to check the optos and left ramp entrance. If I start a game the ball launcher doesn't fire, and the flippers dont work either. Any idea what I could have knocked loose or broke? I'll be cross posting this in the general help as well and will put the solution in both threads too.
I have reseated the plugs at j206 and j209 , and I verified f104 and f105 fuses are good.

go through switch test and see what is going on. You may have an opto board fault (not a cause of flippers not working though).
whilst on the switch test screen, check the flipper switches register also. If they do chase the other voltages down (+50ish at the flippers etc).

expecting with your symptoms and recent history of changes to be an unseated connector (supply) or bad crimp, so check voltages at boards,, but do switch matrix test first.

And thanks for the really cool mods.

#9964 40 days ago

Today I installed the PinSound Shaker as the latest enhancement of my completely pimped out Getaway (https://pinside.com/pinball/forum/topic/high-speed-2-the-getaway-first-restoration). The shaker integrates perfectly, thanks to the orchestration created by mr_tantrum. Tantrum this is a really awesome job!!!

The installation was easy. However, opposing the manual, I advise against "hammering down" the claw nuts into the cabinet. It is absolutely sufficient pulling them in while tightening the screws. Hammering on an assembled pinball machine shouldn'T really be the reccommended way to go anyhow..

Anyway, after I had changed the flipper button leaf switches to optos some time ago (https://pinside.com/pinball/forum/topic/converting-taf-flippers-from-leaf-switch-to-optical-boards) and installed the CPR Backglass recently (https://pinside.com/pinball/forum/topic/review-cpr-backglass-for-high-speed-2-the-getaway), the only things I am now still contemplating is Tantrum's Mountain Mod (but honestly not sure about it), and the crazy Pinduino Supercharger light strip.

Otherwise I think this thing is actually done with nothing left to do. Super happy!

#9965 40 days ago
Quoted from Sprudeldudel:

Otherwise I think this thing is actually done with nothing left to do. Super happy!

Well there's always my mod.

#9966 40 days ago
Quoted from MustangPaul:

Well there's always my mod.

Lite ‘em up!

#9967 40 days ago
Quoted from Sprudeldudel:

Today I installed the PinSound Shaker as the latest enhancement of my completely pimped out Getaway (https://pinside.com/pinball/forum/topic/high-speed-2-the-getaway-first-restoration). The shaker integrates perfectly, thanks to the orchestration created by mr_tantrum. Tantrum this is a really awesome job!!!
The installation was easy. However, opposing the manual, I advise against "hammering down" the claw nuts into the cabinet. It is absolutely sufficient pulling them in while tightening the screws. Hammering on an assembled pinball machine shouldn'T really be the reccommended way to go anyhow..
Anyway, after I had changed the flipper button leaf switches to optos some time ago (https://pinside.com/pinball/forum/topic/converting-taf-flippers-from-leaf-switch-to-optical-boards) and installed the CPR Backglass recently (https://pinside.com/pinball/forum/topic/review-cpr-backglass-for-high-speed-2-the-getaway), the only things I am now still contemplating is Tantrum's Mountain Mod (but honestly not sure about it), and the crazy Pinduino Supercharger light strip.
Otherwise I think this thing is actually done with nothing left to do. Super happy!

Was there any programming of the pinsound shaker?

Did you order it pre-programmed?

Or was it pretty much plug and play.

#9968 40 days ago
Quoted from MustangPaul:

Well there's always my mod

uhm... no way. Simply lighting everything that can be lit isn't in line with my very personal understanding of tasteful modding. More is not always better. Same goes for adding a bunch of matchbox cars, 3D printed stop lights or similar toys, which break with the look and feel of the original design language. Each to his own tho.

Quoted from pinballinreno:

Was there any programming of the pinsound shaker?
Did you order it pre-programmed?
Or was it pretty much plug and play?

The Shaker comes preprogrammed. The stock program was created by tantrum upon request by the PinSound guys. It can be modified, but I like it as is.
Installation is rather plug and play, but does require some drilling. There is also a details video on that at http://www.pinsound.org/help The recommended location of the Shaker didn't quite suit me, but that's not a big deal.

#9969 39 days ago
Quoted from pinballinreno:

Was there any programming of the pinsound shaker?
Did you order it pre-programmed?
Or was it pretty much plug and play.

The shakerization, as I call it, is built into the config file for each orchestration. As long as you have an orchestration using the new convention (just re-download any of them from the community site) and updated firmware, then you will be golden.

Also, I take no offense if anyone chooses to modify my shakerization. I put a lot of time and effort creating it to the point where I thought it integrated well and others would like it, but for some it may be too much shaking. The good news is that you don’t have to start from scatch since you can edit what I did.

#9970 34 days ago

mr_tantrum I also just installed my Pinsound Shaker for HS2. It was plug and play. I made some silly mistakes installing it. Like I mounted it too far forward and the door would not close, then I mounted it upside down. The end product is great. it was a simple install and no programming required. The integration is spot on. It's not overdone, nice work on putting that together!!

20191109_131459 (resized).jpg20191109_134101 (resized).jpg20191109_150700 (resized).jpg
#9971 33 days ago

Glad you like it. Funny about mounting upside down.

#9972 29 days ago

Just throwing this out there to anyone with good up to date electronics experience.
I am working on a mod for my Getaway to using addressable 2812 Led rings 3 x 70mm for the bumper caps and 2 x 90mm rings for behind the speaker grills, the leds will be driven by a Arduino. I am researching the best way for the game to interact with the Arduino. So because I am a bit old school with electronics I was thinking to put 6v AC relays across the traffic lights connections removing the bulbs to keep current down. The relays will send high/low signal to the arduino and also light the original traffic light bulbs the arduino will change the ring colours to match the traffic lights, also a relay on the top light to strobe the rings red and blue to match police lights.
Are relays the best way to go ?

I want to advance on from this to interact to Multiball, Jackpot & Redline Mania etc.
20191107_194012 (resized).jpg20191107_200859 (resized).jpg20191107_201404 (resized).jpg20191107_203328 (resized).jpg20191113_195034 (resized).jpg
photo_5792814484576256525 (resized).jpgphoto_2645234887990155805 (resized).jpg

#9973 29 days ago
Quoted from nutty:

Are relays the best way to go ?

No. Pm me and we can chat about this.

#9974 29 days ago

malenko just posted an update of the PIN2DMD files.

https://drive.google.com/drive/folders/1P-oTdnd_VGMxCbM5Hfnk9k7wPd9mFI2Q

Thanks for the ongoing effort!!!

#9975 27 days ago
Quoted from Sprudeldudel:

malenko just posted an update of the PIN2DMD files.
https://drive.google.com/drive/folders/1P-oTdnd_VGMxCbM5Hfnk9k7wPd9mFI2Q
Thanks for the ongoing effort!!!

I actually upload new betas pretty frequently. I'm trying to get all the "burnout maps" done before the next release, which hopefully will be the last one.

The latest beta I uploaded should fix a few attract mode issues and more.

#9976 26 days ago

Im about to send all my boards off to get looked at, I cant seem to figure out why my game isnt working and now the 12v LED is off too. I havent touched anything so Im at a loss.

I figure I mine as well make paper weight prettier and put in the Mountain mod I bought. I modded the mod and pulled out the small LED strip and put that on the metal behind the mountain to shine in the area in the back right corner, I then installed a frosted LED strip the length of the inside of the mountain. I also added another LED strip to the left of the mountain hole facing outward towards the 3 nearby targets.

getaway1.jpg
getaway2.jpg

I also removed the plastic that would be under the mountain and replaced it with the plastic protector that would go on top. This does expose the rubbers near the mountain hole but it also lets a lot more light out. I kept the stock plastics I pulled together in case I ever want to revert it.

#9977 26 days ago
Quoted from Malenko:

Im about to send all my boards off to get looked at, I cant seem to figure out why my game isnt working and now the 12v LED is off too. I havent touched anything so Im at a loss.
I figure I mine as well make paper weight prettier and put in the Mountain mod I bought. I modded the mod and pulled out the small LED strip and put that on the metal behind the mountain to shine in the area in the back right corner, I then installed a frosted LED strip the length of the inside of the mountain. I also added another LED strip to the left of the mountain hole facing outward towards the 3 nearby targets.
[quoted image]
[quoted image]
I also removed the plastic that would be under the mountain and replaced it with the plastic protector that would go on top. This does expose the rubbers near the mountain hole but it also lets a lot more light out. I kept the stock plastics I pulled together in case I ever want to revert it.

Wow that looks really nice. I'm really sorry for you with all the issues you are having. I've been through it with mine over the last 3 years, and virtually every board has been replaced and I've even had to repair some of the replacements.

#9978 26 days ago

apparently Im missing one of the rubbers on the left side of the mountain, cause there was a broken one just sitting under the plastic.

You can see the clear plastic protector to the right of the mountain entrance replacing the regular plastic. I wasnt sure if I'd like it but I do. I need to get replacement clear bands for everything.

#9979 26 days ago
Quoted from Malenko:

replaced it with the plastic protector that would go on top.

Plastic protectors go UNDERNEATH the plastics to protect against ball impact from below. It's counter intuitive - I installed them on top first time as well, and changed that later.

#9980 25 days ago

I think I only used 1 or 2 plastics as protectors, the rest were used as replacement plastics. Im not gonna worry about swapping them around but that's good to know for next time.

#9981 25 days ago
Quoted from Malenko:

I think I only used 1 or 2 plastics as protectors, the rest were used as replacement plastics. Im not gonna worry about swapping them around but that's good to know for next time.

I only have them on my AFMr and they are colored - was my key to not install them on top.

#9982 24 days ago

Sorry if its been covered before...I've just got my machine together running L2 Rom.
Can't turn off flipper button launch adjustment. Menu section in on or off doesn't make any difference...any help out there?
Also chasing chrome apron decals mainly the stripes. Have the retro refurb t2 ones but they are really expensive.
Cheers for any help !

#9983 23 days ago
Quoted from Jakusu:

Sorry if its been covered before...I've just got my machine together running L2 Rom.
Can't turn off flipper button launch adjustment. Menu section in on or off doesn't make any difference...any help out there?
Also chasing chrome apron decals mainly the stripes. Have the retro refurb t2 ones but they are really expensive.
Cheers for any help !

Not sure what your flipper button issue would be. I'm running L2 and have flipper launch set to "off" which functions correctly.

Just looked up the apron you are referring to - wow, that looks nice: https://www.retrorefurbs.com/shop/terminator-2-pinball-chrome-apron-decals/#iLightbox[product-gallery]/1

Do you know anyone who can print on chrome vinyl? If so, this might be your best option having one custom made (although not sure what that cost would be).

1 week later
#9984 16 days ago

Has anyone done a spreadsheet for the color bulbs needed for inserts, etc? Looking to update with new Comet bulbs. Any bulbs owners have used that you are happy with? Anything to avoid? Thanks.

#9987 16 days ago
Quoted from pinballjah:

Thanks! Very helpful.

FYI, since I posted this I've changed my mind about a few things. For insert bulbs I've moved to the 4 SMD no dome non-ghosting bulbs. I typically color match some inserts (natural white for clear, red for red, blue for blue, green for green, etc.) For yellow inserts I use natural white and for orange inserts I use warm white.

I also swapped flashers out with the 13 SMD versions (and changed some of the colors) as I want to be visually jolted when they fire. Not everyone likes this, so if you prefer more subtle flashing you'll want to go with something like their 8 or 5 SMD towers.

#9988 16 days ago
Quoted from pinballjah:

Has anyone done a spreadsheet for the color bulbs needed for inserts, etc? Looking to update with new Comet bulbs. Any bulbs owners have used that you are happy with? Anything to avoid? Thanks.

I'll throw mine in here as well in case it helps.

https://docs.google.com/spreadsheets/d/1JXrVWkt0pT8KE-Pao9o1GCdVKzX1lbI6SrglDpxkP5s/edit?usp=sharing

I also used Comet for all my lights. I went with non-ghosting 2SMD lights as my ROM was patched for LEDs.

I'm a fan of their Sunlight White option for GI and used their pop bumper discs (red/yellow/green) with clear caps for my bumpers.

Adding the strip lights for the GI as Mr_Tantrum has done is a clever way to light up the voids and super easy with Comet's matrix setup. I use them all the time in my JP mods.

#9989 16 days ago
Quoted from Geteos:

I'll throw mine in here as well in case it helps.
https://docs.google.com/spreadsheets/d/1JXrVWkt0pT8KE-Pao9o1GCdVKzX1lbI6SrglDpxkP5s/edit?usp=sharing
I also used Comet for all my lights. I went with non-ghosting 2SMD lights as my ROM was patched for LEDs.
I'm a fan of their Sunlight White option for GI and used their pop bumper discs (red/yellow/green) with clear caps for my bumpers.
Adding the strip lights for the GI as Mr_Tantrum has done is a clever way to light up the voids and super easy with Comet's matrix setup. I use them all the time in my JP mods.

Thanks for the details. Will experiment with a few different bulbs.

#9990 16 days ago

For those of you with Pinsound on your HS2:
I created 5 sound packages, two of which are posted for download here:
https://www.pinsound.org/pinballs/wpc-alpha-dmd/getaway/

For both:
I loaded 15 different lambo "drive by" sounds to the inlanes (because I really didn't like the beeping "car horn" sound)
I changed the "shift gears" tone to the sound of a lambo's engine winding up - needing to be shifted. The vocal cue "Shift Gears" is still present.
I filtered the police radio voices in Mr_Tantrums custom callout files so that they sound more like they are coming through a police radio (in by opinion). This was done with permission from Mr_Tantrum.
I changed the after-ball bonus multiplier sounds to different lambo engine sounds.

Music for "Outrun" is all new. Call it "up tempo" or "club" or "house" I suppose. I'm not wild about having lyrics in the music, so this fits my requirement. You won't recognize any of the music.

Music for "Speed" is also all backing tracks, except for ball capture (which is Yellow's "OH YEAH"). The rest is Billy Idol, Steve Stevens (from the movie "Speed"), Frankie Goes To Hollywood, Cheap Trick (Top Gun end credits), and even the Blue Man Group. The main theme is made up of multiple versions of "Don't Need a Gun" (but no lyrics). If you're not familiar with the song, listen to it here:

If the music does't strike you, feel free to grab all the Lamborghini "drive by" sound files.

A HUGE thank you to Mr_Tantrum for posting the instructions on how to do this, and for all the PM's and emails that he's responded to along the way. It's like I have an all-new game!

#9991 16 days ago

Hi guys, just joined the club and just found this forum today. Thanks for all of the LED ideas and mods (my wallet doesn't thank you).

One thing I am looking for that I cannot find is this Williams Speaker Panel Grill, can they be purchased? Mine looks rusty and doesn't have the Williams logo.

Dave

Capture-2 (resized).PNG
#9992 16 days ago
Quoted from daveddd14:

Hi guys, just joined the club and just found this forum today. Thanks for all of the LED ideas and mods (my wallet doesn't thank you).
One thing I am looking for that I cannot find is this Williams Speaker Panel Grill, can they be purchased? Mine looks rusty and doesn't have the Williams logo.
Dave[quoted image]

Welcome! I can't say that I've ever seen them for sale on a retail website but you can try to post a wtb in the market place and you may find a set, it's worth a shot... good luck!

#9993 16 days ago

It was suggested that I post my problem here....

The opto's are working like they should after I sat and thought about it for a while. If they did not work then they would not show up in the switch test going off and then on as I trip the circuit. Running a pinball up the ramp and around the Supercharger does give you the Supercharge points.

To clarify the problem, The magnets for the Supercharger does not work and the shifter does not work. But I can fire the ball with a flip of the bat.
And I still have the error 24 ""ALWAYS CLOSED"". what the heck is that anyways?

#9994 16 days ago
Quoted from Brewchap:

The magnets for the Supercharger does not work

Did you check F103 on the PDB? Did you check to see if the led on the accelerator board is lit?

Quoted from Brewchap:

the shifter does not work

Did you check this in switch test?

Quoted from Brewchap:

I can fire the ball with a flip of the bat.

This is a setting in the menu that you can turn off if you want to.

Quoted from Brewchap:

And I still have the error 24 ""ALWAYS CLOSED"". what the heck is that anyways?

This is not an error. It's part of the game design, they put a diode on the coin door interface board to act like a closed switch. If the game doesn't see this switch closed it will think that the 12 volt fuse is burnt and give you a F114/F115 fuse alert.

#9995 15 days ago
Quoted from EStroh:

For those of you with Pinsound on your HS2:
I created 5 sound packages, two of which are posted for download here:
https://www.pinsound.org/pinballs/wpc-alpha-dmd/getaway/
For both:
I loaded 15 different lambo "drive by" sounds to the inlanes (because I really didn't like the beeping "car horn" sound)
I changed the "shift gears" tone to the sound of a lambo's engine winding up - needing to be shifted. The vocal cue "Shift Gears" is still present.
I filtered the police radio voices in Mr_Tantrums custom callout files so that they sound more like they are coming through a police radio (in by opinion). This was done with permission from Mr_Tantrum.
I changed the after-ball bonus multiplier sounds to different lambo engine sounds.
Music for "Outrun" is all new. Call it "up tempo" or "club" or "house" I suppose. I'm not wild about having lyrics in the music, so this fits my requirement. You won't recognize any of the music.
Music for "Speed" is also all backing tracks, except for ball capture (which is Yellow's "OH YEAH"). The rest is Billy Idol, Steve Stevens (from the movie "Speed"), Frankie Goes To Hollywood, Cheap Trick (Top Gun end credits), and even the Blue Man Group. The main theme is made up of multiple versions of "Don't Need a Gun" (but no lyrics). If you're not familiar with the song, listen to it here:
If the music does't strike you, feel free to grab all the Lamborghini "drive by" sound files.
A HUGE thank you to Mr_Tantrum for posting the instructions on how to do this, and for all the PM's and emails that he's responded to along the way. It's like I have an all-new game!

I can hardly wait to get home after the holiday to check this out.

#9996 15 days ago
Quoted from GRUMPY:

Did you check F103 on the PDB? Did you check to see if the led on the accelerator board is lit?

I'm not sure what you mean by PBD so no I did not check the fuse. If the accelerator board is on the bottom left on the back of the playfield, then yes there is a light on.

Quoted from GRUMPY:

Quoted from Brewchap:

the shifter does not work

Did you check this in switch test?

Yes. I checked in the test menu under all three switch test and it did not register.

This was a working game, until I pulled the playfield apart to clean and wax.

I should also add that I have a Slam Tilt error, that I bypassed by disconnecting the wire

#9997 15 days ago

Just checked the Power Driver Board and the F104 fuse was good.

Also so wanted to point out that that everything in column 3 is out

#9998 15 days ago
Quoted from Brewchap:

Also so wanted to point out that that everything in column 3 is out

You may have broke a wire at one of the top red or middle red stand up targets when working on the game which would disable the rest of the switches down the line. Check the green/orange wires on these switches, there needs to be two wires on each switch. Make sure you have continuity on this wire back to the connector J-206 pin 3 of the CPU board. If this is good you may have popped U-20 on the CPU board. But check this first.

#9999 15 days ago

Ok just tested this and it tone out. Bad news, I found J206 connector installed at 207 pins, so I'm sure that I popped U20. That makes sense since I pulled J206 when I was trying to find the problem with the Supercharger and my shifter problem started right after that.

#10000 15 days ago
Quoted from Brewchap:

Ok just tested this and it tone out. Bad news, I found J206 connector installed at 207 pins, so I'm sure that I popped U20. That makes sense since I pulled J206 when I was trying to find the problem with the Supercharger and my shifter problem started right after that.

206/207 no difference on the board. But I still think you popped U-20.

Promoted items from the Pinside Marketplace
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 16.00
From: $ 233.10
Wanted
Machine - Wanted
Fort Lauderdale, FL
5,500 (OBO)
Machine - For Sale
Lynbrook, NY
There are 10060 posts in this topic. You are on page 200 of 202.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside