(Topic ID: 234372)

Genesis won’t start multiball


By tandem2

7 months ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 9 days ago by pb456
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

IMG_20190812_210241624 (resized).jpg
IMG_20190812_210634050 (resized).jpg

#1 7 months ago

I’m having an issue with my Genesis game, with the ARMS (left) kickout hole. When I make the shot to collect each A-R-M-S letter, the kickout hole works fine. But after the letters are collected, and the ball is trapped for multiball, the kickout hole won’t release the ball when it’s time for multiball. Any ideas on what might be causing this?

Thanks,
Jody

6 months later
#2 11 days ago

Any success with this?

tandem2

I'm wondering if your Genesis and mine share the same problem, I was having difficulty (which I thought I corrected) with one of the ball trough switches, where it wouldn't kick out a ball after the ball drained. Now, everything else works, but once I make one of the ramp shots, and it's the last letter (ARMS, LEGS) - where the 'lightning' effect across the back of the playfield runs.... No ball kick out from either the ramp or the shooter lane.

Is this the same issue as you're having? Did you get it resolved?

#3 11 days ago

Check for dents in the ball guide rail in the trough and get rid of them with a file.

#4 11 days ago

I just started to have the same issue with my Genesis.

Quoted from MarAlb:

Check for dents in the ball guide rail in the trough and get rid of them with a file.

I checked for dents, but nothing. Anyone know what else could be the problem?

#5 9 days ago

I examined the trough for dents/burrs and found a very small dent, but wasn't stopping the ball from rolling.

I can see how it gets created as the solenoid that opens the trough can possibly push a ball back into the trough with some force.

My problem was that the second switch, with wireform, that is normally open, was completely closed. Took several tries, but I finally got it adjusted after I took it apart, bent the metal "bar" or restrictor or... (what is that part called????) and adjusted the bottom leaf so that it was once again normally open.

The pictures should be easier to understand.

IMG_20190812_210241624 (resized).jpgIMG_20190812_210634050 (resized).jpg
Promoted items from the Pinside Marketplace
$ 14.99
Electronics
PinballElectronics.com
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
€ 8.40
$ 299.00
Displays
Boston Pinball Company
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 29.99
Playfield - Toys/Add-ons
Full Tilt Pinball LEDs
$ 45.99
$ 120.75
Cabinet - Sound/Speakers
PinWoofer
From: $ 218.00
From: $ 35.00
Boards
PCB Emporium
$ 199.00
Lighting - Interactive
Medisinyl Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 1,099.00
Flipper Parts
Mircoplayfields
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside