(Topic ID: 300099)

Genesis fixed but Genesis figure is always revealed.

By NickyVanHalen

18 days ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 12 days ago by NickyVanHalen
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

system20 (resized).jpg

#1 18 days ago

Gottlieb Genesis Fixing for a friend, he has installed new mother board and power supply board and done some ground mods. When I first got machine it allowed me to play 11 or 12 games shutting down during 3 of them. The more it's played the faster it shuts down to the point you can't get through 1 ball. I'm an EM guy looking for any direction or help where to look next.

#3 18 days ago

You suggest repinning connectors? Or would you replace harnesses if available.

#4 17 days ago
Quoted from NickyVanHalen:

You suggest repinning connectors?

Yes.

The wiring harness itself is probably fine. The connector pins can sometimes be worn out and dirty. Although, I found that to be more of a serious issue on system 1 gottlieb games than system 80 games. Still, it's worthwhile to do a visual inspection of the pins.

However, before you go through the trouble of repinning, what I always do is clean all the edge connectors on the boards. Rub all the edge connector pads with a pink rubber eraser to remove grime and tarnish. Others have suggested sandpaper or fiberglass erasers, but I always recommend the pink rubber eraser since that is the least destructive approach that also does a very good job with cleaning.

#5 17 days ago

Thank you. Sounds like good place to start. I ll try that tomorrow and see where that gets me. Appreciate the help.

#6 17 days ago

I would try and replace/rebuild the interconnect.... they are always jacked.

system20 (resized).jpg
#7 12 days ago

UPDATE found broken diode on coil, another coil had been replaced w coil w no diode (should have had 1) and a bridge rectifier w loose bad solder. Game is now working except the Genesis figure that should be revealed when u earn it is always revealed I get the light show and change of music. I'm sure the cannister? Should be covering it then rotate open to reveal. I can't get past memory in test mode (is this because of new board?) Not sure how to get that final part working.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside