(Topic ID: 71772)

Game Plan owners club. Welcome!


By SpOoKyRiDeS

6 years ago



Topic Stats

  • 434 posts
  • 87 Pinsiders participating
  • Latest reply 19 days ago by frunch
  • Topic is favorited by 36 Pinsiders

You

Linked Games

Topic Gallery

There have been 95 images uploaded to this topic. (View topic image gallery).

IMG_20200716_190218.jpg
SharpShooter Drop Target (resized).jpg
IMG_2683 (resized).JPG
IMG_2727 (resized).JPG
IMG_0659 (resized).JPG
IMG_20191118_095953.jpg
AD1B2DB7-EF08-46AA-A0CB-18285E897188 (resized).jpeg
EFDDE5DC-14E1-41D1-828F-CB501543A168 (resized).jpeg
389D7190-098A-42C5-A70F-26A2F4008A4E (resized).jpeg
474A759C-1DA2-4860-9EA7-81007E817AB0 (resized).jpeg
B8D4B5E7-F652-42EA-A94C-30CAB603D852 (resized).jpeg
1579DFC8-4879-4040-AE43-9B30605249AB (resized).jpeg
3160EAEA-30EC-4834-95B7-2E826ED6C0DE (resized).jpeg
DC48CA88-1ED5-4FEB-9EE5-DAAC3BBAED53 (resized).jpeg
IMG_8900 (resized).jpg
Sharp Shooter - Power Supply (resized).jpg

There are 434 posts in this topic. You are on page 7 of 9.
#301 1 year ago

Hi, I found an original Attila the Hun Parts Catalog, 2 Field Service Bulletins, and pages explainging the game options and accounting functions.

If you would like these, I would be happy to mail them to you for $5 to cover the large envelope & postage.

Send me a pm with your name & mailing address and I will reply with my paypal email address. Thanks! Jim

IMG_20190128_192606 (resized).jpg
#302 1 year ago

I finished up Sharp Shooter II this afternoon and got some solid game playing time in!

First the display issues: With them all pulled out I tested the transistors on all 5 display boards and they all tested good. Moved on to the 74LS379's and compared some readings to the working Old Coney Island displays and they were different, so I gave it a shot and replaced the 74LS379 on one of them and everything was working perfect in game and test mode. I ended up replacing that same chip on all 5 displays (adding a socket obviously) to fix all 5 of the faulty displays. I've got no idea what happened to this thing before I had it that would have taken out that chip on all 5 displays, but its all good now!

Here is the break down on the display issues in case someone has something similar happening:

Player 1 display - all digits out and shows nothing, replaced 74LS379
Player 2 display - all digits out and caused mpu to not boot fully, replaced 74LS379
Player 3 display - only showed 1's on all digits all the time, replaced 74LS379
Player 4 display - only showed 4's on all digits all the time, replaced 74LS379
ball/credit display - only showed 0's on all digits all the time, replaced 74LS379

After installing a new ball, rubbers, lights, doing some switch cleaning and adjustments, and cleaning up the drop target bank so it resets properly, we are good to go!

Another project done..... on to the next.

3 weeks later
#303 1 year ago

Where is the cheapest place to get the 11000uf caps for the power supply? I checked a few places and they were around $30 for the screw terminal style. Also, is there any reason you can't splice on a radial lead variety? They appear to be much cheaper.

1 week later
#305 1 year ago

I thought you all might get a kick out of this. Here's an original invoice direct from Gameplan when my family's former Hi-Fi business bought parts for it back in 1987. That battery also was likely the same one that exploded causing me to buy an Echo Lake MPU about 20 years later.

IMG_1281 (resized).JPG

#306 1 year ago

8$ part causes $300 damage. Gotta love it.

#307 1 year ago

Archived after 21 days
476 views
Sold (amount private)
Contributed to Pinside
Machine - For Sale
Fully shopped/refurbished “Fully working gameplan cocktail pinball. This has an Echo Lake replacement MPU (these are no longer being produced but work in any gameplan machine). No issues that I can think of ...”
2019-04-16
Oakland, CA
800 (OBO)

Starting high because of Echo Lake board.

#308 1 year ago

1.200 dollars in California dollars converts to like 650 in Chicago dollars...yep, checks out. Glws!

#309 1 year ago

GLWTS !! Nice to see these Game Plans on Pinside-- One here 95% rebuilt with new board as well.

#310 1 year ago

Hi All -

I want to purchase some colored star posts for my Andromeda. Can someone link me the correct post/size? In the parts catalog, it doesn't specify what type of posts they are. Would the Titan colored posts work? Thanks in advance.

3 weeks later
#311 1 year ago

Proud owner of a nice Lizard that I just got working. Does anyone have a link to the rule set?

Thanks

2 weeks later
#312 1 year ago

Does anyone sell new spinners that are Game Plan compatible? I ordered replacements from PBR and the arms are bent in the wrong place. Yes, I went through the lots trouble making those replacement spinners for my Cyclopes and didn't pay attention to fitment first...I tried bending the arms flat and forming them to the right curvature. That resulted in breaking the arm.

#313 1 year ago

Anyone have some Cyclopes pop bumper caps for sale? Need one but would buy more for backups. Thanks!

#314 1 year ago
Quoted from crank:

Anyone have some Cyclopes pop bumper caps for sale? Need one but would buy more for backups. Thanks!

I don't. However, I got plain caps from Pinball Resource and made some. I found a pretty close paint match, off the shelf. I printed out new decals which can be found here- https://www.ipdb.org/files/619/Game_Plan_1985_Cyclopes_Bumper_Cap_Scans.jpg

#315 1 year ago

Good idea Clytor, thanks!

2 weeks later
#316 1 year ago

I figured I should make a note in this thread as well since I posted it in the Pinfest thread already. Cyclopes is almost ready to go to a new loving home.

42282C73-EF1C-4BF4-B206-1701C6F60F9E (resized).jpeg
#317 1 year ago
Quoted from Clytor:

I figured I should make a note in this thread as well since I posted it in the Pinfest thread already. Cyclopes is almost ready to go to a new loving home.
[quoted image]

looking good!

how much?

(and yes, you will regret this )

#318 1 year ago
Quoted from Whysnow:

looking good!
how much?
(and yes, you will regret this )

I hope not but it's sold and sounds like it's going to a good home. While not as rare, Radical was my grail and got one. I'm good for the moment.

#319 1 year ago
Quoted from Clytor:

I hope not but it's sold and sounds like it's going to a good home. While not as rare, Radical was my grail and got one. I'm good for the moment.

congrats.

Radical is a great game also!

#320 1 year ago

Just joined the club with a project Sharpshooter II. Back glass is really nice, playfield looks like it has little to no wear but very dirty. Cabinet is pretty good and stencils are available from Jeff at Pinball Pimp. Almost all the fuses were way over rated so I replaced them with proper values before I tried to boot it up. Good news! Got 6 flashes, coined it up and so far after a quick look the only problems I see are 4 switches not working and multiple bulbs either broken or burned out.

The sounds all work good but there is a pretty bad hum, buzz, static coming from the speaker. Turning up the pot doesn't seem to make the noise louder and the noise seems to fluctuate with the attract lights and the displays going on and off. Any ideas how to remedy this?

Both flippers are really messed up and made up with a mixed bunch of parts. Probably need to update with with complete new assemblies. Any recommendations?

I could use a parts manual and/or rubber size and location. I could buy a kit but some of them I want to double up like the drop target bank to hopefully prevent breakage of the drop targets.

All of the plastics are badly warped. I've had good luck in the past flattening them but the plastic in the upper left corner is broken in half so I'll be looking for one of those. Maybe someone here has one?

I'm sure there will be more as I dig in a little deeper.

#321 1 year ago

For the sound issue I would check the connectors. Those connector pins can get easily corroded. I had an issue with my Old Coney Island where at power up it was a loud hum and distorted sound, but as the game played it would seem to "warm up". After cleaning connectors on the sound board I checked the proper connector in the harness and sure enough, if you wiggled it the distortion would come back right away. I swapped out every pin in that connector as they had some corrosion on them and now it's been solid ever since.

If all of your switches that don't work are in the same row/column it may end up being one of the diodes that is also associated with a dip switch. I had this issue with my Old Coney Island as well. Changed a little diode and they all worked again. Someone here on the forum helped out with that. You'd probably need the schematics to figure out if they were all linked together.

Quoted from mstire:

Just joined the club with a project Sharpshooter II. Back glass is really nice, playfield looks like it has little to no wear but very dirty. Cabinet is pretty good and stencils are available from Jeff at Pinball Pimp. Almost all the fuses were way over rated so I replaced them with proper values before I tried to boot it up. Good news! Got 6 flashes, coined it up and so far after a quick look the only problems I see are 4 switches not working and multiple bulbs either broken or burned out.
The sounds all work good but there is a pretty bad hum, buzz, static coming from the speaker. Turning up the pot doesn't seem to make the noise louder and the noise seems to fluctuate with the attract lights and the displays going on and off. Any ideas how to remedy this?
Both flippers are really messed up and made up with a mixed bunch of parts. Probably need to update with with complete new assemblies. Any recommendations?
I could use a parts manual and/or rubber size and location. I could buy a kit but some of them I want to double up like the drop target bank to hopefully prevent breakage of the drop targets.
All of the plastics are badly warped. I've had good luck in the past flattening them but the plastic in the upper left corner is broken in half so I'll be looking for one of those. Maybe someone here has one?
I'm sure there will be more as I dig in a little deeper.

#322 1 year ago

Thanks Pin-up.
I had all the boards out to look them over closely and all the header pins are surprisingly clean. Mpu had the original battery but luckily zero corrosion.

I'll double check all of the connectors and see what I can find.

As for the switches, there's actually 8 that don't work. I believe they are the 10 point ones. All have the same color wires going to them. I found them on the play field schematic but not sure what controls them on the which PCB. I'm not too good at understanding schematics.

There is a cracked SCR on the LDU board (#38) that might be suspect. Can these be tested in circuit?

3 weeks later
#323 1 year ago

I posted this already in tech but getting no responses so thought i'd ask here too. I have a Star Trip I got mostly running this week. I have two final issues I'm trying to resolve. 1. Spinner rollover switch detect fine in test mode but will not work in game play. 2. When ball one drains the ball count doesn't step up to ball 2, after you drain what is ball 2 will it then step up to ball 2 and count the balls correctly. So your getting an extra ball in either 3/5 ball setting. Non battery damaged MPU-2, replaced the ceramic caps on mpu and all electrolytic caps in the game, have not replaced header pins yet on mpu. Any thoughts to either issue? Thanks

#324 1 year ago

Is the extra ball value set really low? It might default to a low value, not sure.

Not sure what to suggest as far as that spinner though...

#325 1 year ago
Quoted from frunch:

Is the extra ball value set really low? It might default to a low value, not sure.
Not sure what to suggest as far as that spinner though...

Good thought, when I put the remote battery pack on, I reset all accounting and settings to get rid of the gargled displays. But never went back and actually set any values for the different settings. Will do that and see what happens.

#326 1 year ago
Quoted from frunch:

Is the extra ball value set really low? It might default to a low value, not sure.
Not sure what to suggest as far as that spinner though...

You were spot on, set values for the 3 scores levels to beat and now that part is working correctly. But now my game over light won't turn off

#327 1 year ago
Quoted from cjs001:

You were spot on, set values for the 3 scores levels to beat and now that part is working correctly. But now my game over light won't turn off

Maybe a locked-on transistor/scr for the game over light?

#328 1 year ago
Quoted from frunch:

Maybe a locked-on transistor/scr for the game over light?

That's what I thought too, replaced the associated MCR106 with no change, grounded the gate of the Game Over MCR the lamp does turn off. Replaced Decoder and no cigar. Made sure all bulbs were functioning then went into lamp test. Found 1000 when lite lamp not lighting at all and its another MCR106 which goes through a buffer chip along with Game over light before the decoder so wondering if the buffer chip is faulty. If I ground the anode for the "1000 when lit lamp" it does light so not a wiring issue to that bulb. That MCR with DMM gives appropriate values. Don't have 4050 buffer chip on hand so will need to order a couple.

#329 1 year ago

Determined that the spinner rollover switch that I thought didn't work may actually be fine. When you roll over the switch its suppose to turn on the lamp for the spinner "1000 point when lit" insert. That bulb is always off so once I resolve that issue it may be good to go.

#330 1 year ago

Ended up being a faulty 4050 buffer chip on the lamp board. Replaced and its working now.

#331 1 year ago

Good stuff, congrats on the fix! How do you like the game?

#332 1 year ago

Anyone have a Captain hook? I need some pictures taken on some of the wiring to figure out this mess I have.

3 weeks later
#333 1 year ago

Ive got a supernova that need's a cabinet, I've got everything but. I was wondering if any of you had blueprints of gameplan cabinets so I can build one accurately. Or if one of you would be kind enough to take mesurments so I can build one.. Thank you in advance...

1 week later
#334 1 year ago

...Bump...

I’d really love to bring this game back to life! Any help on the cabinet dimensions would be great..

4 weeks later
#335 1 year ago

Anyone know what coil to order for the kick out coil on a Sharpshooter II. The kicker is weak. I replaced the sleeve, but it is still struggling. My coil doesn't have a number on it and I can't find one in the manual.

thanks,
Aaron

Edit - Never mind. Found a parts guide for Andromeda on IPDB. part number is 21-50005b and it is available on Marco.

https://www.marcospecialties.com/control/keywordsearch?SEARCH_STRING=21-50005b

3 weeks later
#336 11 months ago

Finishing up my Sharpshooter 2 restore and need to find these two plastics. Especially the broken one.
The large one goes in the top left corner, the other goes directly behind the drop target bank.

IMG_0591 (resized).jpg
#338 11 months ago

New to the club. First Game Plan machine for me. It’s a Sharp Shooter. Question - she’s not booting up. The fuse under the playfield blows immediately. Seems all coils fire at once and then the fuse blows. Not getting any flashes on the mpu Any tips or ideas to look for ?

#339 11 months ago
Quoted from Nikrox2:

New to the club. First Game Plan machine for me. It’s a Sharp Shooter. Question - she’s not booting up. The fuse under the playfield blows immediately. Seems all coils fire at once and then the fuse blows. Not getting any flashes on the mpu Any tips or ideas to look for ?

I'd suggest start by unhooking most connectors. Start putting them back one at a time (GI first?) and trying to boot. Eventually you'll have a starting point.

#340 11 months ago

Thanks. Just pulled each connector on the mpu and no change. Pulled J3 on the SDB and it does stop the fuse blowing (I have a circuit breaker set up with gator clips to save on the fuses while I trouble shoot) but still no flashes - but does that help me identify the fuse blowing issue? And could that issue cause it to still not boot up? (Not getting a flicker)

#341 11 months ago

Oh wait. I pulled one at a time. Should I try putting one at a time on then adding another? And is this on the mpu ? Sorry for all the questions

#342 11 months ago

And I am getting gi and back box lights / flashers. No displays what so ever

#343 11 months ago

Some screeching sounds (almost as bad as a Nugent I had previously until a friend rebuilt the sound board). So it too may have issues. Ugh

#344 11 months ago

The connectors between the backbox, playfield, sound board, and cabinet will need to be replaced if they haven't already been. Lots of connectors to replace, but i found that to be essential in getting my sharpshooter working properly. What voltages are you measuring at the test points on the power supply board?

#345 11 months ago

Looks like someone has already replaced the connectors and removed the battery (and some previous corrosion).
Possible a chip on the driver board causing all coils to fire at once? Pops, target bank, etc? Thinking what ever issue that is - is also causing it not to boot up? Could be separate issues tho?

#346 11 months ago

Here's an exhaustive guide to Game Plan repairs, came in very handy when i was fixing up my Sharpshooter.

http://www.pinrepair.com/gp/

I'd definitely start by verifying you have good voltages at the power supply. Section 2a lists the test points and voltages you should look for at them.

#347 11 months ago

Thank you! I’ll check those this evening and report back in my findings

#348 11 months ago

Ok, first - that link has amazing info! Had similar to the Bally/Williams, so this was a big, big help- Thank you!

Second - readings on the Power supply is as follows:
TP1- 12.82 (good)
TP2 - 4.94 (good)
TP3- 6.37 (good)
TP4- 4.95 (bad?? Should read 24V shouldn't it? (from what I can understand anyhow..lol, remember I'm still a "newbie" I did check the fuse, still nuttin above 4.95 -

So - from the link above, since the MPU is not receiving the 24v, that could be causing it not to boot (so now I need to find the issue with the power supply??)

But, in reading the link, on the MPU - the reset circuit may also be an issue (it reads if this is not working, it will not boot) - and although someone did replace the rechargeable battery and did some corrosion cleanup, it looks like it did migrate into the bottom left corner (reset circuit area) - so this could also be an issue.

When the game is powered on, and the J3 connector is disconnected from the SDB and although the MPU isn't "booting up" - I can just touch the J3 connector - and the coils all fire at once (pop bumpers, bonus hole, target bank) - so from further reading, I could have issues also on the SDB...ugh

#349 11 months ago

I have to admit my knowledge is limited, as my mpu was working when i bought my game (though it had other issues).

I would definitely keep going on the direction you're heading though, if the game doesn't boot up properly, it may be holding the blanking signal low which may result in all the coils firing (i had a similar experience with my Black Knight a while back, though this may or may not apply to this case)...

That said, you definitely want to get your 24vdc working properly or it won't boot anyway. I'd focus on that first. Check the 24vdc bridge rectifier on the power supply with your meter, shown in the image below:

Screenshot_20190904_085859_org.mozilla.firefox(1).jpg
#350 11 months ago

Yes, get your voltages right to start with (That bridge). Do you have a service manual?

Promoted items from the Pinside Marketplace
$ 16.50
Wanted
Machine - Wanted
Fort Worth, TX
650 (OBO)
Machine - For Sale
Brooklyn, MI
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 40.00
Lighting - Interactive
Professor Pinball
1,500
Machine - For Sale
Denver, CO
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
750
Machine - For Sale
Ann Arbor, MI
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
£ 59.00
Playfield - Other
PinballToys
$ 20.90
Apparel - Unisex
Pinball Haus
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 8.95
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 92.95
Cabinet - Shooter Rods
Super Skill Shot Shop
There are 434 posts in this topic. You are on page 7 of 9.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside