(Topic ID: 179020)

Funhouse switch issues

By dzrossi

4 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 4 years ago by dzrossi
  • No one calls this topic a favorite

You

Linked Games

#1 4 years ago

Funhouse was not acting correctly so I decided to test switches. Quick multi ball is not working and I believe some sounds are not. In switch test mode. All switchs worked except Trapdoor sw45 registered as Steps supper dog sw55. When I unplug the Steps Supper Dog from the opt board on bottom of playfield trapdoor switch shows correctly. Very strange all other switches work correctly. Supper dog and trapdoor are in same row 5. Trapdoor column 4 and Supper dog column 5. I would think if opt board was the issue more switches would be effected. Funny thing is when I play game trap door shot does register correctly. Looking for ideas and thoughts. Reading some blogs I believe the LM339 chips on opt boards need to be replaced at times but not convinced this is the issue.

#2 4 years ago

Quick multiball not working won't be a switch issue, the mirror shot for Quick M-ball is the same switch for all the other mirror awards. Were you working on something on it before this happened? Pick up the pf and look at the trapdoor switch wires and compare the color code to the schematics. Same thing for Super dog switch.

#3 4 years ago

Thanks for advise. After comparing switch to others the white wires we soldered to the wrong side of the diode. After I fixed the switch register correctly.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside