Full Throttle Club - Enjoy the Adrenaline

(Topic ID: 144336)

Full Throttle Club - Enjoy the Adrenaline


By PinballRulez

3 years ago



Topic Stats

  • 713 posts
  • 85 Pinsiders participating
  • Latest reply 3 months ago by BertoDRINK1
  • Topic is favorited by 21 Pinsiders

You

Linked Games

Topic Gallery

There have been 160 images uploaded to this topic. (View topic image gallery).

20181205_163758 (resized).jpg
20181205_163019 (resized).jpg
20181205_163806 (resized).jpg
20181205_163004 (resized).jpg
ft14 (1).jpg
DSC_0023 (resized).JPG
DSC_0027 (resized).JPG
DSC_0019 (resized).JPG
7645F636-57B3-4CCC-8B18-089122213632 (resized).jpeg
07375C57-7834-4184-BE77-5A20157F2538 (resized).jpeg
DD030FCF-6478-4C08-82D8-84CEC16118C9 (resized).jpeg
86CABF7C-ECA7-4497-A5C4-A17413A10FE3 (resized).jpeg
A61F524E-EEB1-43EB-B443-D973CDA81650 (resized).jpeg
20180213_150227 (resized).jpg
20180210_215225 (resized).jpg
20180210_213634 (resized).jpg

There are 713 posts in this topic. You are on page 15 of 15.
#701 10 months ago

Well didn't manage to get our game fixed before Helmet left... Fuses keep blowing on new io-boards. Gone back to old io boards (old Software - and can't be updated on these) the game no longer blows fuse. Anyone have any idea what this could mean? Helmut had tested and installed latest software on the new IO boards, before sending out.

Even on the old boards and SW, the first ball of every game won't be shot onto playfield via shooter lane coil. Game has to manually do it after going through checks.

Anyone know what could be causing this - the shooter lane coil definitely works - ball 2 and 3 works 100% of the time, just ball 1 has the problem. It's like it almost seems to forget to eject once the launch button is pressed.

We're obviously quite a bit more worried now Helmut has left and can see us never getting FT working properly and updated to latest ver. any help is appreciated.

#702 10 months ago

Nobody knows. We can guess, but you really need to take it up with Heighway support. I would imagine they are in the process of hiring a new support person, but there has to be someone else to help in the meantime from the company. email/call don't let it sit.

Quoted from take2-take5:

Well didn't manage to get our game fixed before Helmet left... Fuses keep blowing on new io-boards. Gone back to old io boards (old Software - and can't be updated on these) the game no longer blows fuse. Anyone have any idea what this could mean? Helmut had tested and installed latest software on the new IO boards, before sending out.
Even on the old boards and SW, the first ball of every game won't be shot onto playfield via shooter lane coil. Game has to manually do it after going through checks.
Anyone know what could be causing this - the shooter lane coil definitely works - ball 2 and 3 works 100% of the time, just ball 1 has the problem. It's like it almost seems to forget to eject once the launch button is pressed.
We're obviously quite a bit more worried now Helmut has left and can see us never getting FT working properly and updated to latest ver. any help is appreciated.

#703 10 months ago
Quoted from luvthatapex2:

Nobody knows. We can guess, but you really need to take it up with Heighway support. I would imagine they are in the process of hiring a new support person, but there has to be someone else to help in the meantime from the company. email/call don't let it sit.

Yeah we was getting somewhere with Helmut but then it stopped and then the confirmation he's left. Have been emailing since hopefully we'll get a reply, will have to try giving them a ring tommorow.

3 weeks later
#704 10 months ago

Hey guys, not sure where the best place to get eyes on this is, but i just posted here with a couple of issues....

https://pinside.com/pinball/forum/topic/heighway-pinball-support-full-throttle-and-alien/page/8#post-4402495

any assistance/thoughts are appreciated...

4 months later
#705 6 months ago

Just installed titan red comp. rubber on my full throttle, looks great and shoots even smoother than before if you can believe it

ft14 (1).jpg
#706 5 months ago
Quoted from Join_The_Cirqus:

Finally had a Custom Topper made

[quoted image][quoted image][quoted image][quoted image][quoted image]

Very nice, where did you have this done?

2 months later
#707 3 months ago

Having owned both Alien and Full Throttle i much preferred FT as a game! Alien haz the looks, but FT just played great and the rules (at least the multiball stacking) are great. Shame that it didn't work out differently and more weren't produced!

#708 3 months ago

Agreed had them side by side for almost a year, I always tell people Alien got the better theme and great atmosphere, but Full Throttle got much better gameplay and rules! And I like the bike theme and being taunted (reminds me of Rudy on Funhouse) as I play anyways

#709 3 months ago

Hey guys I got FT on trade a few months and ha e really been enjoying it. I put it up for trade but again but the more I play it the more I like it.
I haven't had any issues after setting it up. When we first set it up a couple switches were not registering one would actually register almost as soon as you started a ball so it would not give you a chance to do the skill shot. Ended up not being a big deal just had to locate them and reseat them and no problems since besides for an occasional lcd cable also needing to be reseated.
I was thinking about ordering a new longer cable for the back box lcd it seems to be loose at the MPU and doesn't have enough slack for any movement.

Any thing you guys recommend to help the life of this machine? Any parts I should try and stash also? I see there is someone reproducing the I/O board so that's good.
Is there a source for the switches themselves? Are the switches know to be going bad and is there a source for them?
Someone has Alien LEDs listed in the market they look excellent as the one in FT was wondering if those would work and if I should grab a few, I messaged them but haven't heard back yet didn't know if they just wouldn't work.
Is the power supply an issue should I try a find one as a spare?
Thanks for any advice if this machine stays in my collection longer i don't think it would be a problem because it is very fun.

20181205_163004 (resized).jpg20181205_163758 (resized).jpg20181205_163806 (resized).jpg20181205_163019 (resized).jpg
#710 3 months ago

The LEDs are the same as those one, so Id grab some so you have some on had if needed. He mentioned he is also making inductive switches sometime soon so grab some of those once available! The power supply monitors etc I believe can be found on digikey but I wouldn't worry about that. I grabbed a spare I/O board which you can find on here as well just in case down the line I need one.

#712 3 months ago

Lot of good parts there, thanks for the link! Id have to say look in the Alien section as well, lots of the parts are for Full Throttle too, just not organized that way.

#713 3 months ago

Thanks for the links and advice, definitely going to grab a few parts to have for spare.

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 45.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 50.00
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 10.00
Playfield - Decals
Metal-Mods
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 19.50
Apparel - Unisex
ArcadeMade
$ 22.00
Electronics
Yorktown Parts and Equip
$ 47.00
$ 25.00
Playfield - Decals
Flashinstinct
From: $ 375.00
Gameroom - Decorations
Gameroom Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 18.00
Cabinet - Other
Pin Monk
There are 713 posts in this topic. You are on page 15 of 15.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside