(Topic ID: 144336)

Full Throttle Club - Enjoy the Adrenaline


By PinballRulez

3 years ago



Topic Stats

  • 713 posts
  • 85 Pinsiders participating
  • Latest reply 8 months ago by BertoDRINK1
  • Topic is favorited by 22 Pinsiders

You

Linked Games

Topic Gallery

There have been 160 images uploaded to this topic. (View topic image gallery).

20181205_163758 (resized).jpg
20181205_163019 (resized).jpg
20181205_163806 (resized).jpg
20181205_163004 (resized).jpg
ft14 (1).jpg
DSC_0023 (resized).JPG
DSC_0027 (resized).JPG
DSC_0019 (resized).JPG
7645F636-57B3-4CCC-8B18-089122213632 (resized).jpeg
07375C57-7834-4184-BE77-5A20157F2538 (resized).jpeg
DD030FCF-6478-4C08-82D8-84CEC16118C9 (resized).jpeg
86CABF7C-ECA7-4497-A5C4-A17413A10FE3 (resized).jpeg
A61F524E-EEB1-43EB-B443-D973CDA81650 (resized).jpeg
20180213_150227 (resized).jpg
20180210_215225 (resized).jpg
20180210_213634 (resized).jpg

There are 713 posts in this topic. You are on page 10 of 15.
#451 3 years ago

What does Full Throttle weigh? I haven't seen it mentioned in the threads or on the website. Thanks!

#452 3 years ago
Quoted from txstargazer3:

What does Full Throttle weigh? I haven't seen it mentioned in the threads or on the website. Thanks!

I moved one this weekend. Seemed like any other to me.

#453 3 years ago
Quoted from woody76:

I moved one this weekend. Seemed like any other to me.

same as anything...plus the head comes off

#454 3 years ago

Thanks, good to know it is not a heavyweight like Hobbit. I have to get it into the 8th floor of a high rise. Yes, there is a freight elevator.

#455 3 years ago

Just joined the club last night! Having a high pitch background sqeal coming from the speakers - anyone else run into that?

#456 3 years ago
Quoted from e4mafia:

Just joined the club last night! Having a high pitch background sqeal coming from the speakers - anyone else run into that?

I think I read on another thread that this can be remedied by turning down the amplifier power and turning up the volume to compensate.

#457 3 years ago

e4mafia - there is a service bulletin explaining how to remove the speaker wiring from the main loom and twist the speaker wiring and re-connect.
I simply replaced, and re-routed the wiring with some balanced shielded mic cable I had left on a reel for the run from the amp to backbox speakers and the sub.
This, plus increasing the signal level to the amp, and in turn using less gain on the amp, has made the hiss barely audible even in a quiet room.

#458 3 years ago
Quoted from e4mafia:

Just joined the club last night! Having a high pitch background sqeal coming from the speakers - anyone else run into that?

In this thread a lot of info is already available. Here are the links

Speaker - Low Hum noise
https://pinside.com/pinball/forum/topic/full-throttle-club-enjoy-the-adrenaline/page/7#post-3173964

Speaker - High Pitch noise
https://pinside.com/pinball/forum/topic/full-throttle-club-enjoy-the-adrenaline/page/7#post-3175096

#459 3 years ago

mine came today ! the box with the usb was bouncing around in the cabinet and had no wires hooked up to it , otherwise it was all good !

#460 3 years ago
Quoted from freezie:

mine came today ! the box with the usb was bouncing around in the cabinet and had no wires hooked up to it , otherwise it was all good !

Congrats. Let us know what you find of this great pin

#461 3 years ago

Melissa just told me that my Full Throttle LE will be #215. My wife's birthday is February 15th; I should get some bonus points at home for that! It should arrive in about three weeks.

#462 3 years ago

Loving it already ! I still have some small tweaking to do for smoother flow , minor detail . Anyone have a problem with a wicked airball at the left ramp entrance ? Quite often a fast hard shot will air up and land by the motorcycle and get caught up .

#463 3 years ago
Quoted from freezie:

Loving it already ! I still have some small tweaking to do for smoother flow , minor detail . Anyone have a problem with a wicked airball at the left ramp entrance ? Quite often a fast hard shot will air up and land by the motorcycle and get caught up .

No. But I'll bet $ it's the spinning wheel in the playfield. Make sure it's setting perfectly flush.
Keep tweaking the ball guides, once you get them just right, it will play crazy fast!

#464 3 years ago

I definitely have to get those wheels flush , and the guides needs slight tweaking , nothing major. Beauty pin!

#465 3 years ago
Quoted from Zampinator:

No. But I'll bet $ it's the spinning wheel in the playfield. Make sure it's setting perfectly flush.
Keep tweaking the ball guides, once you get them just right, it will play crazy fast!

This. Getting the wheels perfectly flush is not the easiest thing to do though you'd think it would be.

Even so that left ramp is not a really easy shot.

#466 3 years ago

A few mods to share:

Replaced the stock bike with a proper MotoGP bike. Shortened the spring a bit an attached it to the bottom of the hinged bracket. Much better wheelie action now.

Also added a FV MotoGP bike above the pops.

image_(resized).jpeg

image_(resized).jpg

image_(resized).jpg

image_(resized).jpg

#467 3 years ago

Looking for some advice here . What angle are you running full throttle at? I am getting major air balls right off the flippers and its causing a lot of problems for me . I realized it tonight when a lot of my shots wouldn't go up the ramps , or around loops . It's lifting the ball and the balls hitting the upper lane protectors instead of just smoothly running through. I'm at 6.5 degrees right now .
What should I be looking for to stop this from happening ?

#468 3 years ago
Quoted from freezie:

Looking for some advice here . What angle are you running full throttle at? I am getting major air balls right off the flippers and its causing a lot of problems for me . I realized it tonight when a lot of my shots wouldn't go up the ramps , or around loops . It's lifting the ball and the balls hitting the upper lane protectors instead of just smoothly running through. I'm at 6.5 degrees right now .
What should I be looking for to stop this from happening ?

Adjust your flipper rubber on the bat. Likely a bit too low

#469 3 years ago

I did suspect that Whysnow. I will check that tomorrow .

#470 3 years ago

Not in the club (one day I hope) but I played this on location in Denver yesterday. Played great outside of when the ball came through the garage entrance/left orbit towards the flippers. It would go right down the center and drain 95% of the time. Isn't a big deal when you plunge the ball as there's a ball save at the start but pretty annoying in multiball or when you hit the right outer orbit. Was the ball guide just not set up right? Anyone else have this problem? I played a different full throttle six months ago and don't remember this happening but I can't remember for sure.

#471 3 years ago
Quoted from Pale_Purple:

Was the ball guide just not set up right? Anyone else have this problem? I played a different full throttle six months ago and don't remember this happening but I can't remember for sure.

That is an issue, and it's maybe a ball guide issue. I have that problem and it's tough to figure. Doesn't do it on initial plunge but on multiballs, the plunger "seems" to be stronger or more erratic but everyone says it's a ball guide adjustment. I've fiddled with ball guides and have yet to dial it in...if it doesn't do it on the initial plunge, why on multiball auto-plunge? The spinning wheels have been blamed but that didn't seem to explain it fully on my game. Still working it out....

#472 3 years ago

The game I was playing had it happen on almost every initial plunge. Probably 28 out of 30 initial plunges.
Gotta say the game I played had the black lock down/magazine around the glass and I really liked it. Looks better than the gray for sure. Now I just can't wait to play a LE game with the optic ramps!

#473 3 years ago
Quoted from Pale_Purple:

The game I was playing had it happen on almost every initial plunge. Probably 28 out of 30 initial plunges.

This happens maybe 25% of the time for me but it's pretty rare to not have a ball save in effect when it does happen. Need to do more tweaking I guess. I just hate bending stuff when it's connected to the playfield, can't be good long term.

#474 3 years ago

Flipper rubber made no difference . I'm at a loss right now , I'm getting major airballs right off the flippers , so bad at times I hit the right ramp sign square in the middle , and I've shot balls right back into the launch lanes . Otherwise it al,pst always hits the ramp covers making 90% of my ramp or loop shots hit something and not go through . No where near as smooth at the ft I played at yegpin , which was smooth and fast . I'm sure once I get the balls to roll flat it will,be though .

#475 3 years ago
Quoted from freezie:

Flipper rubber made no difference

Can you adjust flipper height, not the rubber but the flipper? Does that look out of whack at all? Try some regular bands on them as well just for kicks..?

#476 3 years ago

I'm thinking the bats at this point too . Has to be.

#477 3 years ago
Quoted from freezie:

I'm thinking the bats at this point too . Has to be.

Make sure your flipper bats aren't too low when at rest. There is a plastic plug under them to allow easy removal of the flipper assembly. If its a little too low, the ball can dip into that area & skip up into the air. Even if you think they look fine, try adjusting them up an 1/8" & see if that helps.

#478 3 years ago

My pin would only do it on a ball coming back at the flippers at a high rate of speed. The ball speed would force the flippers back slightly & cause the ball to skip in the plastic plug area & cause air balls. I adjusted the flippers up slightly & it fixed the problem. Hope that helps.

#479 3 years ago

raised them up 1/8th and it didnt change a thing. the plastic sign over my ramp is now broken from getting hit . i have an email in to heighway as well as m distributor . strange . left flipper shots can even get back to the launch , and right flipper shots can get up and over the plastics and the ball gets trapped on the cycle .

#480 3 years ago
Quoted from freezie:

raised them up 1/8th and it didnt change a thing. the plastic sign over my ramp is now broken from getting hit . i have an email in to heighway as well as m distributor . strange . left flipper shots can even get back to the launch , and right flipper shots can get up and over the plastics and the ball gets trapped on the cycle .

Same thing happened to me, both plastics shot by the end of the first week. Insane air balls.

Here is what I did to fix it:
1. Ensure that the wheel mechs are 100% completely flush
2. Ensure that the flipper sub assembly mech is 100% completely flush
3. Remove those god awful superbands, this game already gets a lot of side spin on the ball, these only exacerbate the problem and will get the ball airborne. Put regular rubbers on.

If all of that has been done and you are still having the issue, then it is probably an issue with the bats themselves, like others mentioned before me. I am sure Andrew and his team will get this figured out for you.

#481 3 years ago

my next step is to pull the superbands off , i do agree they are grabby . wheels are flush (first thing i did) everything seems to be flush and installed right as well .

#482 3 years ago

I get a lot of air balls too. I think it's why I have had so many broken plastics. I find it happens more when the ball is out of control and coming back to the flippers fast and loose. It doesn't happen when I play better and keep the ball under control. I will try different rubber and see if that helps.

#483 3 years ago

Hello just joined the club I had to change out a couple fuses cause they had the 3A fuse in for the Europe power and it popped. Only problems I cant seem to figure out now are the picture does'nt fit in the backbox screen and the small screen boots up and I can tell its on but it does not display (stays black) any suggestions? Thank you.

#484 3 years ago
Quoted from Charliew65:

picture does'nt fit in the backbox screen and the small screen boots up and I can tell its on but it does not display (stays black) any suggestions?

no clue. I would email support.

#485 3 years ago

I fiigured it out I switched the cables the one to the monitor and the one to the playfield monitor and now everything is perfect! Loving this game...

#486 3 years ago

also the right flipper was sticking up and I just threw a stronger spring on it. Working great now

#487 3 years ago
Quoted from Jgaltr56:

I get a lot of air balls too. I think it's why I have had so many broken plastics. I find it happens more when the ball is out of control and coming back to the flippers fast and loose. It doesn't happen when I play better and keep the ball under control. I will try different rubber and see if that helps.

I swapped the factory flipper polyurethane with Titan silicone red. They are much less bouncy and don't cause the crazy spin which seems to help with airballs. This game definitely forces you to work on your ball control skills!

#488 3 years ago

I'm getting quite a few intermittent missed switch detects from the inductive sensors below the MPH lanes and the fast inner loop. Happens during gameplay and in test. Heighway recommends adjusting the inductives closer to the playfield but no detail on what is involved to do that. Just wondering if anyone has had success with this before I start removing PCBs? Also wondering if the ball type makes a difference? I put PBL Super Shinys in on day one because they don't get magnetized like others. Maybe they reduce the range of the inductive sensors?

#489 3 years ago
Quoted from Jgaltr56:

Heighway recommends adjusting the inductives closer to the playfield but no detail on what is involved to do that.

Inductive switches can be adjusted by placing a small screwdriver between the PCB and the playfield and pushing the switch out towards the playfield so it is sticking out at its maximum. See attached pic, hope this helps.

switch_adjust_(resized).JPG

#490 3 years ago
Quoted from Krakatoa:

Inductive switches can be adjusted by placing a small screwdriver between the PCB and the playfield and pushing the switch out towards the playfield so it is sticking out at its maximum. See attached pic, hope this helps.

Yes. This should be all you have to do. My "M" on MPH needed to be adjusted closer, it took just a clue of seconds & it was fixed.

#491 3 years ago
Quoted from Krakatoa:

Inductive switches can be adjusted by placing a small screwdriver between the PCB and the playfield and pushing the switch out towards the playfield so it is sticking out at its maximum. See attached pic, hope this helps.

That did the trick. Thanks!

#492 3 years ago
Quoted from Pale_Purple:

Not in the club (one day I hope) but I played this on location in Denver yesterday.

Curious to know where it is on location in Denver.

#493 3 years ago

It was at 1up-lodo. Pretty cool spot, all the games in great shape with leds, color dmds, and anti-glare bars. Next time I'm in Denver I'll be back.

#494 3 years ago

I feel a little silly now , my issue was the plastic cover on the lcd , I thought I checked it twice , but it was sticking up 1/16" of an inch and causing a ramp effect . Adjusted easily with the 4 screws under the playfield that hold the lcd in place . Now the only issue I face ( minor) is when the balls kicked into the shoot out lane , it rolls up the plastic cover then back down into the lane . At least I can play with that issue , fast and smooth !! Just as I remember it playing in Edmonton !

#495 2 years ago

Starting to get the rules in a little more detail , just got a score of 140,767,080, that made me happy. I was having a great game right before that when my left flipper failed . Turns out the two bolts for the coil fell out , lol . Can someone explain the pinball laws of physics to me? How do two bolts fall out , but only one is found ? Luckily I have some pinball misc bolt kits and had the Bolt and washer I needed . Love this game , very addictive!

#496 2 years ago
Quoted from freezie:

How do two bolts fall out , but only one is found ?

Look on the speaker magnet. Sometimes they stick there.

#497 2 years ago

Yup , checked there too lol . I just hope it shows up before shorting anything out .

1 week later
#498 2 years ago

Have you ever wanted a fast way to learn to play Full Throttle without reading long reviews?

Now we have the answer for you:

#499 2 years ago

Today I upgraded my speakers cause after about 40 games it sounded like the left speaker was blown, After searching the internet I couldnt find a good quality 4" speaker with less then 1.61" depth. Last night at walmart I found these and they work perfect and they are only 1.51" deep. Sound really crisp to. They were only $25 for the pair.

image (resized).jpeg

image (resized).jpeg

#500 2 years ago

good price !

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
4,800 (Firm)
Machine - For Sale
Fruitland Park, FL
4,500
Machine - For Sale
South Portland, ME
5,000 (OBO)
Machine - For Sale
West Bridgewater, MA
$ 57.95
Playfield - Toys/Add-ons
PinBoss Mods
From: $ 15.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
From: $ 9.99
Eproms
Matt's Basement Arcade
From: $ 19.99
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 1,000.00
$ 25.00
Cabinet - Other
Filament Printing
$ 24.00
Electronics
Yorktown Parts and Equip
$ 40.00
Playfield - Decals
Great American Pinball
From: $ 38.00
Playfield - Decals
Pinball Mod Co.
$ 209.99
$ 15.00
Cabinet - Other
Siegecraft Electronics
There are 713 posts in this topic. You are on page 10 of 15.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside