(Topic ID: 96939)

Frustrating Coil Problem

By Captain_Tilter

8 years ago

Topic Heartbeat

Topic Stats


Linked Games

#1 8 years ago

Hey all.
So I have been working on a beat up Demolition man for the past couple of months and I am having one last (or so I hope) problem that is really stumping me. At first the lower ball release and right jet bumper coils were locked on as soon as the game was powered on while the diverter hold and top popper solenoids would not fire at all. I replaced the Tip36c, tip102 and predrivers for the high power coil and the tip102 and pre drivers for the low power coils. Turned it back on and nothing changed. Anyhow replaced the u4 and u5 ls chips upstream and BAM no more locked on coils but still no working top popper or diverter hold. I have desoldered and checked all of the diodes and resistors for both of these and all test good. When I test the top popper transistor tip 102 to ground it fires and the u5 and u4 chips I replaced earlier should indeed be the ones controlling everything. Is there somewhere else I should be looking?? 20 pin connector?etc? I am really stumped here. Thanks for any info.

#2 8 years ago

Test the transistor itself, I suspect you'll find it will fail. Grounding the tab of the transistor usually tells you the circuit is all ok to to the coil, but the transistor or possibly the diode behind it is bad.

#3 8 years ago

Thanks wolf. All transistors have been replaced and the diodes and resistors all test good too. Strange huh?

#4 8 years ago

Do they fire in solenoid test? Do you have any switches listed switch test?

#5 8 years ago

They do not.

#6 8 years ago

I running out of ideas quick here. About the last one I got is try reseating connectors.

#7 8 years ago

Yea I'm out of ideas too. Reseating does not work, so yea basically everything from the u4 and u5 chips to the transistors are new that's why I was thinking it might be some kind of problem further upstream from the Ls chips? I just don't know how reasonable that sounds. Normally things like this have always been just an easy transistor fix for me...

#8 8 years ago

There is power at the coils in question correct?

#9 8 years ago

Yes I am getting 79v testing dc volts on them

#10 8 years ago

Did you test/replace the associated diodes with the coils in question? If those are bad the coils won't work.

Edit: missed you did. If you have voltage at the coil on both lugs, then there are no broken windings on the coil. If there is voltage though, it usually means no connector issues. I would double check the driver and pre driver transistor to verify they are good, and check for broken traces.

#11 8 years ago

I did test them with one side desoldered and they both tested good. As I understand sometimes tests can fail so perhaps I should just replace them? What do ya think as I'm kinda running out of guesses ha

#12 8 years ago

Thanks dsuperbee so I looked over and continuity tested everything and sure enough there was a tiny burned trace between one on the pre-drivers and resistors. Had to jump it from the back of the board as that trace runs between the legs of another predriver. Anyways that should fix one of the coil problems! Sometimes it takes people stating the things you tell yourself you have already checked to make yourself do it again! Ha thanks

#13 8 years ago

Problems solved demolition man is up and playing. It was 2 very small almost unnoticeable traces burned! Thanks you guys!!

Promoted items from the Pinside Marketplace
$ 29.95
$ 25.00
Apparel - Men
Pinside Shop
$ 9.95
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/frustrating-coil-problem and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.