New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 237803)

Frankenstein Flipper Sticks / Locks Up Intermittently DataEast/Sega

By pfister

1 year ago

Topic Stats

  • 39 posts
  • 9 Pinsiders participating
  • Latest reply 1 year ago by wugly
  • Topic is favorited by 2 Pinsiders


Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

2019-03-11_10-02-18 (resized).png
2019-03-11_9-58-56 (resized).png
20190304_234101 (1) (resized).jpg
20190227_182118 (resized).jpg
20190306-073644 (resized).jpg
20190227_172524 (resized).jpg
20190304_234101 (resized).jpg
20190304_234041 (resized).jpg
20190304_234116 (resized).jpg

#1 1 year ago

#mary-shellys-frankenstein is a 3 flipper game. Main-Left Flipper, Main-Right Flipper, Top-Right Flipper. The Main-Right Flipper (controlled by a two step leaf contact - see pictures ) intermittently stays charged and locked in the UP position. This definitely an electrical issue BUT it is also intermittent issue. It happens maybe 5% of the time and seems to be triggered more often by holding the flipper down for an extended time (2-5 seconds). The other 2 flippers work perfect 100% of the time.

This is what I know:
- The flipper coil area seems in really good condition.
- The leaf contact might not be in the greatest condition, however, the top-right flipper works 100%
- The circuit board looks like it's been repaired. All the red lights come on with the flipper contacts hit.

other notes,
Once the flipper locks, simply taping the flipper button 1-5 times, unlocks it. When comparing the the left flipper button to the right. There is significant black on the right button (you can kind of see this in the picture) -- maybe this is hinting to something.

Does this seem like a flipper control board issue? leaf contact issue? flipper coil area issue?

Resource Links:

20190304_234116 (resized).jpg20190304_234041 (resized).jpg20190304_234101 (resized).jpg20190306-073644 (resized).jpg20190227_172524 (resized).jpg
#2 1 year ago

Are you sure it's energized?

When you turn the game off, does the flipper immediately drop?

If it doesn't, It could be as simple as a magnetized coil stop, or a damaged plunger. Important to determine if it's mechanical or electrical and you haven't provided enough information to narrow it down to either.

#3 1 year ago

Very sure it's energized. When the game turns off, the flipper immediately drops. Thanks for replying crazylevi

#4 1 year ago
Quoted from pfister:

Very sure it's energized. When the game turns off, the flipper immediately drops. Thanks for replying crazylevi

I had an issue once on a High Speed where the flipper would lock on and release in a similar way. The switch in the cabinet was so old and corroded it would literally stick together and pressing the button a few times would usually loosen it up and it would separate again so I replaced the switch. Try watching the switch in the cabinet when you press the flipper button in and see what happens.

#5 1 year ago

Shorted transistor on the flipper board?

#6 1 year ago

grantopia I have watched the leaf switch very closely and the contact is totally open ( no contact at all ) while the flipper is energized. This is leading me to the board, like 0geist0 might be suggesting with the shorted transistor.

Here is a link to a video: -- In this video you can see me touching the leaf contact with a screw driver on the right.. and if you look over at the flipper control board, you can see the control board is lighting up red when the contact is made.. Meanwhile, this entire time, the top flipper is locked-up.

0geist0, if is was a shorted transistor, does the intermittent behavior make sense? For example, 90%+ of the time, the flipper is working properly.

20190227_182118 (resized).jpg
#7 1 year ago
Quoted from pfister:

0geist0, if is was a shorted transistor, does the intermittent behavior make sense? For example, 90%+ of the time, the flipper is working properly.

Anything is possible. I just had an intermittent display problem on my Flight 2000, that turned out to be a shorted transistor.

#8 1 year ago

0geist0 - if you're correct, my options are (A) replace the entire board or (B) to fix the transistor. This is my first post and first dive into fixing's a picture of my flipper board -- The Red L1 Light is the one that lights up when I hit the right flipper. What areas of the board should I begin testing / replacing??

Link to Picture of Flipper Board:

20190304_234101 (1) (resized).jpg
#9 1 year ago

Just to update this topic. I ordered a new board. The old board has a lot of blistering traces, which make it a higher risk board to try an repair by replacing some of the transistors, etc.

#10 1 year ago

Well, I replaced the flipper board with a new one and the issue is still happening.
Here's a video:

You can see me taking my finger off the button and the flipper stays up.. and pushing on the flipper to show its energized. When you turn off the machine, the flipper goes down immediately so its definately electrical.

So.. something is causing the coil on the right flipper to stay energized. Any advice or things I should check??

#11 1 year ago

Check the flipper diode. If it's bad or broken it will energize like that.

#12 1 year ago

Shudel, if the flipper diode is bad or broken it will energize intermittently (vs all the time) like that?? I'll look into the diode. Another idea I had is maybe it could be the capacitor on the flipper switch..possibly it is bad or broken as well. Since I dont have a replacement capacitor, is it required for short term testing and trouble shooting? (I think I read it serves an important purpose to limit sparks) but that it wasnt required.

#13 1 year ago

Can you test the diodes while they are connected to the coil? Because I'm getting 0.0v both ways .. on both flipper diodes.

#14 1 year ago

you need to disconnect one Side of diode to get accurate test,I would just replace it and eliminate that as a possible problem.

#15 1 year ago

pintime schudel5 do you need the capacitor in the flipper switch for short term testing? I read it wasnt critical since it's mainly there to diffuse sparks and improve the wear on the leaf contacts.. Since this is my first pin I dont have a lot of extra parts laying around ... but I will soon but I'd love to get to the bottom of this this flipper issue.

#16 1 year ago

Just replace the diode. There are no caps as the EOS and flipper switch is low voltage in conjunction with a single wound coil. All high power and low power switching is done on the flipper board.

#17 1 year ago

I don't think it's the diode on the coil.. I traced the issue to the board behind the back glass.. IF the flipper is locked and I disconnect the cable harness in this picture, then the flipper immediately releases. Looking at this diagram and the circuits on the board, I'm not sure exactly what I should be looking to replace. The top Orange/Purple wire is the right flipper, the next Orange/Blue wire is the left flipper. schudel5 pintime 0geist0

2019-03-11_9-58-56 (resized).png2019-03-11_10-02-18 (resized).png
#18 1 year ago

If you are pulling the coil connector off it makes sense the flipper would de-energize. Did you actually test the diode? If it's happening periodically I would suspect the diode or the leaf switch in the cabinet sticking or making contact somehow as you mentioned pushing the button will also release it.

#19 1 year ago

Have you tried to disconnect the EOS switch? Frankenstein doesn't need it because it uses an internal timer. I once had trouble when trying the EOS switch (as you do on other machines) and had to disconnect it.

#20 1 year ago

pinmario I just replaced the leaf contact/capacitor AND the diode in the coil... now my issue isnt intermittent.. the moment I touch the right flipper button, the right flipper locks up (energized).. only way to unlock is to turn off the machine.. meanwhile, the top right flipper and left flipper are working perfect.

#21 1 year ago

Since you already changed the flipperboard, you could try to switch the wiring of the left to the right flipper (mark them well to restore correctly afterwards). If the problem moves to the left, you need to follow the signal to the mainboard and check the signals. A bad transistor is possible, but maybe the problem is in the logic control. If the problem remains, check the contact AND wiring of the flipperbutton. Have you tried to disconnect the connector of the button when the coil is energized?

#22 1 year ago

pinside if I disconnect the flipper connector behind the back glass. The flipper de-energizes immediately.. if I disconnect the EOS side of the flipper board, the flipper remains energized. Are you suggesting I switch the 2 orange wires (left flipper /right flipper) behind the back glass?? That would be pretty easy versus rewiring a lot of connections.. Since I just replaced the flipper leaf contact, I'm thinking that the flipper button might be OK, especially since the flipper stays un-energized until the button is pushed.

#23 1 year ago

Just thinking if you swap the coil conenction, and/or the buttons you can determine if the problem is in the backbox or not. Best to find the fault before changing parts. Where you swich it is up to you to find the easiest way

#24 1 year ago

pinmario I did hook a meter up to the locking flipper coil and its stabilizing at 5v.. not the higher 50v I suspected. The power holding the flipper up is still pretty significant. I can't budge it with a more than moderate push. Does this make sense?

#25 1 year ago

After the initial flipping, the flipper falls back to a hold voltage just to keep them up for as long as you push the button (most of the older pins use the eos for this) This is enough to hold the flipper up, but it doesn't take much effort to push it back down. According to pinwikki is should be 50V and 8V, so yours should be ok, you can find this article and others here :

(I still think it's an electronics problem)

1 week later
#26 1 year ago

pinmario I replaced the TIP122 transistor (seen next to the orange wire in past posts) with a comparable NTE261 ( because it was at my local electrical supply shop.. however when I turn the machine on, this thing get super hot! The other transistors are cool. I'm always good to turn the machine off immediately. To fix this, I went on mouser and have more TIP122's getting delivered today. In the back of my mind, I'm thinking the TIP122 really is the same transistors as the NTE261 and nothing may change.. is there anything else I should be considering at to why the transistor gets super hot so fast?

#27 1 year ago

I never used a NTE261 but looking at the datasheet, it looks quit the same.
Does it get hot after just switching on or after you pushed a flipperbutton? In the first case maybe you made a short on the board with the replacement or perhaps a connector is positioned wrong?

#28 1 year ago

pinmario it gets hit immediately after turning it on. I'm about to replace the transistor. I'll update you and take extra special care with those connections

#29 1 year ago

Final Update on this issue: It appears to have been the transistor on the main board. Q2 + Q8 is what I replaced (0geist0 nailed it! ). Also ended up replacing a fuse because while experimenting with polarity and diode directions, i must have blown the 50v fuse. ( Check you fuses people!! ) I figured the fuse issue out once I had both flippers working well but everything was operating in low voltage mode. Overall, great experience on pinside. This is my first post and I'm really appreciative of the community. special thank you to pinmario as you definately hung in there with multiple days of back and forth messages. Thank you and goodluck out there. Hopefully this post helps someone.

#30 1 year ago

Great you got it working again, i hope you enjoy the game as much as i do.

6 months later
#31 1 year ago

I have developed what appears to be the same problem with my frankenstein pinball. haven't measured the voltage of what is holding the flipper up but it is up strong enough to stop the ball coming out of the geneva scoop. my lower left flipper is sticking up occasionally maybe 1 time out of 30 or 40 activations. if I press the flipper once or twice it drops. I have already rebuilt all the flippers since I thought that might have been the problem because I knew for sure that the upper right flipper degraded enough so that the flipper was getting caught up on the way down and needed new bushings. I have ordered some new tip122 and 2n4401 transistors but was wondering if you could confirm that the transistors I would have to replace would be q35 and q43 for the lower left flipper? yes the flipper drops instantly when denergized so it is not getting stuck mechanically.

locked on coil is being supplied 4 volts.

2 weeks later
#32 1 year ago

I replaced 35 and q43. the occurence of stuck flipper was reduced but is still occuring. if I go to a switch test with the coin door open and the interlock off the flipper button registers and then turns off while I am holding it but if I wait awhile the flipper moves up slowly like it is using the holding voltage. does anyone know where to look for this problem on the left flipper?

#33 1 year ago

When it goes down try pinching the EOS briefly with your fingers. I had this problem in the past with data east games and it turned out on one that the EOS needed cleaning and another that one of the contacts was loose on the leaf. Also seen cracked leafs exhibit this behavior.

#34 1 year ago

the question is why is it going up with the high voltage interlock open. the right side which doesn't stick doesn't move the left when I hold it will move. I had this problem a moth ago then rebuilt the flippers with new eos sleeves , plungers and bushings. it sticks up occasionaly in game play which is the problem and is held with 4 volts.

#35 1 year ago

If you lift the right flipper up with your finger and hold the button in does it stay up with the coin door open? This might tell you if the symptom is a red herring.

Have you checked to make sure the leaf switch is disengaging?

#36 1 year ago

yes the right flipper will stay up if you move the flipper while holding the button in switch test mode. i removed the ball when the flipper got stuck up. the machine goes into a ball search mode. if I press and hold the button while it was stuck and doing ball search mode it stops the search mode proving its not the button. after I let the button go after a stuck flipper the flipper drops normally.

the leaf switch disengages

#37 1 year ago

Finally got a chance today to really dig into the game. checked input on cn1-12 and it grounds when I hit the button and the l2 flashes and goes out when held, looking good so far. I pulled the board off the wall and layed it on a towel in the bottom of the game so that I would have easier access to it for probing some of the components. started a game and pulled the ball out. started playing with the left flipper only (the one that sticks up) hitting points occasionally to make sure the game does not go into seeking mode. 10 minutes later still no sticking. going to test it later with holding the flipper up for longer period of times. my plan was to see if I was getting voltage on r32 if the flipper is stuck but so far I have not been able to make it stick. My fall back position if I can't get it stuck again is that maybe moving the board shifted a connection to make it more reliable or maybe the board flexed while removing and made a better connection to a bad solder joint. If I can't get it to stick again maybe I will inspect the solder joints better and reflow. and also clean the connectors. other ideas to run down or am I barking up the wrong tree. I know the flipper switch is good because if it was bad and staying connected the game would never go into search mode if it was reading a stuck switch

#38 1 year ago

this is very frustrating. played 20 games no problem then upper right flipper was delayed a second from lower right or a ball or so. i had reflowed the connectors but no sticking. mounted board back on wall and played a few games and the left flipper sticks up again. then to annoy me my plasma bumper controller for my green pop bumper stops working. its definetly the controller because moving around the connectors makes only that controllers bumper not light. i am now worse off then before

#39 1 year ago

finally got to check on r32 with the flipper locked in upper position. I got a reading of 8 volts on it. this feeds the gate of sr2. from what I can see the gate should only be getting 5 volts max if I was supposedly holding the flipper button. does this mean that the sr2 might be bad and leaking voltage through to the gate? Would hitting the flipper button cause the 50 volt surge to shut off a defective scr? also thinking that the upper flipper problem might be the flipper getting out of time with the lower one since it has no eos on the upper and the delay might be 8 volt power trying to raise the flipper. this almost never happens so next time it does I will see if letting the right flipper drop enough to get eos to reset good will fix this. please someone who understands this circuit for the sr2 please let me know should I change it?

Promoted items from the Pinside Marketplace
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
€ 339.00
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 9.99
From: $ 40.00
Lighting - Interactive
Professor Pinball
From: $ 369.95
From: $ 1.25
Playfield - Other
Rocket City Pinball
$ 20.00
Playfield - Decals
$ 21.00
Yorktown Arcade Supply
$ 50.00
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 209.99
From: $ 18.00
Apparel - Men
Pinside Shop
$ 40.00
Playfield - Decals
$ 16.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 219.99
Lighting - Interactive
Medisinyl Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside