New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 205211)

Frankenstein coil issue


By Willy39

2 years ago



Topic Stats

  • 3 posts
  • 1 Pinsider participating
  • Latest reply 2 years ago by Willy39
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

Got an issue with my game. I pinpointed the problem to three coils not firing. The switches associated with those coils are working and recognizes the ball. The three coils not firing are the ball trough, sarcophagus, and vuk North Pole. The Geneva and the ice cave work fine. Just those three. Could it be a bad diode? Loose or broken wire? Or even a blown fuse? Any help is appreciated! Thanks.

#2 2 years ago

Edit: not the ball trough coil. The shooter lane coil. So basically all the high powered 50v coils. (Shooter lane, sarcophagus, and North Pole). I’m thinking fuse? Any suggestions otherwise?

#3 2 years ago

It’s not the fuse. Any other help?

Promoted items from the Pinside Marketplace
From: $ 369.95
Boards
PinSound
$ 20.00
Playfield - Decals
Metal-Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 21.00
Electronics
Yorktown Arcade Supply
$ 28.00
Lighting - Other
Rock Custom Pinball
From: $ 9.99
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 209.99
€ 339.00
Displays
GermanGamingSupplies.com
From: $ 1.25
Playfield - Other
Rocket City Pinball
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 27.95
From: $ 19.99
$ 149.00
Playfield - Toys/Add-ons
Sparky Pinball
$ 2.50
Playfield - Decals
Doc's Pinball Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside