(Topic ID: 187173)

Tech: Flintstones (WPC) Right Flippers Stay Energized

By rogerdodger

5 years ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by R67en
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Fliptronic (resized).jpg

#1 5 years ago

Hi Guys:

Both the upper and lower flipper on the right hand side of the playfield are energizing and staying energized, as soon as the game is powered up, before even starting a game. I know, from past experience, that any solenoid that is constantly energized is often the result of a failed transistor.

I put my analog meter across the middle leg and the left leg of each transistor and transistor numbers 4 and 8 (reading down from the top on the attached pic) are reading 2 ohms but all the other transistors read 60 ohms. I then retested putting one lead on the middle leg and the other lead on the right leg of each transistor and got the same results. Does this mean that these 2 transistors are bad?

I swapped a board from another game and all OK, so I know this board is the problem.

The board is a PinLED Fliptronics board. I e-mailed them to request a schematic but received no reply. I can't read schematics anyway!!

Any help appreciated

Roger

Fliptronic (resized).jpg

#2 5 years ago

I'd go into switch edge test and see if both optos on the right hand flipper button opto board work.

LTG : )

#3 5 years ago
Quoted from LTG:

I'd go into switch edge test and see if both optos on the right hand flipper button opto board work.
LTG : )

Switch edge tests work fine..... and board from another game works perfect, so it is clearly a board problem.

#4 5 years ago

Replace the transistors that tested bad.

#5 5 years ago
Quoted from pintechev:

Replace the transistors that tested bad.

So my basic test confirms that those 2 transistors are bad?

#6 5 years ago
Quoted from rogerdodger:

So my basic test confirms that those 2 transistors are bad?

Confirmation anyone?

4 years later
#7 1 year ago

rogerdodger I know this is an ancient thread, but I'm having the same issues. I just did board work on the MPU, and now my flippers lock on immediately. Not sure where to start. Happen to remember how you resolved this?

Promoted items from the Pinside Marketplace
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 18.00
Apparel - Men
Pinside Shop
$ 18.95
Eproms
Pinballrom
$ 15.00
Playfield - Toys/Add-ons
Pinball Haus
From: $ 27.00
Boards
KAHR.US Circuits
From: $ 9.99
Eproms
Matt's Basement Arcade
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 159.99
Lighting - Other
Lighted Pinball Mods

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!