(Topic ID: 254890)

Flight 2000, no speech


By squad8

1 year ago



Topic Stats

  • 113 posts
  • 13 Pinsiders participating
  • Latest reply 85 days ago by Quench
  • Topic is favorited by 8 Pinsiders

You

Linked Games

Topic Gallery

There have been 17 images uploaded to this topic. (View topic image gallery).

6D44819D-1BAF-4436-80C1-9B2BCF6637A2 (resized).jpeg
F83C46C3-7CB8-4C11-BF9A-D896D655E6FE (resized).jpeg
D9246F66-2D3E-472F-B4C3-6C2944B69C7D (resized).jpeg
4977D217-9795-4130-BA33-779320A25A1F (resized).jpeg
84F2B344-C6A4-487D-B384-09011A3D5832 (resized).jpeg
0D16F952-456E-4A80-8477-785C380E0570 (resized).jpeg
DCFB5031-86BA-4275-8ADC-6333ED68DDBD (resized).jpeg
FDB21347-1AFC-440F-AF7B-DD9ADE24F46B (resized).jpeg
B8322EF1-7E0F-4756-91CF-32CECF244BF4 (resized).jpeg
61254129-4D7C-483C-8F67-59F9ECC3AFF0 (resized).jpeg
44B18C76-ED7B-4669-A77D-68038FA610CB (resized).jpeg
DA9F27DA-2553-4390-B60A-4543609B065B (resized).jpeg
Pinside_NoScaling.png
Lightning_VSU100a.png
3862F69F-4820-41E2-8DCD-8C3876621451 (resized).jpeg
BCBC0582-6DB6-4CF1-B990-1B903B303B41 (resized).jpeg

You're currently viewing posts by Pinsider squad8.
Click here to go back to viewing the entire thread.

#1 1 year ago

I am working on a Flight 2000 project, and I have sound but no speech. I have changed the electrolytic capacitors, and switch 17 is in the on position. Test point 1 fluctuates from .06-.11 volts, T.P. is 5.19 volts, and T.P. 3 fluctuates from -2 to -10 volts.
Thanks in advance for any help.

#4 1 year ago
Quoted from dothedoo:

Is the sound board original to the game? Look at the back side and verify it has the long jumper wire for speech.

The SB-300 sound board has the jumper on the back of the board.

#6 1 year ago
Quoted from Dr_Dude:

Does "no speech" indicate in-game? IE., did you try solenoid-test, which should include some speech call-outs at the end.
Alas, the TSI- S14001A speech chip can fail, and is very hard to source these days. If you are lucky, it may be just a bad-solder on a connector, or one of the easily found drive chips.

There is no speech in test or game play. As far as bad solder goes I have reflowed the connector, and looked the board over.

#8 1 year ago
Quoted from slochar:

Before you go nuts trying to get the speech chip, burn a new eprom for the speech board. I had 3-4 boards I bought as dead that it turned out everything was fine except for the 2716 eprom on them. You can double up the 2716 image to burn onto a much more commonly available 2732.

I will get a eprom burned, to see if that works.

Thanks to all that responded.

#9 1 year ago
Quoted from barakandl:

The lamp interrupt (aka speech busy) signal that comes in MPU j4 should also change state when the speech. I think it normally sits low when no speech happens and goes high when speech is playing.

I probed j4 pin 11 on the mpu, and it stays low in game play, and solenoid test.

Quoted from slochar:

Before you go nuts trying to get the speech chip, burn a new eprom for the speech board. I had 3-4 boards I bought as dead that it turned out everything was fine except for the 2716 eprom on them. You can double up the 2716 image to burn onto a much more commonly available 2732.

I got a eprom for the speech board, and still have no speech.

#11 1 year ago
Quoted from barakandl:

Do you get silence when speech should be playing? Like when you begin the game there should be (speech) or silence and the lamp int should go high during that time.
I don't think there is any speech in solenoid test mode but I am not 100% sure on that.

I will have check better for silence when a game is started, but the lamp int stayed low at that time. I will report back when I check more thoroughly.
Thanks

#13 1 year ago

I ran solenoid test and there is no silence, but it seems like the sounds are duplicated through test. It is hard to say for sure, but it does appear to have silence during game start when there should be speech. I also double checked the lamp int, and it is always low in test, and game start.
One thing that I forget to mention is that I put new ribbon cables on the sound board.

1 week later
#16 1 year ago
Quoted from wrb1977:

Going off of memory from a few years back when I had a F2K...one of the fuses (I think the one for the GI) also controls the speech or sound or both...I can’t remember for sure. Just a thought in case you haven’t checked the fuses???

The fuses are all good.

Quoted from barakandl:

If lamp int never goes high the speech processor is probably not working because its bad or some other kind of problem like at U6, U5, U4, U3, U2, or input connectors. You can probably work through some of these circuits like U5 and U4 Q pins should be pulsing when speech should be playing. U6 P9 should be low when speech is playing, U6 P10 should be high or pulsing when speech is playing. U5 P2 should be pulsing when speech is playing.
I would try a new speech processor chip but saddly they are pretty hard to come by. Another working speech card to compare to and borrow the working processor would help.

The results of your recommendation are:
U6 pin 9 high and low light always on and always pulsing.
U6 pin 10 always low.
U5 pin 2 always high.
U5 puns 2, 5, 7, 10, 12, and 15 always high.
U4 pin 2 high, pins 5, 7, 10, 12, and 15 always low.

1 month later
#19 1 year ago

I haven't had time to continue with the speech problem, and need to get back on it. I am going to order some of the ic's for it, but I also noticed that the capacitor at c17 is cracked. I can not read what the value is on my schematic. Can someone let me know the value.
Thanks to all that helped this far.

#24 1 year ago

I am having trouble finding a .21 uf capacitor for c17. I am also unsure what type of capacitor it is or what I can use.
Does anyone have a recommendation?

3862F69F-4820-41E2-8DCD-8C3876621451 (resized).jpegBCBC0582-6DB6-4CF1-B990-1B903B303B41 (resized).jpeg
#30 1 year ago

The parts are on order, I will report back with the outcome.
Thanks to all

2 weeks later
#31 1 year ago

I replaced C17, U1, U2, U3, and U6, still have no voice. I have been avoiding trying to find a S14001A for U8. I guess it is time to try that unless someone has any other suggestions.

#33 12 months ago

It looks like a typo for TP1 and TP2 as well. TP1 is marked as ground on the board.
I am not sure why I originally had the fluctuation on TP3, but now it is -10. TP2 is 5.20.

#35 12 months ago

I ran the solenoid/sound test and U6 pins 1-6 never change. Pins 1 and 6 read both low, and high with a pulse. Pins 2, 3, 4, and 5 are always low.
Also I have a Twobits mpu that I tried, and still had no speech.

#37 12 months ago

The source of the Lamp Strobe #2 signal is pin 39 of U11 on the MPU board.
It then comes out on MPU J1 pin 8 and then into the speech board at J3 pin 4. Then through the 20k resistor at R24 and onto pins 2 and 5 of U6.

The only thing that I get is a very quick pulse on U11 pin 39 when I start a game. It never goes high.

Note: the Lamp Strobe #2 signal also drives the MPU board LED. So during power up when that LED comes on (flashes) you should see that Lamp Strobe #2 signal go high at the speech board.

It does go high at the speech board with the LED flashes on power up.

#39 12 months ago

The logic probe shows both high and low, with a pulse, in all conditions. ( power up, game over, game start, and game play)

#41 12 months ago

I don’t have a oscilloscope.

I probed every pin on U9, as I started games, and there was no change on the probe. I am fairly sure that it should have speech when a game is started. Someone posted that there should be speech during solenoid/sound test as well, but there is either a solenoid or sound through the whole test with nothing missing.

#43 12 months ago
Quoted from Quench:Can you also tell us which MPU board the game has? (original Stern or aftermarket)

It is a Stern MPU-200, but I also tried a a Twobits MPU.

Quoted from Quench:

What voltage are you measuring on pin 3 of the speech chip - my guesstimate is that it should be around "-2" volts.

I have 2.11 volts on U8 pin 3.

Quoted from Quench:

What did the logic probe indicate on most of the EPROM pins? High or Low?

On the EPROM, pins 1 & 2 nothing, 3, 4, 5 high, 6, 7, 8 nothing, 9, 10, 11 high, 12 low, 13-17 high, 18 nothing, 19 high, 20 low, 21 high, 22, 23 nothing, and 24 high.

Quoted from Quench:

When you power on, with your logic probe, what's the state of pins 2, 5, 7, 10, 12, 15 of U5?
When speech is being triggered, does the logic probe indicate any change on any of these pins?
U5 is used to latch the speech command from the MPU board to the speech processor.
Do the same on U4 (it's the same type of chip as U5) it controls the pitch of speech and also the volume of the analog output.

U5 pins 2, 5, 7, 10, 12, & 15 all start low & go high on power up. Checking the pins of U4, & U5 through solenoid/sound test they are low through the whole test.

U4 pins 2, 7, 10, 12, & 15 also start low & go high on power up, but pin 5 is always high.

Quoted from Quench:

What voltage do you measure on pin 40 of U8 which is the "/BUSY" signal?

U8 pin 40 reads 0.0 volts.

Quoted from Quench:

What does the logic probe on pins 9, 10 and 11 of U6 indicate?

U6 pins 9, & 10 are high, & pin 10 is low with a very rapid pulse.

#45 11 months ago

I started to do the testing today and discovered that I am intermittently losing voltage on U8 pin 40. When I have voltage on pin 40 it is 5.10 volts, but still don’t have speech. I will try to figure out why it is intermittent and then go back through the requested testing. The male pins on J3 don’t look very good, So I may have to repin it.

#46 11 months ago

I can not get consistent test results due to the fact that pin 40 on U8 is going low. It is very inconsistent, when I let it cycle solenoid/sound test it will start high and go low until I turn the game off and back on. Sometimes it will go low on the first cycle and other times it could take 3 or 4 cycles. I thought that I could have had a connector issue, but I don’t think so.

The voltage on U2 pin 3 and the top of R15 is +2.11 volts, and the bottom of R15 is +5.17 volts

U6 is socketed, but I held off on pulling the chip because I can‘t get consistent readings. With U6 in pins 9 & 11 are high & pin 10 is low with a very rapid pulse.

#49 11 months ago
44B18C76-ED7B-4669-A77D-68038FA610CB (resized).jpegDA9F27DA-2553-4390-B60A-4543609B065B (resized).jpeg
2 weeks later
#51 11 months ago

I finally got some time to get back on this. What I found is the game can sit in attract mode with a stable 4.95 volts on U8 pin 40, but when you go into solenoid/sound test it goes to 0.0 volts, and stays there until the game is rebooted. TP 3 is -10.17 volts in attract mode and after U8 pin 40 goes to 0 volts. During test U4, and U5, pins 2, 5, 7, 10, 12, and 15 are constantly low.

#53 11 months ago

On the mpu U11 pin 40, during power up it starts low then goes high for a few seconds, and goes back low. It remains low in attract mode, and through solenoid test.
I am not getting any pulsing on any pins of U9, during test.

#55 11 months ago
Quoted from Quench:

Erm, needed to know what's happening on MPU U11 pin 18, not pin 40

That was a typo on my part, the posted results are from U11 pin 18 on the mpu.

Quoted from Quench:

When you power up do you get any nasty screeching noises from the speaker? If yes, does the screeching change with or without the speech board connected?

I do not get any screeching noises on power up.

#57 11 months ago
Quoted from Quench:

The above isn't consistent with the below in terms of what the MPU board should be seeing of the gated /BUSY signal. According to the above, MPU U11 pin 18 should be low but showing pulsing. Can you recheck it?

I have the same readings, on power up it starts low, goes high for a few seconds, then back to high, and stays high the rest of the time.

Quoted from Quench:

Not even any change from low to high or high to low on any of the U9 speech ROM pins *after* solenoid test #29

I rechecked all of the pins on U9, and there is no change during test.

Quoted from Quench:

Remove and reinstall the speech processor a couple of times to get it to swipe in the IC socket just in case there's some poor connection there.

No change.

Quoted from Quench:

If it makes no difference, power off, pull out the speech processor at U8 and leave it out, power on.
Use a small screwdriver to touch pin 11 in the U8 socket - make sure your hand is touching the metal part of the screw driver. Does it produce any hum from the speaker? If it doesn't, find resistor R45 (next to the big blue capacitor) and very briefly place a short circuit across it. Do you get any click/pop from the speaker? We are just checking if the amplifier circuit on the speech board is doing anything.

I don't get any hum or pop from pin 11 on U8 or shorting R45.

Quoted from Quench:

BTW, do you have any way of dumping the U9 speech EPROM to verify it's good?

I don't, but I had 2 EPROM's burned, so I have tried 3 different chips.

#59 11 months ago
61254129-4D7C-483C-8F67-59F9ECC3AFF0 (resized).jpegB8322EF1-7E0F-4756-91CF-32CECF244BF4 (resized).jpeg
#61 11 months ago
Quoted from Quench:

If you did the amplifier tests in attract mode you may have not gotten any audible effects - if you want, try them again in solenoid test mode after the test has recycled back to solenoid #01 and maximum volume on the speech board has been selected.

I originally did the amplifier test after I started a game, so I did the test again in solenoid test, and still don't get any sound.

Quoted from Quench:

The fact that the speech processor at U8 is making no attempt to read encoded speech data from the speech ROM points to a faulty speech processor.

I can order the speech processor if you think that is what I need.

#63 11 months ago
Quoted from Quench:

What voltage do you measure at pin 5 of the U7 pre-amp input on the speech board? It should be half way between +5 and -10 volts (i.e. around -2.5 volts). Pin 3 should be the same voltage and probably pins 1, pin 2 and pin 7 should be thereabouts.

U7- pin 1, +4.4
pin 2, -8.7
pin 3, -1.6
pin 5, -2.1
pin 7, -2.4

Quoted from Quench:

The only other things I would do is confirm you're actually getting -10 volts at pin 21 on the speech chip itself and that you have pulsing clock activity at input pin 3 of the speech chip.

U 8- pin 21, -10.0
pin 3, both high and low, pulsing.

#65 11 months ago
Quoted from Quench:

Are/were the state of U4 pins 10, 12 and 15 "high" when you you took/take these measurements? If yes, the pre-amp is muted.

U4 pins 10, 12, and 15 were high.

Quoted from Quench:

Do these 3 voltages on U7 change after solenoid test #29 when the three U4 outputs on pins 10, 12 and 15 go low? (pre-amp set to max gain)

When U4 pins 10, 12, and 15 go low, U7 pin 1 remains at +4.4 volts, pin 2 dropped from -8.7 to -8.0 volts, and pin 3 remained at -1.6 volts.

#67 11 months ago
Quoted from Quench:

Find resistor R22. Measure the voltage at the leg where "R22" is printed. It should measure the same as pin 3 of the U7 pre-amp.

R22 is, -1.8 volts, and U7 pin 3 is, -1.6 volts.

Quoted from Quench:

Find resistor R2. With the machine on, put a short circuit across that resistor. Do you hear any click/pop when you short the resistor? If you can keep the short in place what do you measure at pin 1 of U7?

I do hear a pop when I short R2. With the short in place U7 pin 1 is, -1.95, and without the short it is, -1.67 volts. Something changed after I put the short on R2. Now I have a loud hum even in attract, but if I unplug the speech board it goes away.

#69 11 months ago

TP 3 on the speech board is, -10.10 volts.

#70 11 months ago

I am not sure what is going on, but now the loud hum went away. I checked U7 pin 1 again, and now it is, -1.93 volts with R2 shorted, and back to, +4.4 volts without the short.

#72 11 months ago

I will check the resistors, and order a speech chip. I will make a follow up post after I get the chip.
Thank You

#73 11 months ago

I installed the new speech chip, but still no speech.

#75 11 months ago
Quoted from Quench:

Are you seeing any activity on the speech ROM pins when it's supposed to be speaking, i.e. after solenoid test #29?

What pins should I be checking, or should I be checking all of them?

#77 10 months ago
Quoted from Quench:

We're looking for any sign of life. Most of the ROM pins should have activity when the board is speaking. Probe pins 7 thru 11 and pin 18 which is a couple of address and data lines.

Pin 7 is high and pulses after solenoid 29.
Pin 8 is low and pulses after solenoid 29.
Pin 9 is constantly high and low pulsing.
Pin 10 is low and pulses after solenoid 29.
Pin 11 has nothing and then a weak pulse after solenoid 29.
Pin 18 is low and pulses after solenoid 29.

#79 10 months ago
Quoted from Quench:

You did plug in the smaller 5 pin connector onto the speech board that passes audio to the SB300 sound board?

Yes it is plugged in.

Quoted from Quench:

Are you getting any noise on power up now that you weren't before?

Nothing any different than before.

Quoted from Quench:

What's happening on the /BUSY signal at pin 9 of U6 before you start solenoid test mode, then in solenoid test mode between #29 and #08 then after #11?

It starts high then pulses low between #29 and #8 and then goes back high after #11.

#81 10 months ago
Quoted from Quench:

Really need an oscilloscope to see what's going on at this point. Are you able to access one from a friend?

Off hand I can't think of anyone that I can borrow one from.

Quoted from Quench:

Otherwise put your multi-meter on very low AC voltage setting. In solenoid test between #29 and #11 does the meter indicate any changes in voltage on pin 7 of U7 (first filter pre-amp output), then do the same on pin 3 of U1 (output of the volume attenuator) and finally pin 1 of U7 (output of final pre-amp going to the SB-300 sound board).

The voltages were not stable, but they did fluctuate more between #29 and #11. It seemed like there was less of a change on pin 3 of U1, than on pins 1 and 7 of U7. I had a spare chip for U1 so I changed it, but still no speech.

#83 10 months ago
Quoted from Quench:

What kind of voltages were you seeing? - they might be quite low so can be hard to measure with a multi-meter. Without seeing them on a scope, I can only presume that since you're getting voltage changes then the speech audio is there.

There is a lot of fluctuation in the voltages, so the numbers are the averages, but they do increase between #29, and #8.
U7 pin 7 is .061, and then .125 vac between #29, and #8.
U1 pin 3 is .059, and then .139 vac between #29, and #8.
U7 pin 1 is .056, and then .179 vac between #29, and #8.

Quoted from Quench:

Find resistor R24 on the SB300 sound board. Measure the AC voltage on the leg opposite where "R24" is printed. It should be about the same as U7 pin 1 voltage changes during solenoid test #29 through #11.

R24 on the SB300 is .043, and then .187 vac between #29, and #8.

Quoted from Quench:

Find resistor R1 on the speech board and measure the AC voltages on both legs during solenoid test #29 through #11.

R1 opposite of the print is .043, and jumps up to .244 vac during the sounds at #20 to #29.
R1 on the print side is .056, and goes up to .236 vac during the sounds at #20 to #29.
The voltages stay on the low side between #29, and #8.

#85 10 months ago
Quoted from Quench:

What kind of AC voltages do you read here when the SB300 is playing back sound effects in game mode?

I have .058 to .195 vac. I tested with just the background sound after starting a game, and the voltage would increase to the .195 after the pauses in the background sound.

Quoted from Quench:

BTW what happens if you turn the volume all the way up - do you hear any low level speech during solenoid test mode?

I don't hear any speech, but there is always a hum in the the background. At normal volume it is not to bad, but at full volume it is fairly loud.

#87 10 months ago
Quoted from Quench:

You 100% sure the speech EPROM is good and not blank?

No I am not sure, but I had 2 burned, and I have the original. I have tried both of the new chips, but I probably should try the original now that I have replaced other things on the board.

Quoted from Quench:

I hate shotgunning but without an oscilloscope there's not much more I can do to diagnose further. Having said this, all you're left with is a faulty pre-amp (U7), faulty attenuator (U1) or faulty speech chip (output not working).
The U7 pre-amp is known as an op-amp and replacement part numbers are LM1458 or MC1458 - they're cheap.
U1 is a 4051 CMOS analog multiplexer chip - should also be cheap.

I will order some of the 1458's for U7, and I have changed U1 twice.

Quoted from Quench:

Have you changed the resistors I mentioned in post #71 to higher precision (1%) parts?

I checked the values and they were only a little off. I will order replacements with my order.

1 month later
#89 9 months ago
Quoted from mof:

Any updates?

I just replaced R18, R19, R20, R21, and U7, and still have no speech. I am about ready to give up on this one. Quench says that we have gone as far as we can without a oscilloscope.
Thanks to Quench, and the others that tried to help with this.

Promoted items from the Pinside Marketplace
From: $ 170.00
From: $ 100.00
Playfield - Protection
Beehive Pinball Co.
From: $ 14.00
Electronics
Third Coast Pinball
$ 9.00
Cabinet Parts
Third Coast Pinball
From: $ 1.00
Playfield - Other
Rocket City Pinball
From: $ 45.00
Displays
PinballSolutions.eu
$ 12.00
Electronics
Third Coast Pinball
Wanted
Machine - Wanted
Fort Worth, TX
From: $ 18.00
Apparel - Men
Pinside Shop

You're currently viewing posts by Pinsider squad8.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside