(Topic ID: 224861)

Flicker on all bulbs after warmup

By mjbreitbach

2 years ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by CoPinfan
  • Topic is favorited by 1 Pinsider

You

Linked Games

You're currently viewing posts by Pinsider mjbreitbach.
Click here to go back to viewing the entire thread.

#1 2 years ago

Hey all - new to the forum and new to owning a pinball machine! My father has a 1978 Bally Star Trek, and I've played it for over 20 years and loved it. My wife surprised me for my 40th with a 1993 Judge Dredd. I'm trying to troubleshoot an issue that I'm noticing on the system and I can't find any good resources after googling for few days and scraping the forum (maybe my search skills are just bad).

After warming up, all GI bulbs are flickering. Previous owner had replaced some of the bulbs with LED's, but the all of the backglass lights are still incandescent. I've reseated all of the power connectors to the lamp driver board, but still the issue persists. Is it possible for cheap LED's to backfeed and cause flicker in all GI lights? I've tried reading a lot about them but still haven't found a good answer.

I'm attaching a video of the flicker, hopefully someone has seen this before and could give me a starting point.

#4 2 years ago

Power save turned off. It was set to 5 minutes. I'll give it a little bit and see - Thanks for the suggestion!

#5 2 years ago

2 games down, 10 minutes passed, lights are looking good - sounds like power saver was the trick - Thanks so much!

You're currently viewing posts by Pinsider mjbreitbach.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside