(Topic ID: 266520)

Flashers not working, pls help!

By Corey_Fleming

1 year ago



Topic Stats

  • 8 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by pintechev
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hi guys,
On my SMB pinball machine all the flash lamps work in the headbox, but none of them work on the playfield! Any ideas? They aren't dead.

#2 1 year ago

Which transistor(s) control them and is that transistor working?

#3 1 year ago

I fixed it and it's working now, yes it was a transistor. But then I turned it on and it blew the playfield illumination fuse, I replaced it and it blew again, I'm afraid it'll catch fire or something if I try again. The fuses are the right voltage so I dunno what the problem is...

#4 1 year ago

Fuses typically blow due to shorts. I would carefully examine all of your wiring and see if something is shorting out. Also - pull the GI connectors from the boards and see if the fuse blows, if it does, you have a board issue. If it doesn't, you have a wiring issue.

#5 1 year ago

Which board controls fuses? (I'm a pinball noob)

#6 1 year ago

I am not familiar with Gottlieb; hopefully someone else with experience can better guide you.

#8 1 year ago

Bump so you see this.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside