New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 133718)

Flash Won't Boot


By troxel

5 years ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 5 years ago by troxel
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 5 years ago

Recently got a Flash that would not boot. I have replaced sockets, 40-pin interboard connector, and all connectors on the cpu and driver board. Also installed new lamp matrix power resistors. Game just shows two solid LEDs. Put this on my bench so power should not be an issue. I burned Andre's test rom, but it's not doing anything in IC17.

Calling it a night, but wondering if anyone has any input on it.

Thanks!

#2 5 years ago

One thing I learned the hard way is that it won't boot unless the mpu board is connected to the driver board.

#3 5 years ago
Quoted from uncivil_engineer:

One thing I learned the hard way is that it won't boot unless the mpu board is connected to the driver board.

thats something i didn't know i thought you could test mpu board on the bench
and when it worked connect the driver board thanks for that info

#4 5 years ago

Have driver board connected to it. Doesn't leon's rom run with just the mpu? If so, where can I find the file for it?

#5 5 years ago

You do not need the driver board connected to run either Leon's or Andre's test ROM.

Leon's: http://www.pinwiki.com/wiki/index.php?title=Leon_Borre_Repairing_Williams_System_3-6_CPU_Boards

Andre's (better choice): https://pinside.com/pinball/forum/topic/wms-sys-3-7-andre-test-rom-usage-video-v2

Usage and link in the aforementioned thread.

viperrwk

#6 5 years ago

Switched out the cpu and now game is booting. Still messing around with the test rom on the bench and will report back with questions on it.

#7 5 years ago

I put the board back into the game, but didn't remember the PROM order (system 4 board). I rearranged them a couple times and finally got the game to come up. Now I am not able to coin up the game and start. Tried to put the game on free play (which it was) and the credit button isn't responding to adjustments. Put the game in 03 test to test switches and nothing registers.

Am I missing something obvious?

#8 5 years ago

Updated the roms to the greens version (along with soldering some bad solder joints) and now game is playing again. Will start the process of shopping this out. I know the drop targets will need quite a bit of attention, but looks like everything else played well.

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 9.00
1,400
Machine - For Sale
Mount Pleasant, SC
From: $ 5.00
Cabinet - Other
UpKick Pinball
$ 14.00
Electronics
Yorktown Arcade Supply
1,450
Machine - For Sale
Blaine, TN
From: $ 18.00
Apparel - Men
Pinside Shop
$ 12.00
Cabinet - Other
Siegecraft Electronics
Wanted
Machine - Wanted
Bokchito, OK
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 11.00
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 5.00
Playfield - Toys/Add-ons
UpKick Pinball
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 259.99
Cabinet - Toppers
Lighted Pinball Mods
$ 28.95
$ 209.99

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside