(Topic ID: 65903)

Flash Gordon: Saviors of the Universe Club


By TheShameGovernor

6 years ago



Topic Stats

  • 1,026 posts
  • 172 Pinsiders participating
  • Latest reply 54 minutes ago by FatPanda
  • Topic is favorited by 93 Pinsiders

You

Linked Games

Topic Gallery

There have been 522 images uploaded to this topic. (View topic image gallery).

27FC434B-314C-4AED-A946-044A95680183 (resized).jpeg
9D1F1876-3746-414C-A47C-3E467111164C (resized).jpeg
3FA04289-0E17-423C-A3ED-40F8F0A4F070 (resized).jpeg
IMG_0312 (resized).jpg
IMG_6532 (resized).JPG
IMG_1038_LI (resized).jpg
IMG_1035 (resized).JPG
IMG_1034 (resized).JPG
IMG_1026 (resized).JPG
IMG_1031 (resized).JPG
IMG_1025 (resized).JPG
IMG_1024 (resized).JPG
DSCN5535 (resized).JPG
FlashGordonStrobeTransformer_plug2a.jpg
FlashGordonStrobeTransformer_plug1a.jpg
image (resized).jpg

You're currently viewing posts by Pinsider zahner.
Click here to go back to viewing the entire thread.

#574 1 year ago

I would love to see another run. Maybe just a small hand grenade. I wonder if they would be interested if enough of us sent in requests?
BTW, I also asked the person selling the playfield what he wanted for it. Just to be fair, it included shipping and - I think - a set of plastics. Ultimately a bit too rich for my blood, so I too politely declined. He did immediately reply to me.

4 months later
#630 1 year ago

Nice. Looking forward to printing up a set.

2 weeks later
#640 1 year ago

Like them a lot, really nice, but are they for show only, or can we order/buy/get them from you?

Thanks

#643 1 year ago
Quoted from Mikonos:

Hi zahner!
Let me order to print the Free Play card and show result, and I will order copies for you, if you like results.
Best regards

Great. Thanks. I tough you did great work on both FG cards.

4 months later
#685 7 months ago
Quoted from epeabs:

Making some headway. Playfield is installed in the cabinet with new CPR plastics and Reese Rails and 2pac cleared shooter lane. Initially fired it up with the new NVRAM.WEEBLY mpu. My GI is currently not working, 90% of my inserts are, and backbox lights probably 40%. I did install all LEDs, but have not installed Comet's "Bally/Stern LED adapters" which may be a possible problem. It seems to want to credit a game, but doesn't kick ball to shooter lane, and flippers don't work. I haven't had time to delve into troubleshooting it yet. A CPR repro backglass "non mirrored" is on order. I will have to re-stencil and paint the cabinet come spring when it is warmer because it looks horrible compared to the playfield.
[quoted image]

That looks great. I did a standard cabinet repaint on mine, and it made a world of difference.
Want to see a ridiculously amazing cabinet paint job someone did, go to
https://pinside.com/pinball/forum/topic/bally-flash-gordon-restoration-and-customization/page/4?gallery#g

1 month later
#855 5 months ago
Quoted from Spraynard:

I think I’ll try putting in a stronger compression spring and see if that helps
The ball holders within the saucer are a bit worn, nothing too dramatic though. [quoted image]

Okay - nobody will like my solution, but I had the same frustrating issue [it was just the opposite direction - a mighty fling into the pop bumper] and the spring thing didn't work, the tab thing didn't work, none of the quick fixes worked - except one. I was going to put in a weaker coil, but as a stop-gap until I got around to that, I rummaged around and found a coil stop that had a much deeper reach than the stock one on the mechanism. I could not tell you what machine the replacement stop was from, it was just in a bag of old nasty goodies, but it worked, and it worked three years ago when I was rebuilding my then newly purchased FG, and I have long since abandoned the thought of messing with replacing the coil. It has for three years been very nicely popping out exactly as it should. it was a very mechanical,low tech way to restrict the throw of the plunger that has had no side effects as far as I know.

#859 5 months ago
Quoted from BJM-Maxx:

Any idea how much deeper that coil stop was? That is an ideal method if you have such a thing. I was contemplating stuffing something down the core of the sleeve to sit against my stop.

It was about twice as deep as the original. I actually tested my theory before I went on a scrounge for the part and put a headless, slotted bolt in the sleeve to see if my logic worked. I had that bolt in there for longer than I should probably admit, but it worked fine. Had I not found my deeper coil stop, I probably would have just left it there. It's not like the mechanism is a finely adjusted bit of technology, it's pretty much just hammers and anvils with a bit of remote electricity. But that's just me...

2 months later
#909 3 months ago
Quoted from MrSanRamon:

I've been playing my newly acquired FG for awhile and have a few questions, I'd appreciate it if someone could enlighten me.
Sound Option (setting 18): do you use 00, 01, 02 or 03...chimes, chimes & background, noise w/o background or noise w/ background?
The voice callouts "Flash", "Emperor Ming Awaits" sound somewhat garbled/scratchy, is that common or normal?
When either of the 15 second clock timer lights are lit, does that mean that scoring is just multiplied, or are you supposed to hit something? Is there a difference between the two 15 second timers?
Thanks.
Robert

If the sound is not clear, check with Big Daddy or another vendor for a soundboard rebuild kit. Caps and the like get old and I suspect that is what is causing your issue. Also, make sure all plugs and connections are clean and solders solid - but I bet it's a dried up cap or some other component on the soundboard.

#919 3 months ago
Quoted from MrSanRamon:

What do people have the slope of their game set too? I have mine at 5.5 deg, and thinking of going to 6.
The manual doesn't say, so any comments?
Robert

I keep mine at 6.5, and it seems perfect to me. 5.5 sounds pokey to me.

1 month later
#932 60 days ago
Quoted from wolffcub:

Got my Flash on the weekend. Has a few gremlins i need to address but its a nice future restore project.[quoted image]

Nice. Looks like it will clean up quite nicely - really good find!

#939 59 days ago
Quoted from wolffcub:

Is there a better replacement board to get of the few that are offered ?

I had luck with: http://www.bigdaddy-enterprises.com/

The board I bought is midway down the page. Been great.

#940 59 days ago
Quoted from zahner:

I had luck with: http://www.bigdaddy-enterprises.com/
The board I bought is midway down the page. Been great.

Actually, you have to click on the "new boards" link to the left, then go midway down that page. The site is sort of old school awkward, but I've always had luck with the vendor. Call to make sure it's in stock.

BTW: Love the remote bridge rectifier.

1 week later
#957 49 days ago
Quoted from kuchiyaji:

I can't find this game anywhere at all...isn't there anybody selling one?

Hard to find. Most keep once they own. There are two in the market section, but one is $4k, the other more. But the $4k one has a new PF and plastics and so you will never find a nicer example.
Regardless, one will eventually pop up. I found mine with blind luck

2 weeks later
#979 34 days ago
Quoted from UNCgump:

My single drop target in front of the bonus collect lane won't reset once it drops. Can I assume that's a solenoid issue?

So, it never goes up? Not at game start? Did you check the leaf switches and solder joints, linkage. You can test the solenoid by entering the diagnostic/test functions. You cycle through the test modes using the the little button on the inside top of the coin door.

#981 33 days ago
Quoted from UNCgump:

Yeah, never. It stays until the plunge if I set it up manually but never returns as it should. The leafs switch and solder joints all look normal. Thanks for the info. Will check it out.

Sounds like the solenoid is not firing ( which should be apparent when in test mode and cycling through tall the solenoids). It’s easy to replace ... and if that’s it, simple repair.

My MPU decided to go spuds up today after years of reliable performance. Guess my machine had sympathy pains....

2 weeks later
#988 16 days ago

I have a question regarding an issue with my FG's Pinpoint Bally Flash Gordon AS-2518-62 Strobe Board. I have had issues with it with various MPU boards since I installed the strobe a couple of years ago. Initially, I had it set up with the original MPU, and it worked, but did some weird stuff. The game sometimes wouldn't immediately boot, and the voicing and some sound effects from the sound board would not always work properly [half finished phrasing, starting in the middle of phrasing, sounds dropping off or starting in odd spots]. I replaced that MPU with an older Alltek MPU, and it was dodgy too, but other than the sound being kind of wacked out, it seemed to work. With both MPUs, if the strobe was unplugged, the game functioned perfectly.
Well, the Alltek MPU went spuds up and the good folks at Alltek did me a solid and replaced the board with a brand new one for a very reasonable fee. When I installed it - it would not boot at all. The LED on the board just kept flashing over and over, but no boot/start. Double checked voltage, and it was all good [all boards except the sound board are Alltek]. I unplugged the Pinpoint Strobe Board, and everything worked flawlessly. I kind of went over this before with the Alltek people and the Pinpoint folks, but they could not figure it out. Given the fact that the strobe messed with both the Bally and Alltek MPUs, it seems the issue is with the strobe or the machine [switch or something?]

Thoughts?

#996 15 days ago
Quoted from BJM-Maxx:

A couple of of power supply things you could try is to make sure there are no funny shorts between the strobe's dedicated little transformer and the main rectifier board. They should be isolated from each other. You could also physically lift it off the big metal plate and see if something changes.
With that new Altek, you can boot with the strobe unplugged? What happens if you plug it back in after you boot?
When you disconnect the strobe, where are you doing it? Are you unplugging the transformer at the rectifier board or up at the strobe board? You could try pulling the trigger wire (I cannot recall if it is triggered from the solenoid board or from the lighting board). But interrupting that one trigger wire would leave it powered but not firing. If that fixes something then it would seem to be the strobe board firing an unwanted signal back into the MPU.

Thanks to all. A lot of good suggestions.
I am indeed unplugging the strobe at the strobe board. I’ll look at the suggested junctures and report back. Glad to hear I’m not the only one chasing this down.
Thanks again for the posts folks.

Promoted items from the Pinside Marketplace
$ 90.00
$ 16.00
Electronics
Yorktown Parts and Equip
From: $ 140.00
$ 149.95
Boards
Allteksystems
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 159.95

You're currently viewing posts by Pinsider zahner.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside