(Topic ID: 65903)

Flash Gordon: Saviors of the Universe Club


By TheShameGovernor

6 years ago



Topic Stats

  • 1,153 posts
  • 184 Pinsiders participating
  • Latest reply 8 days ago by Skypilot
  • Topic is favorited by 100 Pinsiders

You

Linked Games

Topic Gallery

There have been 579 images uploaded to this topic. (View topic image gallery).

ro (resized).png
IMG_2632 (resized).jpg
4402f64f9ba1b18c2ade44c8de1ebecd11e24e39.jpeg (resized).jpg
earthling (resized).jpg
20200224_181216 (resized).jpg
20200220_184144 (resized).jpg
PHOTO_20200202_135612 (resized).jpg
PHOTO_20200202_135656 (resized).jpg
PHOTO_20200202_135651 (resized).jpg
PHOTO_20200202_135558 (resized).jpg
PHOTO_20200202_135547 (resized).jpg
DSCN6494 (resized).JPG
Flash Gordon - Score Card (resized).jpg
Flash Gordon - Instructions (resized).jpg
Flash-Gordon-Score-Cards (resized).jpg
UPPER FLIPPER (resized).jpg

There are 1153 posts in this topic. You are on page 12 of 24.
#551 1 year ago
Quoted from Captive_Ball:

I'll have to take a look at that...thanks for the info. Do you happen to have a link to that post or tell me which thread to look for it?

Yeah man. Right here https://pinside.com/pinball/forum/topic/taxi-2018-hep/page/10#post-4207373

I asked about doing it on TWD, since it is is pretty normal for that game. But thankfully, it was remedied by Titan's thin flipper rubber.

#552 1 year ago

So I aligned the flippers so the hole is lined up with the bottom edge of the flipper, instead of being centered on the flipper tip, and it plays MUCH better now. That alignment happens to line up the flipper with the ball guides. Next question is, what do you have your Dip Switches set at? I started off with all "Conservative" setting but then moved them to "Recommended Settings" in the manual. Thinking about moving them back.

Also, what slope do you have yours set at? Mine is right around 6.5 right now, but thinking about going all the way up in the back, or to about 7.5? I like it fast and deadly. No mercy!

#553 1 year ago

thought 6.5 was a bit too much for the early SS games.

What are your dip settings?

#554 1 year ago

Whatever the recommended settings are in the manual. I'll get a pic of it when i get home, or you could look it up on IPDB.

Quoted from wm6929:

thought 6.5 was a bit too much for the early SS games.
What are your dip settings?

#555 1 year ago

Was wondering what consenous was for preferred settings.
Would like to get close to running tournment settings.
I am going to work on it this weekend.

#556 1 year ago

pasted_image (resized).png

#557 1 year ago

With the dipswitch ON, it retains lit shots from ball to ball. If it is off, it does not, so making it harder to get 2X playfield, Lit drop targets, etc.

I've learned that over that last couple days, even with the switches on, I can barely break 1 mil. that 1.5 Mil game I had must have been a fluke...

#558 1 year ago

I think getting 7 digits on your score is always an accomplishment.

#559 1 year ago

Does anyone know if Flash Gordon uses an extra long shooter rod than other games? I bought a new rod from PBR but it is much shorter than the old one. The new on is on the left.

37003 (resized).jpeg

#560 1 year ago

Making sacrafices and tearing into FG so future pinheads can get rails easy from reese rails

1B52F1DF-5572-47CA-8054-41B886C41179 (resized).jpeg

#561 1 year ago
Quoted from flynnibus:

Making sacrafices and tearing into FG so future pinheads can get rails easy from reese rails

Thank you, Thank you, Thank you......I was one of the fellows that reached out to Reese about a month ago inquiring about a set of these. You are a true friend of the crown.

pasted_image (resized).png

#562 1 year ago
Quoted from Captive_Ball:

Thank you, Thank you, Thank you......I was one of the fellows that reached out to Reese about a month ago inquiring about a set of these. You are a true friend of the crown.

Dilly dilly

2 weeks later
#564 1 year ago

Thanks! Sent him a PM about selling since he's listing specifically for a trade.

#565 1 year ago

Anyone install a nbii recently. Just curious if there was any new firmware that allows us to use sounds of any length? Or are we still limited to the length of the original stock sound?

http://www.steflip.fr/index.php?file=Boutique&op=art&catid=8&artid=146

#566 1 year ago

I talked to them last month, and he said that he was not interested in making any more. It may be the same for support.

#567 1 year ago
Quoted from FatPanda:

Thanks! Sent him a PM about selling since he's listing specifically for a trade.

I sent him a message over a week ago, does not respond for some reason. Why do people do that???

#568 1 year ago
Quoted from timab2000:

I sent him a message over a week ago, does not respond for some reason. Why do people do that???

There was "sale pending" when I looked last. Also, he wanted quite a bit for the PF, so i politely declined

#569 1 year ago
Quoted from FatPanda:

There was "sale pending" when I looked last. Also, he wanted quite a bit for the PF, so i politely declined

How much???

#570 1 year ago

1750

#571 1 year ago

WOW!!! I can buy the whole machine for that

#572 1 year ago

Yeah, that's why I passed

#573 1 year ago

do we need to mail bomb CPR into doing another run of playfields?

#574 1 year ago

I would love to see another run. Maybe just a small hand grenade. I wonder if they would be interested if enough of us sent in requests?
BTW, I also asked the person selling the playfield what he wanted for it. Just to be fair, it included shipping and - I think - a set of plastics. Ultimately a bit too rich for my blood, so I too politely declined. He did immediately reply to me.

#575 1 year ago

Sounds like a hard top playfield is nearly complete...

2 weeks later
#576 1 year ago

Im wondering if anyone could lend me some knowledge on some issues im having with my FG after putting it back together.

Game boots and plays but only a few solenoids are working(flippers, drop resets, and saucer eject down) and the game will reset if the left pop bumper is activated. I dont know if its relted at all but the BG controlled lamps are inop as well.

I have ~44v at all coils, switch test no stuck switches and all fuses are good. If I jump the transistors to gnd on the driver board, coils Q1-Q6 will fire and the relay for Q15 activates as well but nothing else.

The game has been apart for over a year now while i worked on the cab and a pf swap. I realized im not getting to the pf swap anytime soon but I really want to ply this game again.

Any help is greatly appreciated!

B0CEBB2B-69BF-4C12-B24F-A2763C4E364D (resized).jpeg

#577 1 year ago

Pull the playfield fuse (depowers solenoids) now you can check if any switches actually cause a reset like the left pop bumper. This will isolate switching issues from the high power mechanism issues. You need to look carefully at which backglass lights are not working. The Aux lighting board drives lights on the insert as well as a few on the playfield. Are the Aux board lights on the playfield working? Its possible because the power feed for them comes from the PF and on the insert those ones have a different power feed. The Aux board only grounds them so lights in one place can be working with the others not working. Or is the power to the Aux board itself missing in which case none of its lights will be working (PF or insert).

On my FG I had an issue where the harness that pivots between the door and the head was tugging on a pin feeding the Aux board causing flakey behaviour.

#578 1 year ago
Quoted from BJM-Maxx:

Pull the playfield fuse (depowers solenoids) now you can check if any switches actually cause a reset like the left pop bumper. This will isolate switching issues from the high power mechanism issues. You need to look carefully at which backglass lights are not working. The Aux lighting board drives lights on the insert as well as a few on the playfield. Are the Aux board lights on the playfield working? Its possible because the power feed for them comes from the PF and on the insert those ones have a different power feed. The Aux board only grounds them so lights in one place can be working with the others not working. Or is the power to the Aux board itself missing in which case none of its lights will be working (PF or insert).
On my FG I had an issue where the harness that pivots between the door and the head was tugging on a pin feeding the Aux board causing flakey behaviour.

Thanks, ill pull the pf fuse and check it out tonight. All my insert lights work but the lights behind “Flash Gordon” letters in backbox are inop.

#579 1 year ago
Quoted from Spitfiren8:

Thanks, ill pull the pf fuse and check it out tonight. All my insert lights work but the lights behind “Flash Gordon” letters in backbox are inop.

Those are all powered by the Aux board. Check the two clock inserts in the playfield they come the same board as do the upper play field roll overs that blink.

#580 1 year ago

Man I had a hell of a first ball today. What a rush that was!

#581 1 year ago

Nice ball one.....the other 3 balls all look like standard FG punishment....especially loosing the ball down the right outlane after making a good shot to the inline drops.

Great score....could sense your happiness through a few remarks during that first ball

#582 1 year ago

Yep that's for sure. Punished if you miss a shot. Punished if you make a shot.

I really thought I had a shot to break my high score, but honestly I was just happy to get that ball on film. That bonus score countdown was outstanding!

FG such a great game, no matter how painful it is

#583 1 year ago
Quoted from BJM-Maxx:

Pull the playfield fuse (depowers solenoids) now you can check if any switches actually cause a reset like the left pop bumper. This will isolate switching issues from the high power mechanism issues. You need to look carefully at which backglass lights are not working. The Aux lighting board drives lights on the insert as well as a few on the playfield. Are the Aux board lights on the playfield working? Its possible because the power feed for them comes from the PF and on the insert those ones have a different power feed. The Aux board only grounds them so lights in one place can be working with the others not working. Or is the power to the Aux board itself missing in which case none of its lights will be working (PF or insert).
On my FG I had an issue where the harness that pivots between the door and the head was tugging on a pin feeding the Aux board causing flakey behaviour.

So I pulled the under pf fuse and the game still resets if the left pop switch is activated, this is the only switch that causes a reset. Under pf wiring looks fine.

I have a feeling i need to repin all my connectors. Can i swap in my Medusa mpu to troubleshoot or will that cause any issues? I already slaved in the solenoid driver from medusa and the same issues were persistant.

#584 1 year ago

Very hard to understand how a single switch can cause that. Nothing similar from the other switches on the same column or row of the matrix? Is it like hitting the slam switch? All other switches score normally? Make sure there is no continuity between the switch leads and the solenoid power lines.

#585 1 year ago
Quoted from BJM-Maxx:

Very hard to understand how a single switch can cause that. Nothing similar from the other switches on the same column or row of the matrix? Is it like hitting the slam switch? All other switches score normally? Make sure there is no continuity between the switch leads and the solenoid power lines.

It doesnt go into tilt it just resets. All other switches score normally and dont cause a reset.

#586 1 year ago

This may be a rabbit hole but the slam switch resets the machine, different than a tilt. Most playfields have a slam switch near the bottom middle oriented to trigger if the machine is dropped. Whether that switch is there or not, the matrix believes it was triggered. If it is there, try that switch, you should get the same reset. You could try disconnecting either the column or row that the bumper may share with it.

#587 1 year ago
Quoted from Spitfiren8:

So I pulled the under pf fuse and the game still resets if the left pop switch is activated, this is the only switch that causes a reset. Under pf wiring looks fine.
I have a feeling i need to repin all my connectors. Can i swap in my Medusa mpu to troubleshoot or will that cause any issues? I already slaved in the solenoid driver from medusa and the same issues were persistant.

If you disconnect the cabinet, coin door, and pf slam tilt switches, does triggering the left pop bumper still cause a reset? Is there a diode connected on the pop bumper switches?

#588 1 year ago

Disconnected all 3 slam switches and the left pop switch still causes a reset. There is a diode on the switch...

8BA9203E-CE6F-45D8-B36C-51986F76A38B (resized).jpeg
#589 1 year ago

Maybe quench has an idea? The wiring on the switch looks fine to me. I'm wondering if there's any battery damage to the MPU or something like that?

#590 1 year ago

Mpu looks clean, can i swap in my medusa mpu to test?

#591 1 year ago

No one is going to mention the new y5f cap that’s marked 12v? Ok I’ll keep watching

#592 1 year ago
Quoted from Tallon:

No one is going to mention the new y5f cap that’s marked 12v? Ok I’ll keep watching

Are these incorrect? The same caps are on the other switches as well. I thought they were original?

#593 1 year ago
Quoted from Tallon:

No one is going to mention the new y5f cap that’s marked 12v? Ok I’ll keep watching

I'm pretty sure those are all original as I swapped a bunch out of my own game due to phantom switch hits.

#594 1 year ago

Ok. Just throwing it out there. Pretty sure they are suppose to be 50v not 12v. Not sure if that could cause the phantom switch but....

https://pinside.com/pinball/forum/topic/replacement-switch-capacitorolder-bally-pins

2 weeks later
#595 1 year ago

Tried to search for the stand up target on the upper playfield with no luck. Part number is ASE-2911-21, does anyone have a link to purchase one, or know a suitable replacement?

10
#596 1 year ago

So I’m trying to figure out ways to make my flash Gordon play faster. Do you think the wheels will help?

986381C5-1AD7-441B-BE07-479E475AF8DE (resized).jpeg
#597 1 year ago

You need bigger wheels in the back

#598 1 year ago
Quoted from Skypilot:

So I’m trying to figure out ways to make my flash Gordon play faster. Do you think the wheels will help?

What’s that I see on the bench behind FG? Could it be!? Is it real!!?

#599 1 year ago

I may be a little too excited seeing that Hard Top playfield

#600 1 year ago
Quoted from Andyzola87:

What’s that I see on the bench behind FG? Could it be!? Is it real!!?

Yes, that is a real Dewalt miter saw. They’re pretty nice!

Promoted items from the Pinside Marketplace
$ 149.95
Boards
Allteksystems
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 149.00
From: $ 155.00
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
There are 1153 posts in this topic. You are on page 12 of 24.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside