(Topic ID: 174394)

First post : pop bumper fires when spinner hit


By spacemonkey555

4 years ago



Topic Stats

  • 17 posts
  • 5 Pinsiders participating
  • Latest reply 4 years ago by spacemonkey555
  • No one calls this topic a favorite

You

Linked Games

  • Galaxy Stern Electronics, 1980

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

tmp_27691-IMG_20161127_223645615-1448268148.jpg
SternGalaxySwitchAssignments (resized).jpg
SternGalaxySwitchMatrix (resized).jpg
SternGalaxySwitchTest (resized).jpg
SternGalaxyPlayfieldParts (resized).jpg

You're currently viewing posts by Pinsider spacemonkey555.
Click here to go back to viewing the entire thread.

#1 4 years ago

1980 Stern Galaxy. The lower right pop bumper keeps firing while the spinner keeps spinning. All and any help would be appreciated.

#3 4 years ago

I do not have the schematic but I will be downloading it soon. The two switches are not close together. I did look into the machine. I have another galaxy and it looks like they have two different style switches on either machine. I am a novice and new to pinball so any explanation in layman's terms would be awesome.

#5 4 years ago

Okay I got the wiring diagram. It says that the spinner Target shares a white / green wire with the lower-right pop bumper And the left turn lane and stand up Target. First I checked the wires going to the switch on the spinner and they are correct then I checked the diode on the switch for the spinner and that is in order. Then I went over to the pop bumper checked it and the diode on the switch for it and it all checks out. I know you said that there should not be continuity between the spinner and the pop bumper but they do share the white/green wire. I just checked the diode on the center yellow drop target. Just scratching my head over here. I forgot to mention that this machine is new to me I have not gotten used to the gameplay. I did notice that sometimes the pop bumper fires with the spinner and sometimes it does not. Could it be the sdu board?

#8 4 years ago

Okay gentlemen thank you for all of your support. I tried putting paper on the switch for the spinner and the paper blocks. it does not work. I gaped the switch and still has the same issue. I play the game with the glass off and kept spinning the spinner while hitting different things on the Playfield and found out that the pop bumper acts up only when you hit the yellow drop Target on the left I am going to check the diode on the switch before anything else. I have found a few other inconsistencies but I will get to that later. Please let me know if I should be checking for anything else besides the diodes.

#9 4 years ago

Okay guys I checked the diode on the yellow drop Target on the left and the diode is fine. I also switched out the switch on the spinning Target and I have the same results of the pop bumper firing when the spinner spins while the yellow drop Target is down. Any clues anyone?

#12 4 years ago

I think this project might be a little bit out of my Realm. I did put a piece of paper between the contacts of the switch for the lower right pop bumper with the yellow drop Target down spinning the spinner and it did fire even with the paper in between the switch. I might need someone local to take a look. I will try the switch test before finding someone. The sad part is that I already replaced mpu, rectifier and put LEDs. It looks awesome though.

#14 4 years ago

Thank you ,Yeoldpinplayer, for all of the info. I will read up later tonight when I get home.

"Quench" The problem occurs when the yellow drop target is knocked down only and the spinner is hit. It makes only the lower right pop bumper fire. When the yellow target is reset in the up position, it does not make the lower right pop bumper fire.

I do have a new symptom. When the yellow and red drop target are down, the top pop bumper goes dead.

Just to recap:

Yellow drop target down + spinner = lower right pop bumper fires.

Yellow + red drop target down = dead top pop bumper

#17 4 years ago

"Happy Days Everyone"
I would like to thank all the members here at pinside for helping me track down this gremlin. The problem was the brown/white wire on the center coin chute. It was on the wrong lug. I purchased the machine non working and replaced the MPU with an Altec and replaced the rectifier board since it was very toasty . Everything on the playfield works as it should thanks to you all. I owe you guys a beer if ever in Maryland.

tmp_27691-IMG_20161127_223645615-1448268148.jpg

Promoted items from the Pinside Marketplace
$ 12.00
Electronics
Third Coast Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 7.00
From: $ 14.00
Electronics
Third Coast Pinball
From: $ 1.25
Playfield - Other
Rocket City Pinball
$ 9.00
Cabinet Parts
Third Coast Pinball
From: $ 10.00
From: $ 170.00

You're currently viewing posts by Pinsider spacemonkey555.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside