(Topic ID: 320237)

Firepower sound board failure

By csab00

3 months ago



Topic Stats

  • 10 posts
  • 3 Pinsiders participating
  • Latest reply 87 days ago by Schwaggs
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Sound  (resized).png

#1 3 months ago

Hi!

I am renovating my Firepower sound board.
It was working cca 2 years before i put the board to the shelf as a spare.
I have decided yesterday to change all capacitors and test it.

The board producting this strange noise only:

Do you have an idea what could be wrong?

(The eprom and the voltages are)
I have tried with another speech board the result was the same.

#2 3 months ago
Quoted from csab00:

Hi!
I am renovating my Firepower sound board.
It was working cca 2 years before i put the board to the shelf as a spare.
I have decided yesterday to change all capacitors and test it.
The board producting this strange noise only:
Do you have an idea what could be wrong?
(The eprom and the voltages are)
I have tried with another speech board the result was the same.

Reflow solder on Y1 legs
Retest

Sound (resized).png
#3 3 months ago
Quoted from PINTEC:

Reflow solder on Y1 legs
Retest[quoted image]

You mean the quartz crystal for the CPU?
I did it but it did not helped.
I also reflowed the connectors...

#4 3 months ago
Quoted from csab00:

You mean the quartz crystal for the CPU?
I did it but it did not helped.
I also reflowed the connectors...

Suggest another Microprocessor
NO?

Replace Y1

#5 3 months ago

What was the problem before you recapped if?

You are using the ROMs from a known working board?

Have you checked if the cpu is running? Logic probe on the address or data bus pins of the cpu.

Try swapping in the cpu from the working board.

Then I would suspect the main board Rom and or Cpu sockets.

#6 3 months ago

Hi!
The board was working but I have not tested before recapped it most probably it get broken before I did it.
I have not checked with a logic tester but it must be running becouse it switching the sound
just playing them badly.
The eprom is good, CPU is good, quatz is good.
(I have tried it with brand new CPU)
I think when the CPU is bad then nothing happens...

Quoted from Schwaggs:

What was the problem before you recapped if?
You are using the ROMs from a known working board?
Have you checked if the cpu is running? Logic probe on the address or data bus pins of the cpu.
Try swapping in the cpu from the working board.
Then I would suspect the main board Rom and or Cpu sockets.

#7 3 months ago
Quoted from csab00:

Hi!
The board was working but I have not tested before recapped it most probably it get broken before I did it.
I have not checked with a logic tester but it must be running becouse it switching the sound
just playing them badly.
The eprom is good, CPU is good, quatz is good.
(I have tried it with brand new CPU)
I think when the CPU is bad then nothing happens...

Quoted from csab00:

Hi!
The board was working but I have not tested before recapped it most probably it get broken before I did it.
I have not checked with a logic tester but it must be running becouse it switching the sound
just playing them badly.
The eprom is good, CPU is good, quatz is good.
(I have tried it with brand new CPU)
I think when the CPU is bad then nothing happens...

What are the dip switches set to? They should both be ON.

I would replace the CPU and ROM socket next.

3 weeks later
#8 3 months ago

I was working on the board and had replaced couple of components :

6821 PIA and socket
Eprom socket
MC1408 DA converter
Quartz crystal Y1
Reflowed the amplifier

(The eprom is good)
CPU is good but i have not replaced its socket yet.

Unfortunatly the error is still there.
Interestingly after i replaced the 6821 the sound started to working normaly then it went to the bad state again.

CPU and PIA is running i have checked them with the LEON test eprom!

#9 87 days ago

I have replaced the 6810 RAM that was the bad part.
I should have started with LEON especially the memory test!

#10 87 days ago

Thanks for posting the resolution!

Promoted items from the Pinside Marketplace
$ 25.00
Apparel - Men
Pinside Shop
Men
From: $ 1.25
Playfield - Other
Rocket City Pinball
Other
$ 27.95
Eproms
Pinballrom
Eproms
$ 11.00
Electronics
Yorktown Arcade Supply
Electronics
$ 15.00
Playfield - Protection
UpKick Pinball
Protection
$ 14.00
Electronics
Yorktown Arcade Supply
Electronics
Wanted
Machine - Wanted
Memphis, TN
From: $ 9.00
Boards
KAHR.US Circuits
Boards
$ 129.00
Cabinet Parts
Bob's Pinball Stuff
Cabinet parts
From: $ 90.00
Tools
Pincoder Store
Tools

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!