(Topic ID: 262226)

Firepower right sling killing board


By SmasheyBashe

4 months ago



Topic Stats

  • 12 posts
  • 5 Pinsiders participating
  • Latest reply 4 months ago by SmasheyBashe
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

20200218_102402 (resized).jpg

#1 4 months ago

Hey all, I'm having a hard time tracking down what's killing my firepower board. I've got the mpu/driver combo and I follow the installation instructions and get as far as being able to start a game. As soon as I trigger the right sling IC7 fries on the board.
I've gone through the game and I have tested every diode under the playfield and replaced any that were even slightly suspicious. I have every solenoid unhooked right now (red wire off and certain non of them are touching anything). The game was previously working, but it has been broken for a few years and am now trying to get things going again. Prior to the new board being installed I had found one of the orange wires on the right sling had fallen off and was likely shorting to ground, which I had fixed. Would it be possible that the small capacitor on the switch would be bad and that's causing the issue?

Thanks in advance for any help you can give me.

#2 4 months ago

post some pics. im guessing you put the orange wire in the wrong spot.

#3 4 months ago

And what is the function if IC7 on that board? Is that part of the solenoid driver circuit or some other part?

Did you replace the diode on the sling coil? It may test good but isn't working at higher voltages.

#4 4 months ago
Quoted from Schwaggs:

And what is the function if IC7 on that board? Is that part of the solenoid driver circuit or some other part?
Did you replace the diode on the sling coil? It may test good but isn't working at higher voltages.

I can't remember if that was one of the diodes that I replaced or not (I did test every diode and replaced any the were even slightly suspicious), but all of the coils have their red wire disconnected, so don't think that could be the issue...

Edit: so far as I know, ic7 is for the "special solenoids" ie the slings and pops.

#5 4 months ago
Quoted from wiredoug:

post some pics. im guessing you put the orange wire in the wrong spot.

Here's the right sling. I had a close look and it's wired up exactly the same as the left sling.

20200218_102402 (resized).jpg
#6 4 months ago

measure dc volts across the switch with it open.

#7 4 months ago

Where is the wire for the second coil lug?

#8 4 months ago
Quoted from goingincirclez:

Where is the wire for the second coil lug?

hes cut them all off... im guessing its on the switch

#9 4 months ago

On a related note, hit up barakandl to see if he plans on restocking his (awesome!) Special Solenoid Saver board: https://nvram.weebly.com/repair--conversion-kits.html

#10 4 months ago
Quoted from wiredoug:

hes cut them all off... im guessing its on the switch

Definitely not. I made absolutely sure that none of the solenoid wire were touching anything.

#11 4 months ago
Quoted from SmasheyBashe:

Definitely not. I made absolutely sure that none of the solenoid wire were touching anything.

you also cut all the coils out? .. seems you're out of your depth.. might be time to call a tech

did you measure the voltage potential across the switch yet?

Ive seen this once on a gorgar. melted the loom with a 25v dead shot back to the ground on the kicker switch wire but i never worked out why as it stopped doing it when i stripped it all out and fixed it ( i changed too many things at once to monitor why)

#12 4 months ago
Quoted from wiredoug:

you also cut all the coils out? .. seems you're out of your depth.. might be time to call a tech
did you measure the voltage potential across the switch yet?
Ive seen this once on a gorgar. melted the loom with a 25v dead shot back to the ground on the kicker switch wire but i never worked out why as it stopped doing it when i stripped it all out and fixed it ( i changed too many things at once to monitor why)

I'm out of town for a few days, I'll check out that voltage when I get home & report back. I wish there was a tech available, my only local option doesn't want to work on sys 6

Promoted items from the Pinside Marketplace
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 11.00
$ 50.00
$ 14.00
Electronics
Yorktown Arcade Supply
From: $ 9.00
1,250
Sale Pending!
Gardner, MA
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 27.50
$ 29.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 87.00
Playfield - Toys/Add-ons
Lermods
From: $ 9.99
Eproms
Matt's Basement Arcade

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside