(Topic ID: 222635)

Firepower Locked Coil at Startup **Solved**

By scupbucket

5 years ago


Topic Heartbeat

Topic Stats

  • 13 posts
  • 3 Pinsiders participating
  • Latest reply 5 years ago by aztarac
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

Capture (resized).PNG

#1 5 years ago

Bought an MPU327-3 In May and finally have it installed in my Firepower. Game and diagnostics worked fine for a few days but now the left kicker (solenoid 22) is locked on but only when a game is started after pressing the start button. When the machine powers on, the coil isn't energized at all. Only when a game is started. When running the solenoid test in diagnostics mode, the coil locks on as well. The driver for the kicker, Q12, tests fine. Dropped the folks at Rottendog a message too but was wondering if anyone here might have had a similar problem or suggest somewhere to start? Thanks!

#2 5 years ago

Sounds like the switch for the left sling is stuck closed, or there's a short in the wiring. Does unplugging 2J13 fix it?

#3 5 years ago

Hey Zac! Nope... unplugging the actual special solenoids connector (2J12) does but not the special switch input connector.

BTW... still got the old boards for you. Let me know next time you're in town...

#4 5 years ago

In that case it sounds like an issue with the board itself in the circuitry that fires the solenoid when the pin on 2J13 goes low. If I had the schematics for the RD board I could probably point you to a chip, but I'm not sure if they're available?

#5 5 years ago

Sent you an email with scans of the schematics... the drivers run back into IC9 which looks like a buffer according to the part number?

#6 5 years ago

IC9 appears to be an inverting buffer, so it'll be easy to check whether it's the problem, just compare pins 4 and 16 are both high. If IC9-4 is low, however, then you'd have to go back to IC7C and check the two inputs (pins 9+10) of that. If either is low that'll cause the kicker to turn on. 9 should read high unless the sling switch is closed (so always high with 2J13 unplugged), and 10 should read high except during solenoid test when the CPU fires the coil. It could also be a bad pullup at SIP6 leaving the input to pin 9 floating, but that's less likely.

Capture (resized).PNGCapture (resized).PNG
#7 5 years ago

Ok... making progress here I think. Here's what I found:

In game-over/attract mode - IC9 pin 4 and 16 are low
In-game - IC9 Pin 4 is low and 16 is high

Both during game-over/attract and in-game - IC7C pin 9 is reading nothing at all but pin 10 is reading high

In diagnostics mode - IC7C pin 9 again nothing and pin 10 alternated between high and low as solenoid fires

Thinking IC7 might be the culprit?

#8 5 years ago

Alright, so it's not IC9. What do you mean about pin 9 reading 'nothing'? It should be high all the time when 2j13 is unplugged due to the pullup. With the game off, can you measure the resistance from pin 9 to 5V/VCC? and compare with the resistance from pin 12? Should both be 4.7kohm

#9 5 years ago

IC7 pin 9 is giving no reading at all with 2J13 unplugged, either in attract or in-game. Nada. Weird...

Tested resistance with test point VCC - On IC7, pin 9 is .09k and pin 12 is .02k. They're way off... aaaaand that might be because now the right kicker isn't working at all. I compared readings with the special solenoids for IC8 (pop bumpers) and all those test a solid 4.7k.

#10 5 years ago

That's... weird. I wouldn't have expected the IC to affect the resistance readings. Maybe it's just a coincidence though... Normally I'd suggest pulling the SIP resistor and checking it out of circuit, but since this is a new board maybe there's some warranty option that would be better?

#11 5 years ago

I'm tempted to test it but yeah, to your point I'll see if there's some warranty goodness involved. Or maybe even some additional info from RD. I thought I had a good hang of the original MPU/driver and then got hit with this which is a whole different animal... tons of thanks for the help though, dude. Gives me a better understanding of what makes these things tick.

#12 5 years ago

Just spoke with Jim at RD this AM... dude is rock n roll all the way. Narrowed it down to exactly what we suspected and I swapped in a new 7408 at IC7 and we're back in business. Aside from me wanting to burn this game to the ground every time a problem comes up (I keep reminding myself these are 40+ year old toys and they need constant work) this has been fun figuring out the problems. Thanks for all your help zacaj and a big shout out to Jim at Rottendog for getting back to me so quickly and confirming the problem. I'm gonna go fry something else on the game while putting this hardtop in.

edit - I think I shorted a switch to a solenoid which fried IC7. Whoops!

6 months later
#13 5 years ago

I know this is a bit of an old post - but wanted to say thanks to the OP for posting his problem and solution. I bought a MPU327 in December for my Firepower and its been fine until last week when the top left pop would lock on when I started a game. Turned out to be a bad 7408 at IC8. Not sure why it decided to let go as I hadn't been under the hood messing around, but it's good to go now.

Promoted items from the Pinside Marketplace
From: $ 1.00
Playfield - Other
Rocket City Pinball
Other
$ 15.00
Playfield - Protection
UpKick Pinball
Protection
1,200
Machine - For Sale
Allentown, PA
$ 11.00
Electronics
Yorktown Arcade Supply
Electronics
$ 52.99
Cabinet - Shooter Rods
Pinball Shark
Shooter rods
2,100 (OBO)
Machine - For Sale
Philipsburg, PA

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/firepower-locked-coil-at-startup?hl=scupbucket and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.