(Topic ID: 161174)

Firepower II won't boot


By billsfanmd

2 years ago



Topic Stats

  • 5 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by billsfanmd
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

Just trying to get this thing to start. GI lights come on. Is there a step by step by step guide like on newer pins Would like to take logical order to see if I can get it playing

Once we get it running it will be for sale local

#2 2 years ago

Common issues with these would probably be bad IC sockets. I'd reseat the ROMs and processor and see what happens. Also, make sure you have 5 volts and 12 volts at the CPU.

If the boards are original, you should probably bulletproof them - new sockets, headers, interconnect etc.

Often times, sockets, interconnect and headers get them going and quite reliable without need for more.

If you need help doing this, LMK, I do about 50 sets of these a year. Otherwise, see Vid's Bulletproofing thread.

#4 2 years ago

Does anything else happen besides GI lights coming on ....

#5 2 years ago

Nothing. I'll post pics. He is just planning to sell so not sure fair price. Boards look good. Nice cab and backglass

$400 way off?

Are the test points labeled on cpu ? I thought I saw numbers

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 21.00
$ 45.00
Gameroom - Decorations
Pinball Photos
From: $ 20.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside