(Topic ID: 279592)

Firepower High Score missing last digit

By mdhawkeye

1 year ago



Topic Stats

  • 7 posts
  • 5 Pinsiders participating
  • Latest reply 1 year ago by Teamhex
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

IMG_0600 (resized).JPG
IMG_0590 (resized).JPG

#1 1 year ago

Noticed a weird issue today with my Firepower ... In attract mode, the last digit (always 0) of the high score shown isn't there at all. I KNOW that digit/segment works as during game play or new game its there. I did find this post (https://pinside.com/pinball/forum/topic/firepower-weird-score-thing-when-game-finished#post-2849396) that mentions an identical issue but no resolution. Anyone else see this? Is this just a bug in the code or do I need to be looking elsewhere? I tried powering off/on to see if that resolved it, but no. I did replace the 5101 with NVRAM, but doubt that has anything to do with it.

Thanks
Andy

IMG_0590 (resized).JPGIMG_0600 (resized).JPG
#2 1 year ago

Hello, I can help, I had this problem on my Firepower II, You must reheat the two main boards (where the batteries go) (and where are the coil transistors, lights, etc) if that doesn't help, try also the display board.
Another problem that I see is a bad contact on the display, that is fixed with a connection jump, but it is better that first you try to reheat the cards of all the pins and then verify What happens next

#3 1 year ago

In case you have already done that and nothing has worked, try to do the bridging on the display, I will show you how, only if the other methods did not work.
Another thing if your machine was off a good amount of time, leave it on for a few minutes, it can be 30-40 If the display keeps giving the error if it is already a technical fault, so try to reheat solder on the pins and then tell me what happens

#4 1 year ago

Reseat the display connectors on top of the mpu. If that makes it flicker or come back on, time to repin and reflow some headers.mine had the exact same issue.

#5 1 year ago

Most likely your NVram has a non-displayable character in it for that digit. The last score that alternates with it shows the digit correct? No reheating or reseating of connectors needed.

Make sure the backup HSTD is set to something and then reset the HSTD.

#6 1 year ago

Oh, my bad, didn't see where the display otherwise worked.. That's a weird one....

#7 1 year ago
Quoted from oilspot:

Reseat the display connectors on top of the mpu. If that makes it flicker or come back on, time to repin and reflow some headers.mine had the exact same issue.

I'd start here if you still have an original board. That's what was recommended to me.

I had some light flickering and my second digit for the ball in play was off during a game. I turned off my Firepower for an hour and when I turned it back up it's working again.

Promoted items from the Pinside Marketplace
3,200 (OBO)
Machine - For Sale
Cincinnati, OH
$ 49.99
Cabinet - Shooter Rods
Pinball Shark
From: $ 77.00
Tools
Pincoder Store
$ 649.95
Lighting - Led
Pin Stadium Pinball Mods
$ 399.95
Lighting - Led
Pin Stadium Pinball Mods
$ 15.00
Playfield - Protection
UpKick Pinball
2,200 (OBO)
Machine - For Sale
Lancaster, SC
$ 27.95
Eproms
Pinballrom
From: $ 1.00
Playfield - Other
Rocket City Pinball

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!