(Topic ID: 51656)

Firepower - 5101 RAM Chip Issues?


By dtown

6 years ago



Topic Stats

  • 38 posts
  • 12 Pinsiders participating
  • Latest reply 6 years ago by GListOverflow
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

image.jpg
2013-02-24_15-49-48_32zoom.jpg
image.jpg
image.jpg
image.jpg

You're currently viewing posts by Pinsider glistoverflow.
Click here to go back to viewing the entire thread.

#33 6 years ago

Can't say that it has anything to do with anything but there is something weird going on with the plunger and fiber link there. Normally the link is much longer... your plunger looks like it is about to fall out of the coil when at rest, and unless it is extra long or something there's no way it is getting all the way to the coil stop when it fires.

#35 6 years ago

Here's what it normally looks like:

2013-02-24_15-49-48_32zoom.jpg

The end of the action should come from the plunger hitting the coil stop. Sounds like yours is travelling too far and hitting the wood since you have the wrong link. Looks like maybe it broke at some point and someone just reattached the plunger to the piece that was left?

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 22.00

You're currently viewing posts by Pinsider glistoverflow.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside