(Topic ID: 51656)

Firepower - 5101 RAM Chip Issues?


By dtown

6 years ago



Topic Stats

  • 38 posts
  • 12 Pinsiders participating
  • Latest reply 6 years ago by GListOverflow
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

image.jpg
2013-02-24_15-49-48_32zoom.jpg
image.jpg
image.jpg
image.jpg

You're currently viewing posts by Pinsider dtown.
Click here to go back to viewing the entire thread.

#1 6 years ago

Working on a Firepower that had been stored in a basement and not powered on the last 20 years according to the guy I bought it from at the Allentown Show. I rebuilt the power supply and am getting my correct voltages. I also installed a remote battery holder even though the original is in excellent shape as are all the boards (front and back) from a visual perspective.

I'm getting 4.4 volts at the board from the batteries and 3.89 volts at pin 22 on the 5101 chip. From everything I've read this is a correct drop off in voltage. However, Firepower's got a weird issue. I can walk away for about hour or so, come back, turn her on and she goes into attract mode. However, anything I do with the settings puts the game back into audit mode. Turning her off and on again with the coin door open does nothing but back into audit mode. I can wait an hour or so and try again and it's the same results; attract mode until I try to change settings. Pressing the start button does nothing either and I do have three balls in the trough.

All of the socketed ROM chips pass Clay's finger test so could this be the 5101 RAM chip that can be an issue? In any case, I've already ordered a new chip from Marco's along with a socket. Any thoughts on whether this is my problem or, possibly, something else?

#4 6 years ago

The quick flip method does not work whether with the door open or closed. Manually triggering the coin switches also does nothing. The game is in attract mode, I press the advance button, the playfield lights lock on where they were cycling during the attract mode and the display shows the audit mode numbers. Also, cycling through the adjustments does nothing either.

#7 6 years ago

After powering it on for the first time today, I was able to manually add some credits and start a game. However, the game never ended. It kept going past 10 balls. Also, I could light the locks but the game would immediately kick them out along with a new ball into the shooter lane.

After turning it off and back on again, the same thing as before. Audit mode and nothing. In audit mode I can cycle though settings up to 35 before it goes back to 00 but nothing happens with any of them. No light test, no solenoid test, nothing.

#10 6 years ago

New 5101 RAM chip installed tonight. Game is working and I ran it through its paces. The chip was the culprit. I wanted to socket it but the sockets I got from Marcos just weren't long enough to solder on the front side of the board.

Borygard, I would have invested in the NVRAM but I'm watching my costs here and I already went through the trouble of installing a remote battery holder. Thanks anyway.

And thanks to all that responded. Clay's (pinballninja.com) Time Warp repair video really explained this problem and solution as well.

1 week later
#16 6 years ago

Well, after a week of cleaning I powered the game on and it goes into attract mode like it should. However, the LED's on the logic board are not flashing (they flash once and then stay off) and the game does weird things during gameplay. Wrong sounds, won't kick out a new ball when one is locked, wrong voice calls, etc.

I checked the 5101 chip I installed for proper continuity to other places on the board and connection and all seems fine. Do you think this one failed too? Any ideas as to what else could be wrong?

40 pin connector is tight and shows good connection to the driver board.

#18 6 years ago

Ok. I'll have to try and find one to order. I don't own the test rom but I know what you're talking about. I really think it's a chip issue. Physically, these boards are in excellent shape. I did reflow all 80 (male and female) pins on the interconnect but my problem remains.

#21 6 years ago

I ran several games today and found everthing, mechanically, was working correctly. The only thing it wasn't doing right was the sounds. No background sound and switch activations were making the wrong sounds for the switches that were hit. For example, press one of the center targets and "Fire 1" is said, press another and "Fire 2" is said. Activating the slingshots has "Fire" being said along with the correct sling noise. Lock three balls and multiball starts with the correct light effects but wrong sounds. Some sounds are correct though like the rollovers are making the right sound. Also, when the game ends the sound effect that is made seems to go on for a long time before it stops. Is that normal?

Another problem arised were both the outhole and lane feeder kickers weren't kicking hard enough. Outhole kicker wasn't strong enough to kick any more than one ball at a time. These were cleaned and new sleeves installed. Showing 40 volts but diodes are testing as shorted while in circuit. Didn't have time today but will remove tomorrow and test out of circuit but probably bad. Have replacements so no biggie. Sound problem is more an issue.

#22 6 years ago

Note that I did remove the sound and speech boards. Socketed chips were removed, cleaned and resocketed. Pins were reflowed and checked for continuity but no change.

#24 6 years ago

Main question is, what determines which sounds are played when a particular switch is activated?

#28 6 years ago

Ok guys. I think I fixed the sound issue. First I removed the MPU and driver boards while still connected together. I still think my 40 pin is ok. I reflowed every connector pin and added new solder to most of them. It seemed that at the factory, William's people or a machine cut the pins off too close to the board which in many cases took some of the solder joints. Allowed for cracks to form much easier. I also disregarded Todd Tucky's advice about leaving four of the six driver screws out and put them all in. I don't think the board was getting enough ground. Powered back on and the game played normally with no issues. I only had time to mess with it for two games and the playfield is still only about 60% done as far as cleaning goes. I'll check back in when I've put some more play time in but thanks to all that responded. If it screws up again, the 40 pin is getting replaced.

Outhole kicker and lane feeder are still weak. Diodes tested fine out of circuit. What's up with that? Why do they test almost zero while connected and .5 or so when disconnected? Anyway, I ordered new coils but I was brainstorming while at work tonight and I wonder if my problem is just that the switches have bent down too much and are deenergizing the coils too soon. If that's the case I feel stupid for not thinking of it earlier. Will check in morning when I get home from work.

#30 6 years ago

Lane feeder issue has been fixed. Arm was misaligned due to a loose screw for the mount. Holes stuffed and screws are tight now. However, the outhole kicker is still weak. I uploaded three photos below.
First, shows how far the kicker travels when the switch is activated manually.
Second, shows where the kicker is at rest.
Third, shows how far the kicker travels with two balls. Three balls, even less.

Grounding out the coil with three balls will push them one at a time over the trough hump but not all three together.

Another thing is eventually the switch will no longer activate the kicker. I can take the balls away and try to fire it manually and it doesn't fire. Is this a safety feature or, if not, what could be the cause? Turning the game off and on gets it working again.

Nothing looks misaligned. Thoughts?

image.jpg image.jpg image.jpg

#32 6 years ago

Andy,
I put the apron back on and manually threw three balls around the playfield allowing them to drain as they will. At one point or another one ball did manage to get in front of the other causing the problem.

I traced the outhole kicker to the tip120 transistor at q15. Left leg measured .36 ohms while all the other solenoid transisters measured in the .45 ohms neighborhood on their left legs. I had measured all these before when I had the board off and thought that since it wasn't in the .1 to .2 area it would be ok. I'm guessing this is my problem and am going to Rat Shack tomorrow and get one to replace anyway.

#34 6 years ago

Yea. Only a small part of the plunger rests in the sleeve. But, the bracket is factory. I've had it off. There's no mods. This Firepower has had very little done to it in 30+years. I'm willing to bet it has all the original coils bakelite linkages and plungers. Boards were never touched. The batteries I took out were from the 80's and were, fortunately, the non leaking kind.

As far as the kicker goes, there is actually a screw mounted to the playfield that prevents it from hitting the wood. I took it out. Without a ball in front of it, it travelled all the way into the wood where, sometimes, it would get caught. When I first fired the game up it would kick all three with no problem but after a little while it lost the strength to kick more than one over the hump. I agree that it does look like the coil was placed too far away but the bakelite linkages does show the wear or cutout at the pivot which indicates it's been here for a long time.

Anybody got a Firepower or similar era Williams game that wants to chime in with a photo of their under apron area?

#36 6 years ago

Just found a pic from Firepower teardown and, yes, it's got a two inch or so linkage. Gotta find one. Thanks. Don't know what happened here.

#37 6 years ago

This little beauty of self made engineering lasted about ten kicks before breaking but told me that Glist is correct. Linkage is too short. New one ordered. Thanks.

// Error: Image 107669 not found // image.jpg

Promoted items from the Pinside Marketplace
From: $ 9.00
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 17.00
Electronics
Yorktown Parts and Equip
$ 14.00
Electronics
Yorktown Parts and Equip
$ 22.00
1,600 (OBO)
Machine - For Sale
Lincoln, NE
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 99.00
Gameroom - Decorations
Pinball Sales
From: $ 5.00
Cabinet - Other
Rock Custom Pinball

You're currently viewing posts by Pinsider dtown.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside