(Topic ID: 51656)

Firepower - 5101 RAM Chip Issues?


By dtown

5 years ago



Topic Stats

  • 38 posts
  • 12 Pinsiders participating
  • Latest reply 5 years ago by GListOverflow
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

image.jpg
2013-02-24_15-49-48_32zoom.jpg
image.jpg
image.jpg
image.jpg

#1 5 years ago

Working on a Firepower that had been stored in a basement and not powered on the last 20 years according to the guy I bought it from at the Allentown Show. I rebuilt the power supply and am getting my correct voltages. I also installed a remote battery holder even though the original is in excellent shape as are all the boards (front and back) from a visual perspective.

I'm getting 4.4 volts at the board from the batteries and 3.89 volts at pin 22 on the 5101 chip. From everything I've read this is a correct drop off in voltage. However, Firepower's got a weird issue. I can walk away for about hour or so, come back, turn her on and she goes into attract mode. However, anything I do with the settings puts the game back into audit mode. Turning her off and on again with the coin door open does nothing but back into audit mode. I can wait an hour or so and try again and it's the same results; attract mode until I try to change settings. Pressing the start button does nothing either and I do have three balls in the trough.

All of the socketed ROM chips pass Clay's finger test so could this be the 5101 RAM chip that can be an issue? In any case, I've already ordered a new chip from Marco's along with a socket. Any thoughts on whether this is my problem or, possibly, something else?

#2 5 years ago

Another way to get the game into attract mode is to not only leave the coin door open, but flip the game off then on again really quickly. Also try that with the coin door closed, but it's a quick flip off then on again.

#3 5 years ago

Can you run diagnostics on the game? Does it respond to the coin door switches in diagnostic mode? Can you start a game by adding a credit? If no coin Mechs open door and trigger coin switch by hand. You could have bad coin door switches.

viperrwk

#4 5 years ago

The quick flip method does not work whether with the door open or closed. Manually triggering the coin switches also does nothing. The game is in attract mode, I press the advance button, the playfield lights lock on where they were cycling during the attract mode and the display shows the audit mode numbers. Also, cycling through the adjustments does nothing either.

#5 5 years ago

Can you get into diagnostics - auto-up/manual down switch down, press advance button twice, all displays light up, auto up switch up displays start cycling 0-9, press advance switch again, you get lights, again you get solenoid cycling, again you go into switch test.

You could be having a problem with the coin door switches, the harness connector to the coin door or the connector on the MPU board for the diagnostic switches (1J4, second from the left on the top of the MPU board.)

viperrwk

#6 5 years ago

A bad 5101 can certainly cause what you're seeing. It's probably the most commonly and easily damaged chip in all of pinball.

An NVRAM replacement will not be so sensitive, last a lifetime, and require no batteries ever...

www.LockWhenLit.com/anyPin.htm

Check continuity from diagnostic switches to CPU. With your description though, definitely sounds like a bad 5101.

--
Rob Anthony
Pinball Classics
http://LockWhenLit.com
Quality Board Work - In Home Service
Borygard at gmail dot com

#7 5 years ago

After powering it on for the first time today, I was able to manually add some credits and start a game. However, the game never ended. It kept going past 10 balls. Also, I could light the locks but the game would immediately kick them out along with a new ball into the shooter lane.

After turning it off and back on again, the same thing as before. Audit mode and nothing. In audit mode I can cycle though settings up to 35 before it goes back to 00 but nothing happens with any of them. No light test, no solenoid test, nothing.

#8 5 years ago

Yes, I have also seen weird things like this happen from bad 5101 chips. Strongly suggest replacing it.

#9 5 years ago

I just dealt with a 5101 ram that caused displays digits to shift over one spot. That was a pain. Finally realized it was failing Leon's boot rom memory test.

William's socketed the CPU which rarely fails but not the PIAs or the 5101 ram.... go figure.

#10 5 years ago

New 5101 RAM chip installed tonight. Game is working and I ran it through its paces. The chip was the culprit. I wanted to socket it but the sockets I got from Marcos just weren't long enough to solder on the front side of the board.

Borygard, I would have invested in the NVRAM but I'm watching my costs here and I already went through the trouble of installing a remote battery holder. Thanks anyway.

And thanks to all that responded. Clay's (pinballninja.com) Time Warp repair video really explained this problem and solution as well.

#11 5 years ago

I have a friend who is having some similar issues with his game. I will replace his 5101 RAM chip and see if that helps. Before he got it someone had soldered a 9v battery clip in place of the original battery... As you can guess, the 9v battery did a number on the game... It has since been removed and a 3xAA remote battery pack has been installed.

Rob, I am going to be ordering a few of your NVRAM replacements for a few of my games in the very near future. Awesome product!

-- Shawn

#12 5 years ago

Yikes! 9v will most likely kill the 5101 ram. I think a WMS sys 6 MPU board has a one or more 14/16pin logic ICs that get the battery power as well. Check the schematic and follow the battery voltage around and see where it goes before the blocking diode. 74XX ICs will probably not survive 9v.

I can check the schematic closely for you if you need help.

#13 5 years ago

IIRC from the data sheets max voltage for a 74XX chip is 7.5v. I checked this out when I accidentally put 12v down the 5v rail on my Barracora CPU when I had it on the test bench
I didn't want to risk any of them being stressed to just before failure point so I socketed and replaced them all. What a ball ache!

I recall there is one 4000 series chip on there that is rated to about 15v. That's the only one I didn't swap.

Andy

#14 5 years ago

The 9v clip may not have been for a 9 v battery. I have seen AA battery holders that attach with a 9v clip. Now if they actually hooked 9v up that is a different story.

#15 5 years ago

I myself have used the AA battery holder packs that have the 9v battery snap and made a long 9v snap lead with the blocking diode to solder to the boards on some of my games before but this one actually had a 9v battery on it when my friend got it.

-- Shawn

1 week later
#16 5 years ago

Well, after a week of cleaning I powered the game on and it goes into attract mode like it should. However, the LED's on the logic board are not flashing (they flash once and then stay off) and the game does weird things during gameplay. Wrong sounds, won't kick out a new ball when one is locked, wrong voice calls, etc.

I checked the 5101 chip I installed for proper continuity to other places on the board and connection and all seems fine. Do you think this one failed too? Any ideas as to what else could be wrong?

40 pin connector is tight and shows good connection to the driver board.

#17 5 years ago

That is usually an indication of driver board or interconnect problems.

From here the best bet is to run the test rom and check all the PIAs. Test rom can also check your 5101 (probably not the issue).

#18 5 years ago

Ok. I'll have to try and find one to order. I don't own the test rom but I know what you're talking about. I really think it's a chip issue. Physically, these boards are in excellent shape. I did reflow all 80 (male and female) pins on the interconnect but my problem remains.

#19 5 years ago

I agree it sounds like driver board issues in the solenoid section. In system 6 games, the sounds are driven by solenoid circuits on their way to the sound card.

#20 5 years ago

If you did not replace the female side of the 40 pin it is likely your problem. The tension wears out quickly on these connectors and reflowing will not help. Add 30 years and it is long overdue for replacement. My test driver board i swap in out all the time started developing problems in less than two years and maybe 50 in out cycles.

Test rom will show problems on the driver board. If all PIAs are dead you can start looking for a floating address or data line from a bad interconnect.

#21 5 years ago

I ran several games today and found everthing, mechanically, was working correctly. The only thing it wasn't doing right was the sounds. No background sound and switch activations were making the wrong sounds for the switches that were hit. For example, press one of the center targets and "Fire 1" is said, press another and "Fire 2" is said. Activating the slingshots has "Fire" being said along with the correct sling noise. Lock three balls and multiball starts with the correct light effects but wrong sounds. Some sounds are correct though like the rollovers are making the right sound. Also, when the game ends the sound effect that is made seems to go on for a long time before it stops. Is that normal?

Another problem arised were both the outhole and lane feeder kickers weren't kicking hard enough. Outhole kicker wasn't strong enough to kick any more than one ball at a time. These were cleaned and new sleeves installed. Showing 40 volts but diodes are testing as shorted while in circuit. Didn't have time today but will remove tomorrow and test out of circuit but probably bad. Have replacements so no biggie. Sound problem is more an issue.

#22 5 years ago

Note that I did remove the sound and speech boards. Socketed chips were removed, cleaned and resocketed. Pins were reflowed and checked for continuity but no change.

#23 5 years ago
Quoted from barakandl:

William's socketed the CPU which rarely fails but not the PIAs or the 5101 ram.... go figure.

This is more likely to be related to a parts supply issue - when the boards were assembled possibly the CPUs were in short supply so they assembled the boards anyway and added the chip later when it became available??

#24 5 years ago

Main question is, what determines which sounds are played when a particular switch is activated?

#25 5 years ago
Quoted from dtown:

Main question is, what determines which sounds are played when a particular switch is activated?

The sounds are driven like a solenoid from the driver board. Until you replace the 40 pin you are chasing your tail.

#26 5 years ago

Sounds are driven by tip120 driver transistors in the solenoid section. It grounds an input or multiple inputs at once to play a sepcific sound. You are likely missing one line. Check the connectors on both the sound board and the driver board.

Good test might be to ground all the sound transistor tabs and look for one that does not play any sound. That will tell you if you have a connector problem (but not rule out a bad logic driver circuit!)

#27 5 years ago

On System 6 and earlier a solenoid circuit grounds the appropriate input pin on the sound board. Sometimes it's just a single pin, sometimes it's multiple pins, but always through the solenoid circuits. Pretty much they just replaced the chime box with the sound board, and this method allowed them to do that without changing designs on the CPU boards, power supplies, or programming language. More often than not it's a wire connector issue or a bad header. Step #1 in Williams pins for a problem is always check the connectors first, both on the board and on the wiring harness.

As to the choices on which pin to socket... god only knows. They made some odd decisions when they first went to solid state, some of which weren't corrected until P2K came out. Just be glad they passed on the Rockwell design that was tested in Aztec... it eventually became the System 1 Gottlieb.

-Hans

#28 5 years ago

Ok guys. I think I fixed the sound issue. First I removed the MPU and driver boards while still connected together. I still think my 40 pin is ok. I reflowed every connector pin and added new solder to most of them. It seemed that at the factory, William's people or a machine cut the pins off too close to the board which in many cases took some of the solder joints. Allowed for cracks to form much easier. I also disregarded Todd Tucky's advice about leaving four of the six driver screws out and put them all in. I don't think the board was getting enough ground. Powered back on and the game played normally with no issues. I only had time to mess with it for two games and the playfield is still only about 60% done as far as cleaning goes. I'll check back in when I've put some more play time in but thanks to all that responded. If it screws up again, the 40 pin is getting replaced.

Outhole kicker and lane feeder are still weak. Diodes tested fine out of circuit. What's up with that? Why do they test almost zero while connected and .5 or so when disconnected? Anyway, I ordered new coils but I was brainstorming while at work tonight and I wonder if my problem is just that the switches have bent down too much and are deenergizing the coils too soon. If that's the case I feel stupid for not thinking of it earlier. Will check in morning when I get home from work.

#29 5 years ago

New coils is not going to solve weak firing. This is most likely power related or mechanical. Either poor ground (driver board connectors) or flakey +voltage. These two coils you mention are CPU controlled. Software decides how long the coil pulse is. Most likely some kind of physical issue with assembly.

You can not test a diode mounted on a coil. Each end is connected via the coil winding.

The header pins are cut too short on Williams boards of this era. It is a major manufacturing error. I usually replace all header pins on these boards so i can get a reliable solder joint.

#30 5 years ago

Lane feeder issue has been fixed. Arm was misaligned due to a loose screw for the mount. Holes stuffed and screws are tight now. However, the outhole kicker is still weak. I uploaded three photos below.
First, shows how far the kicker travels when the switch is activated manually.
Second, shows where the kicker is at rest.
Third, shows how far the kicker travels with two balls. Three balls, even less.

Grounding out the coil with three balls will push them one at a time over the trough hump but not all three together.

Another thing is eventually the switch will no longer activate the kicker. I can take the balls away and try to fire it manually and it doesn't fire. Is this a safety feature or, if not, what could be the cause? Turning the game off and on gets it working again.

Nothing looks misaligned. Thoughts?

image.jpg image.jpg image.jpg

#31 5 years ago

>>First, shows how far the kicker travels when the switch is activated manually.
>>Second, shows where the kicker is at rest.
>>Third, shows how far the kicker travels with two balls. Three balls, even less.

That seems OK

>>Grounding out the coil with three balls will push them one at a time over the trough hump but >>not all three together.

The outhole will never have more than one ball at a time. Even at the end of a game when two locked balls are kicked out they won't land in the outhole together. I don't see the fact that it won't kick three balls at a time up the trough hump as a problem as it will never occur.

>>Another thing is eventually the switch will no longer activate the kicker. I can take the balls >>away and try to fire it manually and it doesn't fire. Is this a safety feature or, if not, what >>could be the cause? Turning the game off and on gets it working again.
>>Nothing looks misaligned. Thoughts?

Maybe but I haven't come across it before. Perhaps a system6 expert could chime in When the switch stops working try registering a few playfield switches to see if that then makes the outhole switch start working again.

Andy

#32 5 years ago

Andy,
I put the apron back on and manually threw three balls around the playfield allowing them to drain as they will. At one point or another one ball did manage to get in front of the other causing the problem.

I traced the outhole kicker to the tip120 transistor at q15. Left leg measured .36 ohms while all the other solenoid transisters measured in the .45 ohms neighborhood on their left legs. I had measured all these before when I had the board off and thought that since it wasn't in the .1 to .2 area it would be ok. I'm guessing this is my problem and am going to Rat Shack tomorrow and get one to replace anyway.

#33 5 years ago

Can't say that it has anything to do with anything but there is something weird going on with the plunger and fiber link there. Normally the link is much longer... your plunger looks like it is about to fall out of the coil when at rest, and unless it is extra long or something there's no way it is getting all the way to the coil stop when it fires.

#34 5 years ago

Yea. Only a small part of the plunger rests in the sleeve. But, the bracket is factory. I've had it off. There's no mods. This Firepower has had very little done to it in 30+years. I'm willing to bet it has all the original coils bakelite linkages and plungers. Boards were never touched. The batteries I took out were from the 80's and were, fortunately, the non leaking kind.

As far as the kicker goes, there is actually a screw mounted to the playfield that prevents it from hitting the wood. I took it out. Without a ball in front of it, it travelled all the way into the wood where, sometimes, it would get caught. When I first fired the game up it would kick all three with no problem but after a little while it lost the strength to kick more than one over the hump. I agree that it does look like the coil was placed too far away but the bakelite linkages does show the wear or cutout at the pivot which indicates it's been here for a long time.

Anybody got a Firepower or similar era Williams game that wants to chime in with a photo of their under apron area?

#35 5 years ago

Here's what it normally looks like:

2013-02-24_15-49-48_32zoom.jpg

The end of the action should come from the plunger hitting the coil stop. Sounds like yours is travelling too far and hitting the wood since you have the wrong link. Looks like maybe it broke at some point and someone just reattached the plunger to the piece that was left?

#36 5 years ago

Just found a pic from Firepower teardown and, yes, it's got a two inch or so linkage. Gotta find one. Thanks. Don't know what happened here.

#37 5 years ago

This little beauty of self made engineering lasted about ten kicks before breaking but told me that Glist is correct. Linkage is too short. New one ordered. Thanks.

// Error: Image 107669 not found // image.jpg

Promoted items from the Pinside Marketplace
$ 14.00
Electronics
Yorktown Parts and Equip
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 14.99
Electronics
PinballElectronics.com

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside