(Topic ID: 319772)

Fireball - fourth player not working

By jlbintn

7 months ago

Topic Heartbeat

Topic Stats

  • 57 posts
  • 9 Pinsiders participating
  • Latest reply 5 months ago by jlbintn
  • Topic is favorited by 1 Pinsider


Linked Games

Topic Gallery

View topic image gallery

88888 (resized).jpg
Fireball post adjustment (resized).jpg
IMG_6632 (resized).jpg
IMG_6627 (resized).jpg
IMG_6622 (resized).jpg
IMG_6623 (resized).jpg
IMG_6621 (resized).jpg
IMG_6620 (resized).jpg
Screen Shot 2022-09-18 at 5.47.43 PM (resized).png
IMG_2504 (resized).JPG
IMG_2503 (resized).JPG
Bally Fireball 10pt re (resized).jpg
bally fireball zipper 0 (resized).jpg
IMG_4941 (resized).jpg
IMG_4940 (resized).jpg
IMG_2502 (resized).JPG

You're currently viewing posts by Pinsider jlbintn.
Click here to go back to viewing the entire thread.

#1 7 months ago

Got this game 18 months ago. Have not had much time to work on it, real life took control. I have finally got back to tinkering with it. I can only play three players. Fourth game will not "que" up, despite there being enough credits to do so. Any suggestions on where to start?

There is no diagnostic mode for this, being that it is an EM game, correct?

#4 7 months ago

There are two coin units, both with micro-switches. Not sure how to tell if one (or both) are open early, e.g., when I select the third player or attempting to select the fourth player. Not sure if it's related, the credit counter never goes past ten. Just stops when I reach ten credits. Pertaining to micro-switches, is opening early an internal function in the switch. The arms look normal, not like they have been mangled.

#7 7 months ago

Thanks for the clarification. I found the coin unit in the backbox. Schematics would be nice, but I don't have any. Here are the issues I'm encountering, pretty sure they're all tied to once source. Just a guess at that, though.

Can't play four player games.
Credits cap at 10.
Ball three indicator does not work, except momentarily when ball four comes out of the outhole.
Ball 5 indicator does not work.

Bulbs are good.

Game plays well enough, the flippers feel weak, not surprising from a 50 year old game that needs some TLC, but that's not my primary concern at the moment.

I put new fuse holders in, the old ones needed to be retired

I'll keep all posted. Many thanks for the help thus far

#9 7 months ago

Update: third ball in play is now working. Don't ask me why or how, I didn't do anything.

1 week later
#10 7 months ago

Both flipper units rebuilt, yesterday. While not the response from a SS game, much much better. Flippers still will not close when hitting the mushroom, but that was a recurring issue prior to the rebuild. They will stay closed if I push them into that position, but just retract in, then immediately back to normal when the ball hits the mushroom.

Having the playfield raised up to work on has resulted in several other lights starting to illuminate, all on the playfield. The game plays well enough, the grand-kids (and the wife) really like it

#12 7 months ago

So, the adjustments are all related to the flippers? I'm trying to be sure I understand which switches need to be adjusted so the lock catches and holds the flippers closed.

#14 7 months ago

Thank you

#16 7 months ago

Yes, they try to close electronically, but they will not stay closed. This has been an on again off again issue since I got the machine. Since I had the playfield up to rebuild the flippers, it is now a "permanent" issue. They will not lock closed. How loose should that bar be? I notice two screws in there that can be tightened along the slide path. Both are very very loose. In reference to the switch when closed, my switches do not look that way (see picture in the post prior to yours) at all when the flippers are closed. I have made no adjustment on them whatsoever at this point, so kind of perplexed at why they ever did work.

Got the credit issue resolved, by relocating the stop. Can't believe I looked right at that and didn't see it earlier. Probably focused on the other crises, instead of one at a time

Is there any place that sells packaged leaf switch kits in large scale. I suspect that that flipper switch is going to need a rebuild, and probably not the only one. Four players is now crediting properly, at least the last several times I tried.

Thanks for the information, was very helpful.

#17 7 months ago
Fireball1 (resized).jpgFireball2 (resized).jpg
#18 7 months ago

I replaced two relay coils on the machine yesterday, the 10 score relay and the flipper close relay. Ten points are not scoring (that started right after I rebuilt the flippers) and as is probably evident, the flipper close switch looks quite crispy. The old coil was burnt.

#21 7 months ago

Got the zipper switch adjusted, it closes properly, only thing that reopens the flippers is hitting that mushroom again. Tilting the machine, ball drain down the out-hole or hitting the other two mushrooms does not open them. To avoid the coil getting overheated, I must tap that mushroom. Even powering off the machine does not cause them to reopen.

For the close flipper solenoid EOS switch, when it goes back to the open position, should the two leaf blades on the bottom (as per sizteves photo) still be in contact?

Some other symptoms, maybe related, maybe not:

The 1000 score relay sticks from time to time. The 10 score relay sticks on any hit that would score 10 points. I have to open it with a business card to keep it from burning up.

The only commonality is that all of this started after I had the playfield up to rebuild the flippers.

On the relay coils, is there an acceptable equivalent for the G-30-1500?

#24 7 months ago

10 point coil sticks on all players. All springs accounted for.

#25 7 months ago


First picture is open, second is closed

Edit to add:

noticed while testing, if I do not hit one of the mushroom bumpers (Odin, Wotan), hitting the blue mushroom (while flippers are closed) does nothing. I hit one of the other two mushrooms (doesn't matter which) then hit the blue mushroom, the flippers open.

Upon further review: the buzzing from the zipper's coil is because it is attempting to open after a drain or hit on Odin/Wotan. So, it is trying to open

#27 6 months ago

I noticed the difference in the leaf stacks from your picture. Everything was functioning prior to rebuilding the flippers. Something went off the rails during or after that. I'm not happy about that, but I'm not at all surprised

edit to add

the mechanism opens and closes smoothly, doing it manually

In the backbox, on the panel where the score coils mount, behind the 10 point coil.... there was a fire there at some point in the past. And there was definitely some type of rebuild on the harness behind that coil. Everything else on the wood looks fine, but that area is charred, not just brown from overheating, but charred

#28 6 months ago

Replaced the lowest leaf. The old one was pretty shot. As to your observation about the two lower leaf switches never changing state, I'm confused. Manually triggering the zipper mech, there is a noticeable gap between those two, until the latch snaps back a tiny bit once it's set. Are not those two leafs always supposed to be in contact, except that momentary gap when the flippers close?

Sorry if the answer is obvious, I'm just not seeing it. I think I've been looking at it for too long, and that could be the problem

#29 6 months ago

Yessss!!! Victory of sorts.

Not with the zipper flipper, but with the 10 point coil problem. There appears to be some slippage of one of the connectors that was part of the rebuild after whatever caused that burn in the wood.

Just moved the harness around, and the game functioned perfectly relative to scoring. One of the wires is slipping out of the connector and is exposed, noticed it while re-arranging that cluster of wires. Pain in the ass to take things apart, but it doesn't feel like chasing a ghost anymore.

Nice way to end the weekend

#31 6 months ago

Gapping those two leaf switches when closed disables the workaround. They close fine, but just buzzing noises from the coil after hitting Odin or Wotan and the blue mushroom tap does not open them again. So, I adjusted it back to no gap when closed and I'm back to where I was

#33 6 months ago

I might have to walk away from this. I should have just waited and bought one that had been re-worked or was in a bit better condition than mine. I don't have the expertise to do this, not at the level I need to have at any rate. I'm a relatively quick study, but time isn't the luxury it was. I'm not good at schematics, either.

I don't want to give up on it, but that may be out of my control. Still have the 10 point coil issue, although all wires have been re-worked. Seems to be relegated to sticking switches on some parts of the playfield. A hit on another 10 point area or a 100 or 1000 point score unsticks the coil and the score registers.

I suppose weak coils could be an issue. Re-flowing the connects on the transformer may not be a bad idea. The zipper switches are now set up as they should be, but not opening when they should.


#35 6 months ago

Yeah, what would be really nice right now is to have another set of eyes on the game. I'm not timid with these things, but I always seem to find the problem children, i.e., those that need work

I'll get it figured out, the help around here is pretty solid and it does make a project like this easier.

How would you determine if the coil spring is too tight? Can that bigger spring cause the problem I am experiencing?

Edit to add

The blue mushroom for the zipper, is it supposed to score when it's hit?

#37 6 months ago

Looking at the springs in the pictures provided, I see what you are suggesting. Any suggestions on a replacement, primarily where I could fine one? Anybody know the part number for that spring?

#39 6 months ago


That is very helpful


Part # A-1653-1 is the lamp socket used in the backbox for ball in play, game over, etc., correct? Is is possible to use a bayonet socket as a replacement?

1 week later
#40 6 months ago


Mushroom bumper now scores 100 points. Flippers close fine, but will not open. Testing leads me to believe that big spring is the issue, once locked closed it is so tight it will not allow the coil to pull down the latch.

Player up stepper cleaned and adjusted, which fixed a minor issue with the game displaying Player 1 and 2 simultaneously after a fourth player ball drain.

Transformer is good, before and after reflowing the connections with a new power cord. Wasn't really worried about the transformer.

Sooooo, replacing that spring is number 1 on the list atm.

#41 6 months ago

For the most part, it's working fine. The spring wasn't the only issue I eventually dealt with, the coil was a bit weak so I replaced it when the spring arrived.


What would cause the armature to stick to the coil after the flippers open? Doesn't do it all of the time, but pretty sure it's not (small) spring related. I have to push it off, and by push I mean not much, as there is barely any resistance, but there is some resistance there. As a result, it takes a couple of attempts on the mushroom to break it free before it will close again.

Measured the close coil on the zipper, it's reading 8.5 - 9 ohms, so good there. I cleaned up the entire unit - it was a greasy mess. Installed new nyliners as well.

Anyway, progressing nicely and it is, basically playable now (again)

#43 6 months ago

Definitely magnetized, just enough too. I don't know that I want to mess with that spring, until I can secure a replacement. Right now, it's down to having to hit the mushroom once to pull that armature up. That's a quirk I can live with until another solution comes along.

#45 6 months ago

I found an armature at JT Amusements for $14.95. Steve didn't have that (or the spring) in stock. I'll see if that fixes it up. If it shows some magnetism, I think I'll try the hammer beating first before installing it, instead of some of the more exotic remedies.

Just finished running it through some tests before making this post. And one sequence, it did close as it should, without needing two hits to shake that thing loose. And, while not applying your solution, I think I hit the flippers at the same time the mushroom was hit and it closed, so same effect.

Another question, and it is outlane related. I read in the manual that posts can be installed to make draining a bit more difficult. Right now it's a damn drain guru. It refers to an illustration that is not in the manual I have. That's next on the to-do list, but not until I can find a good picture or illustration of where they should/could go.

There are still some quirks (ball 5 light for instance), but finally, no game-breakers. I suspect this game, being so old, may have those from time to time. And I need to find something that will work as a good bulb puller for those back-box bulbs.

What a pain in the ass they are, especially the match row.

#48 6 months ago


#49 6 months ago

Some shots. Odin lane is the worst of the wear on the playfield. Would love to find a stencil. Or, color me crazy, if I could find a playfield I might just roll with a swap.

Edit to add:

The playfield was pretty dirty when I got the game. Fifty years old, no surprises obviously. We tried to clean it up as best we could, but some of the dark marks in areas were just not coming up so we did what we could and then invested in a playfield protector. Every once in a while we have issues with the buttons, specifically the 10 point buttons getting trapped because the protector shifts ever so slightly. Eventually I'll try to trim them out just a bit, but it's not happening often so that can wait.

Anyway, still looking for a photo on the posts that can be placed at the outlanes to make draining harder. It was referenced in the manual, but I have yet to find the illustration it refers to, FO-320, which is on page 7 under Playfield Panel Post Adjustments. Unless that is referring to something entirely different. Right now, the game is "set" to Easier.

Ball 5 issue is/was related to the Ball Count Unit. I cleaned it up some, lots of black crap came off. I suspect grease from the zipper unit.
IMG_6620 (resized).jpgIMG_6621 (resized).jpgIMG_6622 (resized).jpgIMG_6623 (resized).jpgIMG_6627 (resized).jpgIMG_6632 (resized).jpg

#51 6 months ago

Yeah, I think you are correct and was leaning in that direction myself. Outside of drilling holes to push them a bit further up....

not really sure I want to do that to a 50 year old playfield, and I'm not sure the plastics would look right with the upper posts extended, even a little bit.

I think I'm going to clean the spinner cogs. There was a lot of gunked up grease globs on there. They have a black look to them. I changed out the ball plunger spring yesterday, and even it had a greasy feel to it, all the way up the rod to the tip. Somebody really liked grease.

#53 6 months ago

Yep, I meant the gears by that. They have a lot less grease on them now. Damn, what a mess. They're actually starting to look like brass again. When I had the motor off the machine yesterday to clean it, I added a couple of drops of 3-n-1, wiping away excess. I don't know how long it has been since the last lube so I played it conservatively. I'm going to establish a plan going forward, but right now still working to form a baseline.

#54 6 months ago

Got the armature plate installed today. Works well, although I had to play with the adjustment. Seems if I set it all the way in, so the flippers close as tightly as possible, it has trouble opening. Opening them up by about 1/8 of an inch (guesstimating), resolved the issue. The game is playing very well. Took this shot last night
88888 (resized).jpg

I put a new coin door skin on, looks great. Don't know what dented the one that came with the machine, but it had to be a hard hit to bend it that way. Installed a Sega knocker assembly, and now it makes noise when getting or adding a credit

Also, on the inner side of the cabinet, near the play counter to the right and above it, back towards the door, there are two bolts with nothing attached to them, spaced about 3-4 inches apart. Any idea what those bolts are for, or what may have been there?

Thanks everyone for the help that was provided, that got me moving in the right direction. Much appreciated, all of you

#55 6 months ago

Figured I would ask here, since this is still an active topic. I'm trying to configure the coin door to credit 1 play for a nickel and two plays for a dime. Reading the manual, and playing with the plug settings is going nowhere. I can get it set to give 3-6 credits depending upon the plug configuration, but never 1. I believe I'm following the instructions, but just can't get it to work. Can anybody give me an illustration, or the rough equivalent in explanation, for what plugs go where on the game to achieve 1 play or two play depending upon the coin I drop.

edit to add:

found a similar post in the 72 Fireball club thread. Will follow-up with it there, instead of here. But if somebody knows, and runs across this post first, please feel free to respond

2 weeks later
#57 5 months ago

Mine is very very clean now, but still working sections at a time to clean up whatever exhaust was created by that crap being on there in the first place. I pulled the bumpers today to make it easy to clean the metal rings. I have pulled a lot of the metal parts off of the cabinet, sanded them with 200 grit sandpaper, and polished most of them. The metal bar under the backbox at the back of the playfield, and the playfield support, including lock bar were sanded and painted. There is a whole big list of things I've pulled to clean.

The smaller parts, I treated in an ultrasonic cleaner, which took care of about 75-80% of the crud and rust. Then polished with steel wool, and wiped clean with 91% alcohol and/or naptha. The game looks much better inside, but still have a lot to clean. Two steppers are done, the player up unit in the backbox and the ball count unit in the cabinet.

The game is playing very well, notwithstanding the fish paper incident yesterday

Promoted items from the Pinside Marketplace
From: $ 12.99
Cabinet - Other
The Pinball Scientist
$ 25.00
Apparel - Men
Pinside Shop
$ 5.95
Playfield - Protection
The Pinball Scientist
$ 52.99
Cabinet - Shooter Rods
Pinball Shark
Shooter rods
From: $ 115.00
Playfield - Protection
Beehive Pinball Co.
$ 69.99
Cabinet - Shooter Rods
Pinball Shark
Shooter rods
Great pinball charity
Pinball Edu

You're currently viewing posts by Pinsider jlbintn.
Click here to go back to viewing the entire thread.


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/fireball-fourth-player-not-working?tu=jlbintn and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.