(Topic ID: 341412)

Fire Power lane advance

By Dancoar

3 months ago

Topic Heartbeat

Topic Stats

  • 17 posts
  • 5 Pinsiders participating
  • Latest reply 89 days ago by Dancoar
  • No one calls this topic a favorite


Linked Games

Topic Gallery

View topic image gallery

Switch MAtrix (resized).png
IMG_0180 (resized).jpeg

#1 3 months ago

So I recently acquired a fire power. It good working order, but recently the lane advance for FIRE, which would work by pressing the right flipper button stopped working.
I determined that the problem was at the flipper assembly. By trial and error I adjusted the outer leaf on what I think is the EOS switch and it worked beautifully.
However, now every time I hit the flipper button, the onus advances as if I had gone down an open lane.
ie from 1-2-3etc not the 2x-3x
Where have I gone wrong?

#2 3 months ago

Without hitting the flipper button, pound on the playfield to see if the bonus advances. If it does, then you have a switch that is closing due to vibration. Check all the switches that advance the bonus for contacts too close together. The EOS or switches on the flipper button should not cause what you are describing.

#3 3 months ago

Suspect shorted lane change to EOS switch stack:

Place game into switch test press flipper note switch(s) #'s

#4 3 months ago

Went through the switch test and none were up. Shook the playfield and did not advance bonus.
Played with the switch at the flipper, picture included.
The outside leaf marked by yellow when pressed into the next leaf advances the lane change and the bonus.
If adjusted so that when the flipper is engaged the leafs touch, both the lane changes and the bonus advances
I should also say that I am not experienced with doing this, but excited to get more involved
Thanks for your help

IMG_0180 (resized).jpegIMG_0180 (resized).jpeg
#5 3 months ago

While in switch test with all balls out of the machine, make the EOS and see what switch(Es) come up

#6 3 months ago

the negative side of the diode leg looks like it's touching the solder tab with the blue/green wire?

#7 3 months ago

The next step is to

Place game back in switch test, Actuating the Lange change switch will show #45 on the display

Suspect Flipper EOS voltage short into Lange change switch stack to the driverboard switch circuit

Keep game in switch test next check all other remaining 13 switches in Column #6 and Row #5 #61 is not used
Note switch #'s

Switch MAtrix (resized).pngSwitch MAtrix (resized).png
#8 3 months ago

The outer switch doesn't look like the right switch. The large high power contacts are for EOS switches, not low power switch matrix switches. Also, both blades are bent noticeably, which likely causes the contacts to not to be flush when closed. You can find the correct part number in the parts book linked below.


In the mean time, try lightly sanding the contacts on the incorrect switch. High power contacts often have oxidation you can't see, causing resistance. Switch should measure less than 1 ohm resistance when closed. Sanding the contacts may get it working until the correct switch arrives.


#9 3 months ago

Appreciate all the help and insight.
Easiest first: I checked to be sure there were no wires touching where they shouldn’t and the diode leg was clear.
I went back to the switch test and activated the right flipper, #45. Unfortunately at some point, the entire flipper stopped firing. I took the entire assembly out, lightly sanded the contact points and established appropriate position for the leafs. I did get the flipper working appropriately… but still do not have lane advance.
That was enough adventure for tonite. I plan to check the switches for the column and row tomarrow.

#10 3 months ago

Update. First and foremost, I am incompetent.
Understanding that. I did a complete switch test.
At start up, none were shown as closed.
I tested each as best I could.
Coin door and # 4,5,6. Were non functional.
Slam tilt #7 and play field tilt #47 also did not work.
I could not identify #51,57, 58 (ball ramps) do not sure what they are doing. #45 was out as was #37.
I also blew the flipper fuse. It had been ok, but I goofed up something. I replaced the fuse with a 3amp fuse but it blew when I hit the right flipper button. Left flipper was ok until the fuse blew.
I think that I will get a new right flipper assembly.
Any other thoughts.
Thank you all so much
Though frustrating, this is fun

#11 3 months ago

Update, I misread the fuse type.. should be 10 amps?

#12 3 months ago

yes F4 should be 10A Slow Blow

#13 3 months ago

Yes. Thanks. Not sure where I got the 3amp. But is working again. Still not getting the lane advance. Looking at switch 37 and 45

#14 3 months ago

have you confirmed continuity for the White/Green and the Green/Blue back to the driver board top right-hand side connectors?

in post #4 you say that when you 'make' the lane change switch contacts, that the lane does change, is this correct? Is this fixed now?

#15 3 months ago

Lane change does not work. All other switches work. #37 had the leafs installed backwards, but does work with good contact.
Have not checked continuity.. will try next week.
Another finding is that when target 4 is hit, targets 1-4 light up. You only get points for the one hit. All other targets act independently. Targets 1-4 switches are on the same column.

#16 3 months ago

Adventure continues. I installed a brand new right flipper complex with lane change. After adjusting EOS switch, flipper works perfectly. But still no lane change. Mechanically, the flipper does close the lane change switch. Tried checking continuity of row ( white green wire), but am a little clumsy with leads. Am getting alligator clips to help and will check later this week. Did inspect individual switches and they look intact with no loose wires. All work in switch test mode and during play.
Am afraid problem is on the driver board?

1 week later
#17 89 days ago

My fire power needs more work. I did replace the right flipper assembly and now have lane advance working, but it again also advances the carry over bonus by 1000 with each hit.
I have checked continuity for column 6 and row 5.
I used the single reference point at switch 45 and had good signals to all switches in the row and up to the board connection. For the column I used #43 and was good for 41,42,44,45,48 and to the board. Could not find 47,46.
Other issues have developed.
1. When target 4 is hit, it lights up 1,2,3&4.
2. When I turn it on the upper right eject fires multiple times before stopping. I have credits and hit the start button, score resets and it says FirePower, but no balls load into the shooter.

I have checked the switch with the ejector and it is working properly. I have checked continuity for column 5 and row 4 and they are good.

I checked solenoid test in diagnostics? And 2,3,4 did not fire

Many questions:
1. Is the continuity testing valid from a single reference point.
2. Is the problem likely in the board.
3. Ideas regarding the balls not loading and repeating ejector

Promoted items from the Pinside Marketplace
$ 27.95
From: $ 1.00
Playfield - Other
Rocket City Pinball
$ 42.95
$ 15.00
Playfield - Protection
UpKick Pinball
$ 12.50
Lighting - Led
RoyGBev Pinball
$ 649.95
Lighting - Led
Pin Stadium Pinball Mods
$ 52.99
Cabinet - Shooter Rods
Pinball Shark
Shooter rods
$ 11.00
Yorktown Arcade Supply
$ 44.99
Cabinet - Shooter Rods
Pinball Shark
Shooter rods


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/fire-power-lane-advance and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.