New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 41338)

Fire! Pinball flippers and left and right slingshot not working.


By Willy39

7 years ago



Topic Stats

  • 23 posts
  • 7 Pinsiders participating
  • Latest reply 7 years ago by wayout440
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 7 years ago

My friend just acquired a fire pinball and the flippers and slingshots do not work. We also noticed the diagnostics led light on the board flashing. We did double check and re plugged in all the wires leading to the flippers and still nothing. Any ideas? Thanks for the help.

#2 7 years ago

Do you have a volt meter?

#3 7 years ago

The blinking diagnostics LED is normal.

With your very limited description, the first thing that comes to mind is a blanking issue that isn't allowing the flipper relay and the special solenoids to engage.

First thing to do is test for voltage at the coils. Compare readings to working coils.

--
Rob Anthony
Pinball Classics
http://LockWhenLit.com
Quality Board Work - In Home Service
314-766-4587

#4 7 years ago

So this sounds more like an issue with the power going to the coils rather then the wiring going to the cpu board? Could it be an issue with the flipper power board or the regular power supply board? It was working for one game and playing an immediate game after that, the flippers and the slings did not work and continue to not work.

#5 7 years ago

The other question I have is the lower slingshots and the flippers not working related? Are they on the same power? I know either both work or both don't so I am just trying to figure out a relation to it all.

#6 7 years ago

Check the manual find the transistor that drives the sling and flipper ground it out and see if your getting power to that. Just a suggestion.

#7 7 years ago

Again, first thing to do is test for power at the coils in question. DMM set to 200V range, black lead to ground strap, red lead to coil lug. Post readings.

--
Rob Anthony
Pinball Classics
http://LockWhenLit.com
Quality Board Work - In Home Service
314-766-4587

#8 7 years ago

I agree with Borygard, however I if u don't have or know how to use a DMM, I would look at all ur fuses. I believe there is a fuse under the playfield that runs all those solnoids, the tricky thing is it may look ok but still be blown which will take you back to what Borygard said and you'll need to vet a DMM. But my money is on a blown fuse either under playfield or in back box. But then the question will be why did the fuse blow?

#9 7 years ago

Ok. Found a blown fuse under the playfield like you guys said to check it is the one on the back right side of the playfield. Changed the fuse and got it working.....for about 5 minutes. During the game the flippers and all slingshots stopped working. So something is blowing that fuse. Any ideas? We did use a dmm and power is getting to all flippers and slings. Thanks in advance for the continued help!

#10 7 years ago

This exact thing just happened to me on my F14 and I posted a thread about it within the last month. I think it was a bad TIP that was grounding to short. Let me look up my old post and check the schematics for your game...Ill be back I a sec

#11 7 years ago

This is what my problem was its a bit diff. but I believe going to be the same solution.

"Just wanted to log a repair for everyone. My F14's pop bumber quit working. I found that the 2.5 slo-blo fuse under the playfield was blown, I replaced it and immediately blew the fuse again. I then found that the slingshots also not working. All three of these are connected via a RED/WHITE wire. I test each coil and found they were all shorting to ground. I started at the pop and was lucky to find that the blue/violet wire was the culprit. Traced the problem back to the TIP 122 @ Q69. Replaced the TIP and fuse again, and I am back up and running. I think problem was mis-adjusted leaf switch, causing the pop coil to stay locked on. (i just got the machine so I hadn't noticed that)"

#12 7 years ago

Ah just turn machine off and start testing the TIP's the one that is reading diff. from the other is the one shorting to ground. You can do all fairly quickly and I don't feel like looking at schematics right now got to pack for the OHIO show!!!. But something caused that TIP to blow. So look at all your solenoids and make sure the are all adjusted properly and that one is permanently stuck closed. i.e. your EOS switch. Pops swiches or bad Diode on a coil? Here's a Link http://mirror2.ipdb.org/files/859/Williams_1987_Fire_Instruction_Manual.pdf

#13 7 years ago

Finally got to this game this weekend . All coils and diodes checked out . Did a switch test and the slings and flippers switch did not work . Going to try and replace Q67 this week from what I've read that goes quite often on Fire! And it controls the ground relay for the flippers and slings . Not sure what the Q67 should read when testing there is nothing in manual on its normal operating reads ?

2 weeks later
#14 7 years ago

Just an update , found a bad tip at q68 I believe it was . Thanks for all the help !!!

2 weeks later
#15 7 years ago

Could this problem with the flippers and slingshots not working be caused by a bad k1 relay? Does anyone think that should be replaced? Any way to test it to see if the k1 on the board is good or bad?

#16 7 years ago
Quoted from Willy39:

Could this problem with the flippers and slingshots not working be caused by a bad k1 relay? Does anyone think that should be replaced? Any way to test it to see if the k1 on the board is good or bad?

Not likely but possible. Check the simple stuff first. Most likely the flippers and slingshots are separate problems. Check flipper power supply board (it has it's own fuse F2, small board under CPU board). Special solenoids get power from main power supply board (also F2, but to the right of the CPU board)

Verify power present at both terminals of the coils of the flippers and slings with a meter.
From there it's test the actuating switches.

Once you get all that looked into then report back with specifics.

#17 7 years ago

I asked about the relay based on what it looks like he tried already. So far he:

- replaced q68 tips
- checked fuses under playfield and on flipper power board
- Did test with a DMM the connectivity to the flippers and slings
- Did ground out the connection with a DMM and the flipper and sling coils did fire.

I was over his house trying to help him and when it did work briefly both the slings and flippers worked. When it stopped working both did not work. So we think the problem is related. What is on the cpu board that could be malfunctioning that effects both the slings and flippers?

#18 7 years ago

Just backing up willy39
We did check all the simple stuff power , fuses grounded the coils and they fired . Also checked the EOS and all checks out . Hunted down the bad TIP and replaced it last night and still have no flippers or slings . That's why we are thinking that it could possibly be the K1 relay ????????

#19 7 years ago

You should hear the K1 relay click in when the game is started or when you enter test mode.

Measure from the flipper button org-gry or org-vio wire (ground side of the button) back to chassis ground (ground braid is convenient). If K1 is working you should have continuity to ground. Current path: power supply-->flipper coil-->>cabinet button--->>back to CPU K1 --->>to ground

#20 7 years ago

Just took a look at the MPU schematics, if relay K1 is found to not be pulling in it looks like U50 IC is feeding into both Q7(turns on K1 flipper relay) and special solenoids SS5T and SS6T. I'm not sure if these are the for the slings or not. Grounding Q77 or Q79 should tell you if those are the correct transistors for the slings. If U50 is bad that could be the common fault between flippers and slings.

#21 7 years ago

Thanks wayout440! We will play around with it this weekend and post what we find out!

#22 7 years ago

Thanks wayout440 , pulled the u50 and reseated it , flipper and sling issue is gone !!!

#23 7 years ago
Quoted from Shefhog:

Thanks wayout440 , pulled the u50 and reseated it , flipper and sling issue is gone !!!

Wow, and it wasn't even bad. Good for you - glad you got it!

Promoted items from the Pinside Marketplace
$ 9.00
Electronics
Yorktown Arcade Supply
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 1.25
Playfield - Other
Rocket City Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
1,600 (OBO)
Machine - For Sale
Huntley, IL
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 17.00
$ 27.99
Eproms
Matt's Basement Arcade
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 18.99
Eproms
Matt's Basement Arcade
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside