(Topic ID: 124256)

FG - Alltek Ultimate MPU Board 5 Flashes


By boo32

4 years ago



Topic Stats

  • 13 posts
  • 4 Pinsiders participating
  • Latest reply 4 years ago by barakandl
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 years ago

Flash Gordon was working well with one error. On the playfield inserts for the upper playfield bonus, the playfield lamp under the number nine would never turn on and the number ten was locked on and would turn on with the GI.

This morning, i entered the self-test by pressing the button inside the coin door. I had never tried the self-test and wanted to see if it would shed any light on the locked on insert lamp.

I pressed the button and it entered the test. The number nine did not light and the number ten stayed lit and would dim when the playfield lights flashed. I continued through the test and cycled the power.

Now, the alltek mpu self-test light only flashes five times. The playfield and backbox GI are on, but the displays do not come on. When I turn it on, the power on siren sound continues for about a minute and then goes off.

Ive looked up the significance of the five flashes and found this:

Fifth Flash:
Tests the second PIA chip (U11). As above. If you have already swapped U10 and U11 and don't have the fifth flash, try a new 6821 in U11. If still no success, swap once more. Worst case-replace both PIA's.

Sixth Flash:
Tests the Display Interrupt Generator. This actually tests both U11 and U12. If U11 has been replaced, and no sixth flash, replace U12.

Does five flashes mean it is failing the fifth test? Need to replace the U11 chip?

Thanks in advance for reading this.

#2 4 years ago

also check your 42V 5a fuse on the transformer (and check the test points on the Allek MPU). If the 42V is not present, it will not give you all flashes either.

#3 4 years ago

Followed a suggestion that I check fuses - I know I'm new and not great at diagnostics. I found that F4 was bad. I replaced F4 and did it blew shortly after power on. Where does the diagnosis go from here?

#4 4 years ago

In theory this could stem from a few problems. Bad knocker coil, bad coin lockout coil, bad bridge rectifier on power supply. If it was bad playfield solenoids would blow the 1-2amp pf fuse, not the rectifier board fuse would be blowing.

Unplug every connector on the driver board. Power up again with new fuse and see if it blows.

That will isolate the problem to driver board / solenoid coil issues or a power supply bridge rectifier issue.

PS you are seeing 6 flashes, not 5. No 7th flash means no zero crossing. No 43v input to MPU no zero cross and no 7th flash.

#5 4 years ago

I unplugged the connectors to the driver board. The fuse did not blow.

Before I forget, thanks to everyone for taking the time to help me through this.

Barakandi, interesting you mentioned the knocker coil. This machine is fairly new to me and I don't think I have heard the knocker fire even when a new high score was set.

#6 4 years ago

a seized coil could result in a short circuited transistor that drives it... which would blow a fuse at power up. So by disconnecting the coil drive connector, you can isolate at least if it is the CPU controlled coils or something else. It takes time...

#7 4 years ago

It is also very common for the coin lockout coils to be removed, tampered with, have things jammed up against them, etc. Make sure that the little coil on the coin door is not screwed up. It is an easily overlooked coil.

#8 4 years ago

Since I can't get into test and I have everything disconnected from the driver/power board, how do I test the coils? Physically inspecting that there is no frozen coil?

#9 4 years ago

That is a good place to start. Make sure that the plunger moves, the coil does not look crispy, there is nothing sorting the lugs, etc.

#10 4 years ago

None of the coils seems to be physically bound. I checked the coil in the coin door and the arm it hits could have been out of place.

Should I begin restarting while adding one connector at a time to the driver board to try to isolate the problem location?

#11 4 years ago

I hooked up the connectors expect for j2. The game goes into attract and will start a game. When j2 is connected, the fuse at j4 on the rectifier board blows.

#12 4 years ago

I clipped the line to the knocker and now everything is working, except the knocker of course. Going to get a new coil for the knocker and see if I can get it to work.

Thank you for all the help.

#13 4 years ago
Quoted from boo32:

I clipped the line to the knocker and now everything is working, except the knocker of course. Going to get a new coil for the knocker and see if I can get it to work.
Thank you for all the help.

q3 / knocker circuit needs a separate fuse. Oversight from Bally. You will see q3 area on the driver burned burned up pretty often on these driver boards.

Your Q3 will need to be checked on your driver board if it locks on when you install a new solenoid. Make sure to get the diode orientation correct as well.

Promoted items from the Pinside Marketplace
$ 279.95
$ 279.95
$ 399.95
$ 279.95
$ 279.95
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 49.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 3.00
Playfield - Decals
Doc's Pinball Shop
$ 89.99

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside