(Topic ID: 258271)

Fathom Switch Issues


By Hi-Fi

53 days ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 52 days ago by Quench
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

0988D507-7834-4513-9E40-EE8DFCE2D705 (resized).png

#1 53 days ago

Hello,

My Fathom is acting strange and I can’t seem to figure out what the problem is.
All the coils fire in the test mode. There are also no stuck switches.

However I have some switches that fail to register.

The middle pop bumper does not work, the left outlane switch labeled “special” does not register. On the left drop target bank the third blue drop target (second one from the top) does not register. I also cannot change the A B C rollover lights by pressing the flipper button.

I looked at the schematic and “I 6” (65-A4J2-14) has most of these features so I thought I was on to something. However, the right flipper and the tilt still work?

Any idea what I should check next?

0988D507-7834-4513-9E40-EE8DFCE2D705 (resized).png
#2 53 days ago
Quoted from Hi-Fi:

I looked at the schematic and “I 6” (65-A4J2-14) has most of these features so I thought I was on to something. However, the right flipper and the tilt still work?

You are onto something.
All those switches on "I6" that aren't working come from MPU connector J2 to the playfield. The tilt and right flipper button on "I6" come from MPU connector J3 to the cabinet.
So you likely have a bad connection at MPU J2 pin 14 that needs to be reterminated with a new crimp terminal.

#3 52 days ago

Could it also be a broken or disconnected wire on one of the switch lugs somewhere downstream of all the switches that aren’t working in that row? The switches aren’t necessarily wired in the same order as on the diagram, so if this is the issue, you would have to check each one.

#4 52 days ago
Quoted from Nokoro:

Could it also be a broken or disconnected wire on one of the switch lugs somewhere downstream of all the switches that aren’t working in that row?

Sure could. OP didn't mention the 2nd green inline drop target not working which is also on that row so potentially it could be a broken wire at/after that inline drop target switch.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 45.00
Displays
PinballSolutions.eu
$ 17.00
$ 9.00
Cabinet Parts
Third Coast Pinball
$ 90.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside