(Topic ID: 295213)

Fathom slingshot solenoid dead - Locked-on after diode came loose

By Aeon

11 months ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 11 months ago by BigAl56
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Skjermbilde2 (resized).JPG
Skjermbilde1 (resized).JPG

#1 11 months ago

Hi guys. I have a Fathom pinball machine. During my last game, I noticed that the left slingshot ended in a locked-on state after kicking the ball out. Very soon after, it smelled burned components and I immediately turned off the machine.

After inspecting the machine, I saw the diode was broken off on the right side of the solenoid (red circle in picture below). I hoped it was just to solder it in place again, but after testing I can hear that both switches on the slingshot is working correctly, but the solenoid isn't kicking anymore.

The solenoid looks fine so I'm afraid it might be the solenoid driver board that got toasted which I haven't checked yet as I don't know where to look or troubleshoot it.

This is what got me this far:
https://techniek.flipperwinkel.nl/ballyss/rep/index3.htm#driver

Is there anyone who can put me in the right direction what to troubleshoot next in this spesific scenario?

Skjermbilde1 (resized).JPGSkjermbilde2 (resized).JPG
#2 11 months ago

The driver transistor for this coil will be shorted on the A3 driver/power supply board.

Look in the schematic for which one is the driver or run your meter along them all (power OFF - meter set to resistance) and find the shorted transistor.

Put a new diode on the coil, they are only $0.01 each and not worth risking. Use a 1N4007 although 4004 will suffice.

#3 11 months ago

Verify that the correct coil is in use. Usually is an AN-26-1200 or or AQ-25-1200. Both have two lugs, that appears to be a flipper coil.

#4 11 months ago

Thanks, pins4u! I'll take a closer look. And probably come back with more questions.

nplg, yes, the coil for the right slingshot is different so I think you might be correct.

#5 11 months ago

Broken or miswired diode is usually death to the SD board transistor. Also check the playfield fuse and make sure it's a 1A SB.

Promoted items from the Pinside Marketplace
$ 149.95
Boards
Allteksystems
$ 18.95
Eproms
Pinballrom
$ 55.00
Displays
PinballSolutions.eu
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 18.95
Eproms
Pinballrom
$ 17.00
From: $ 45.00
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!