(Topic ID: 124335)

Family Guy Club - "Victory shall be mine!"

By jardine

7 years ago


Topic Heartbeat

Topic Stats

  • 481 posts
  • 100 Pinsiders participating
  • Latest reply 32 days ago by PanzerFreak
  • Topic is favorited by 24 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20211204_145521 (resized).jpg
20211202_210138 (resized).jpg
Doc1 (resized).jpg
IMG_20211201_181636_381 (resized).jpg
IMG_20211202_123511_098 (resized).jpg
IMG_3385 (resized).JPG
IMG_3389 (resized).JPG
FG Pinballl (resized).jpg
FG Pinball (resized).jpg
20211201_201109 (resized).jpg
20211120_124813 (resized).jpg
20211113_150927_HDR (resized).jpg
20211027_155740 (resized).jpg
20211027_154710 (resized).jpg
20211027_154715 (resized).jpg
Screenshot_20210509-032730_Gallery (resized).jpg

There are 481 posts in this topic. You are on page 10 of 10.
#451 6 months ago

UPDATE: Nobody could have seen this coming, but Stewie was actually unplugged!
Haha thanks purplemunkydishw and Williampinball , you are both right.
I made sure the connector can't get loose anymore.

Stewie works now, but it does act a bit odd.. twitchy or something. The software version is 11.0, is this something an update would fix?

#452 6 months ago
Quoted from RobDutch:

UPDATE: Nobody could have seen this coming, but Stewie was actually unplugged!
//<![CDATA[
window.__mirage2 = {petok:"f2fdb6c1e0868e716ede5b9523577c2b0c3b31a2-1637190969-1800"};
//]]>

Haha thanks purplemunkydishw and Williampinball , you are both right.
I made sure the connector can't get loose anymore.
Stewie works now, but it does act a bit odd.. twitchy or something. The software version is 11.0, is this something an update would fix?

I have the same version so I wouldn't know if they fixed that in the new one or not but that's great it was a easyer fix

#453 6 months ago
Quoted from RobDutch:

UPDATE: Nobody could have seen this coming, but Stewie was actually unplugged!
Haha thanks purplemunkydishw and Williampinball , you are both right.
I made sure the connector can't get loose anymore.
Stewie works now, but it does act a bit odd.. twitchy or something. The software version is 11.0, is this something an update would fix?

Stewie is supposed to be twitchy. He will swing to one side or another then stop, then get twitchy, then swing back. It's normal.

QSS

#454 6 months ago

Man I miss this game .Traded plus $ for NIB LZprem ,which Im loving but that was the worst moment I’ve had in this hobby letting that go .Someday it will be back home .Someday I say !

#455 6 months ago
Quoted from RobDutch:

UPDATE: Nobody could have seen this coming, but Stewie was actually unplugged!
//<![CDATA[
window.__mirage2 = {petok:"b53390474269ad5fffecee033d4ec3d6b832ca8c-1637288798-1800"};
//]]>

Haha thanks purplemunkydishw and Williampinball , you are both right.
I made sure the connector can't get loose anymore.
Stewie works now, but it does act a bit odd.. twitchy or something. The software version is 11.0, is this something an update would fix?

I am thinking that's why it was unplugged but I like my and I don't mind it at all great game as a keeper

1 week later
#456 5 months ago

Before and after

20211120_124813 (resized).jpg20211201_201109 (resized).jpg
#457 5 months ago

Hi Everyone -
I'm Andy and based in the UK; a proud 'new' owner of this game and my first Pinball Machine. It was kindly bought as a surprise birthday present for me by my wife, and installed at home just a few days ago. We have fond memories of playing this with our nephews in Florida quite a few years back, so it's always been a favourite of ours. Having flicked through the game manual, and looked around the internet I can see the learning curve is going to be pretty steep to get my head around all the terminology let alone understand the inner workings for maintenance.

If anyone has the time and patience to help me with a couple of things I would be most appreciative, I have reached out to the supplier that my wife sourced the item machine and so far the responses have not resulted in successful resolution.

1) Stewie isn't moving at all during the game or during mini-pb.
When I select the 'F.G icon' within in the Diagnostics menu, no further menu options open on screen as per the manual, the menu just makes an acknowledgement sound that a button was pressed. I have also ensured the power interlock is in the correct position, as I have run the other diagnostics tests ok. I have taken a 'poor' photo's where I think that Stewie is plugged in and the rear cabinet to show some unplugged cables?

2) UK V2.0 is showing on boot, so I have attempted to update this to V12 from the Stern website. My USB stick appears to be recognised as it has allowed me to back up the existing system files and can see the V12 .bin on the USB for me to select it. But the update never goes further than an 'erase failed' message. Photos attached and a video uploaded if the link works as a new member.

Thank you kindly in advance

FG Pinball (resized).jpgFG Pinballl (resized).jpgIMG_20211201_181636_381 (resized).jpgIMG_20211202_123511_098 (resized).jpgIMG_3385 (resized).JPGIMG_3389 (resized).JPG
#458 5 months ago
Quoted from Crewey:

Hi Everyone -
I'm Andy and based in the UK; a proud 'new' owner of this game and my first Pinball Machine. It was kindly bought as a surprise birthday present for me by my wife, and installed at home just a few days ago. We have fond memories of playing this with our nephews in Florida quite a few years back, so it's always been a favourite of ours. Having flicked through the game manual, and looked around the internet I can see the learning curve is going to be pretty steep to get my head around all the terminology let alone understand the inner workings for maintenance.
If anyone has the time and patience to help me with a couple of things I would be most appreciative, I have reached out to the supplier that my wife sourced the item machine and so far the responses have not resulted in successful resolution.
1) Stewie isn't moving at all during the game or during mini-pb.
When I select the 'F.G icon' within in the Diagnostics menu, no further menu options open on screen as per the manual, the menu just makes an acknowledgement sound that a button was pressed. I have also ensured the power interlock is in the correct position, as I have run the other diagnostics tests ok. I have taken a 'poor' photo's where I think that Stewie is plugged in and the rear cabinet to show some unplugged cables?
2) UK V2.0 is showing on boot, so I have attempted to update this to V12 from the Stern website. My USB stick appears to be recognised as it has allowed me to back up the existing system files and can see the V12 .bin on the USB for me to select it. But the update never goes further than an 'erase failed' message. Photos attached and a video uploaded if the link works as a new member.
Thank you kindly in advance

[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

did you try the Stewie Motor Test?

Doc1 (resized).jpg
#459 5 months ago
Quoted from Moomert1:

did you try the Stewie Motor Test? [quoted image]

Thanks for replying, yes. When I select the 'F.G icon' within in the Diagnostics menu, no further menu options open on screen as per the manual, the menu just makes an acknowledgement sound that a button was pressed.

#460 5 months ago

Because it's on early code, the Stewie test may be under coils test. Regardless, 2.0 is very early buggy code. Likely won't work, but couldn't hurt to try another USB drive. Smallest drive you can find. If that doesn't work, I would contact Stern.

#461 5 months ago

Thank you phishrace for replying. Coil test #20 is missing from the coils tests list, and does not test on cycle either.
I will try to find a smaller USB, this was a 1GB. Thanks

#462 5 months ago

If anyone has some Family Guy Plastic pieces they are looking to sell, let me know. Seems that you can only order the entire set. I don't need the entire set. The piece I need is the "Shot Scoop to play Stewie Pinball" piece. Mine broke and needs to be replaced. I am also looking for the mini playfield slingshot plastic pieces.

20211202_210138 (resized).jpg
#463 5 months ago

Is there a protector for that shoot scoop plastic?

#464 5 months ago
Quoted from Crewey:

I will try to find a smaller USB, this was a 1GB.

1gb is plenty small enough. Try another one roughly that size. Maybe 4gb or smaller.

#465 5 months ago
Quoted from phishrace:

1gb is plenty small enough. Try another one roughly that size. Maybe 4gb or smaller.

Thanks again for your help phishrace I've now tried other USB thumb drives I have, formatted them as FAT32 but are not even being recognised when inserted. I'm assuming that is because they are 3.0 whereas the 1gb previously was not. I will see if I can dig out a different 1.1 or 2.0. Thanks

#466 5 months ago
Quoted from Crewey:

Thanks again for your help phishrace I've now tried other USB thumb drives I have, formatted them as FAT32 but are not even being recognised when inserted. I'm assuming that is because they are 3.0 whereas the 1gb previously was not. I will see if I can dig out a different 1.1 or 2.0. Thanks

Make sure everything is erased from the USB. No added #, letters, or file names. I use a pnk brand usb without problem.

#467 5 months ago
Quoted from tp:

Make sure everything is erased from the USB. No added #, letters, or file names. I use a pnk brand usb without problem.

Hi tp thanks for your input, the more the better for me to try new potential fixes.
Each time I've tried the USB's have been formatted blank to FAT32 and the V12 .bin added to the root only. Thanks

#468 5 months ago
Quoted from Moomert1:

If anyone has some Family Guy Plastic pieces they are looking to sell, let me know. Seems that you can only order the entire set. I don't need the entire set. The piece I need is the "Shot Scoop to play Stewie Pinball" piece. Mine broke and needs to be replaced. I am also looking for the mini playfield slingshot plastic pieces. [quoted image]

To help hide my cracked plastic, i added a Family Guy TV

20211204_145521 (resized).jpg
#469 5 months ago
Quoted from phishrace:

1gb is plenty small enough. Try another one roughly that size. Maybe 4gb or smaller.

I have now tried further USB thumb drives and the error is the same every time (as per the video) 'erase failed'

#470 5 months ago

You do flip switch 8 dip switch, right?

#471 5 months ago
Quoted from dapperdan24:

Is there a protector for that shoot scoop plastic?

Yes there is/was a protector made for the scoop. I've got it on my game and I'll check my books as to where I got it. It's an excellent addition to the game if you can even still get one.

QSS

#472 5 months ago
Quoted from QuickSilverShelby:

Yes there is/was a protector made for the scoop. I've got it on my game and I'll check my books as to where I got it. It's an excellent addition to the game if you can even still get one.

QSS

If you can find where that was from, I'd be super appreciative!

#473 5 months ago
Quoted from Bublehead:

You do flip switch 8 dip switch, right?

Sure did Bublehead thanks,

Stern have replied to the supplier my wife bought the machine from to say, the Boot Rom should be V3.1 and not V2.0 that's in the machine.
As a total noob I have no idea if that's something I can easily swap out if they send me the part, or is more involved and requires more knowledge and skill.

#474 5 months ago

Just a reminder - if anyone would like the UNRELEASED 12.02 Code, PM me your Email & I'll send it to you. It's Free Play Only, so if you're operating your game, you won't want it.

This code fixes the following:
-Sound spike bug fixed. SAM games had a bug where the sound gets crazy loud, and you have to shut off the game to "fix" it. Many games got a code update to squash that bug...for some reason FGY's wasn't released. 12.02 fixes this.
-LARD countdown bug fixed. After Lard Multiball ends, Stewie will sometimes keep counting down for Jackpot, even though the mode is over. 12.02 fixes this.

#475 5 months ago
Quoted from dapperdan24:

If you can find where that was from, I'd be super appreciative!

Ok, give me a day or two and I'll check my books and see if I have a record of where I bought it. Will get back to you shortly.

QSS

#476 5 months ago
Quoted from Rarehero:

Just a reminder - if anyone would like the UNRELEASED 12.02 Code, PM me your Email & I'll send it to you. It's Free Play Only, so if you're operating your game, you won't want it.
This code fixes the following:
-Sound spike bug fixed. SAM games had a bug where the sound gets crazy loud, and you have to shut off the game to "fix" it. Many games got a code update to squash that bug...for some reason FGY's wasn't released. 12.02 fixes this.
-LARD countdown bug fixed. After Lard Multiball ends, Stewie will sometimes keep counting down for Jackpot, even though the mode is over. 12.02 fixes this.

PM sent. I want this.

QSS

1 week later
#477 5 months ago
Quoted from Crewey:

Sure did Bublehead thanks,
Stern have replied to the supplier my wife bought the machine from to say, the Boot Rom should be V3.1 and not V2.0 that's in the machine.
As a total noob I have no idea if that's something I can easily swap out if they send me the part, or is more involved and requires more knowledge and skill.

Apologies for being a needy noob here; I have tried googling this to understand some of the schematics involved but it still isn't quite clear.
Basically after I confirmed to the distributor that the CPU was 520-5246-00 CPU (which is apparently correct) and the Boot ROM installed is V2.0 (V3.1 is apparently what should be present) They have informed me that their UK stern supplier has recommended a CPU replacement, which will take a long time due to the pin being old and parts coming from the USA.

Please excuse my ignorance I honestly have tried reading up to work this out myself, but would replacing the Eprom with a V3.1 that has the most recent Family Guy software version pre installed not possibly resolve the issue? Isn't changing out the whole CPU overkill, bearing in mind they have only seen the video that I've uploaded previously

If the Stewie motor had been working when we received the pin, I'd have never tried to find the Stewie test motor diagnostic to then find out it doesn't even exist in this very early version of the software

#478 5 months ago
Quoted from Crewey:

Apologies for being a needy noob here; I have tried googling this to understand some of the schematics involved but it still isn't quite clear.
Basically after I confirmed to the distributor that the CPU was 520-5246-00 CPU (which is apparently correct) and the Boot ROM installed is V2.0 (V3.1 is apparently what should be present) They have informed me that their UK stern supplier has recommended a CPU replacement, which will take a long time due to the pin being old and parts coming from the USA.
Please excuse my ignorance I honestly have tried reading up to work this out myself, but would replacing the Eprom with a V3.1 that has the most recent Family Guy software version pre installed not possibly resolve the issue? Isn't changing out the whole CPU overkill, bearing in mind they have only seen the video that I've uploaded previously
If the Stewie motor had been working when we received the pin, I'd have never tried to find the Stewie test motor diagnostic to then find out it doesn't even exist in this very early version of the software

The boot rom doesn't contain the game’s code. That rom is burnt on a chip, game code is re-writable using the USB port.

I don’t remember if the boot rom is socketed…but if it is, find someone local who can burn the rom for you. Easy to swap it out. If it’s soldered, you can still probably find someone local to burn & remove the old one, add a socket, then replace.

#479 5 months ago
Quoted from Rarehero:

The boot rom doesn't contain the game’s code. That rom is burnt on a chip, game code is re-writable using the USB port.
I don’t remember if the boot rom is socketed…but if it is, find someone local who can burn the rom for you. Easy to swap it out. If it’s soldered, you can still probably find someone local to burn & remove the old one, add a socket, then replace.

Thank you Rarehero for clarifying that the boot ROM doesn't contain game code! As the 'erase flash failed' error consistently occurs when trying to update the game via any USB, it now makes more sense why they want to replace the CPU.
Regards
Andy

1 week later
#480 4 months ago

Merry Christmas to all fartheads!!

3 months later
#481 32 days ago

Have a brand new complete Family Guy plastic set for sale, please PM if interested.

https://pinside.com/pinball/forum/topic/family-guy-plastic-set-803-5000-93

Promoted items from the Pinside Marketplace
6,200 (Firm)
Sale Pending! Machine - For Sale
Mount Joy, PA
$ 6.00
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 99.00
Boards
PinballReplacementParts
From: $ 18.00
Apparel - Men
Pinside Shop
$ 599.95
Lighting - Led
Pin Stadium Pinball Mods
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
Wanted
Machine - Wanted
Monclova, OH
There are 481 posts in this topic. You are on page 10 of 10.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!