(Topic ID: 66172)

F14 Tomcat Owners Club Fans Also Welcome.


By Hellfire

6 years ago



Topic Stats

  • 4,117 posts
  • 325 Pinsiders participating
  • Latest reply 5 hours ago by C0untDeM0net
  • Topic is favorited by 132 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,242 images uploaded to this topic. (View topic image gallery).

f-14 (resized).PNG
Williams_1987_F_14_Tomcat_PS.pdf (PDF preview)
IMG_20200125_151942729 (resized).jpg
DSCN1658 (resized).JPG
DSCN1525 (resized).JPG
DSCN1576 (resized).JPG
DSCN1518 (resized).JPG
pasted_image (resized).png
pasted_image (resized).png
20200120_185319_HDR (resized).jpg
20200120_185310 (resized).jpg
20200120_185038 (resized).jpg
20200120_185229 (resized).jpg
20200120_185630 (resized).jpg
20200110_193532 (resized).jpg
20190901_211820 (resized).jpg

You're currently viewing posts by Pinsider tomdk.
Click here to go back to viewing the entire thread.

#2200 2 years ago

Question in the club:
Anybody ever heard from a proto or earlie F-14 with the additionel 4 bulbs on the display pcb CONNECTED ?!
Many machines have this display like in Millionaire ... but so far no one ever had it connected to the PDB ..

Thanks for looking

#2203 2 years ago
Quoted from Averell:

We're in charge to do that - it's not so difficult.
You need some resistors, sockets, bulbs or LED and the connection to the power supply or to the GI wiring.
The base of the LED-Panel is the same as used in the Millionaire, but that Pin has two more displays for credit counter.

YOu are in charge .. I am just the guy sitting in the corner waiting for your success

Same question in r.g.p. ... no usefull answer so far. A guy told me that he had a look in the proto schematics and there is no space for an other 4 switched lamps in the matrix. F-14 uses them all ....

4 weeks later
#2278 2 years ago

Important Information !!

The beacon motors from all the different shops will not work properly in F-14 !

I bought a motor from marcos but it was only able to run 2 beacon ight, if added the third it starts stuttering.
Today I got my fixed original motor back and it works.

The difference is 5 watt. The repro has 3 watt, the original 8 watt ... it seems that the repro motors are only useable in Highspeed.

Just as an information that you dont spend money for the crappy motors !

I payed with shipping and taxes a hell lot of money for this motor.

#2282 2 years ago
Quoted from shirkle:

I got a repro from Marco and it fully works. I don't know how many watts it is, but I can check.

This will be the motor I have, so you are a lucky guy. I had no luck with this motor. So it seems there is a 50:50 chance that it works

#2291 2 years ago
Quoted from gutz:

few things to check: Did you replace the nyliners on the outside beacons? Is the washer on top of the middle pulley stack to prevent the pulley from contacting the mounting plate? Are the rotating arms binding low or contacting the lamp arm?

Mechanical is everything well. i did not change the nyliners, only the rubbers.
With the 4 Watt motor middle and left turned and middle and right turned but not all three. That means that the motor is missing some power. I am not a electronic expert but it seems to make sense that 8 watt replaced by 3 watt is a large difference.
I guess this motors are for Highspeed with one rotating beacon .. there might be 3 watt enough.

However .. mine is working nop. It should be just a hint for replacers **IF** they run in the same problem. it might save them some time to figure out

#2334 2 years ago

A metall socket with 2 watts is a 44, therfor you need no manual.
Never would I use a LED in a vintage game ... just replace the bulb, its a red or blue cap on it. remove it with some water and you can use it again .. dont forget to clean the "billy boy".

1 week later
#2365 2 years ago

?? Yes please ??

#2382 2 years ago

I also installed this very very usefull board and kicked the capacitor out.
Avarell loves the look of this bomb

the boards are great, the price is great ... if I see what other people aski here for moddings , and this is not a toy. It is a usefull part to prevent your machine from burning down ...

2 weeks later
#2414 2 years ago

Good luck with the motor !
Please let us know if it works ! I had this replacement and it was not able to turn on all 3 beacons.

Coindoor: Black ...

#2417 2 years ago

Thanks for response .. than I was just unlucky with the motor !

Enjoy the aircraft !!

2 months later
-1
#2515 2 years ago

F-14 has no decals .... sorry ... could not resist ...

#2523 2 years ago

I has luck .. my F-14 was not completely faded or destroyed. I bought several cans of good paint and tested which color will fit best for red and black. Little white and yellow was brushed. Masked with regular tape.
The whole was coated with a non glossy clearcoat .. also in a can.
The good point: I could rescue the little sticker in the front

P1090770 (resized).JPG

P1090758 (resized).JPG

P1090728 (resized).JPG

P1090778 (resized).JPG

1 month later
#2607 2 years ago

Why ??
The bulbs are not connected as I know ..... and the panel is not original anyway ... so it makes no sense ....

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 221.00
Cabinet Parts
Tilted Pinball
$ 14.50
Electronics
PinballElectronics.com
$ 17.00
Trade
$ 9.00
Electronics
Yorktown Arcade Supply
$ 5.00
Playfield - Decals
Metal-Mods

You're currently viewing posts by Pinsider tomdk.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside