(Topic ID: 66172)

F14 Tomcat Owners Club Fans Also Welcome.


By Hellfire

5 years ago



Topic Stats

  • 3,827 posts
  • 303 Pinsiders participating
  • Latest reply 4 days ago by TicTacSeth
  • Topic is favorited by 119 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,120 images uploaded to this topic. (View topic image gallery).

DB184DA4-4152-4C97-99C8-CE256B17AF8F (resized).jpeg
Screen Shot 2019-06-14 at 1.50.17 PM (resized).png
image (resized).jpg
beacondome (resized).jpg
D3A9267A-773B-4AA6-93D6-A34234208BA9 (resized).jpeg
cracked pins (resized).jpg
trans (resized).PNG
Photo May 30, 4 57 59 PM (resized).jpg
Photo May 30, 4 49 34 PM (resized).jpg
Photo May 30, 4 57 51 PM (resized).jpg
Photo May 29, 10 12 02 PM (resized).jpg
Photo May 30, 5 18 42 PM (resized).jpg
Photo May 30, 5 18 29 PM (resized).jpg
Photo May 30, 6 09 04 PM (resized).jpg
Photo May 30, 5 20 18 PM (resized).jpg
Photo May 30, 5 19 32 PM (resized).jpg

There are 3827 posts in this topic. You are on page 77 of 77.
#3801 14 days ago
Quoted from shirkle:

Is it possible my beacons are pulling power away from that VUK coil somehow?

Beacons are 26 vac and the VUK coil is 50 volts dc. But the VUK coil is turned on by a snubber relay, this relay is powered by B+ which comes from the same winding that power the beacons. I would check the connector 6P1 in the cabinet for a poor connection on the red wires. Then I would remove the snubber and look for cracked solder joints.

trans (resized).PNGcracked pins (resized).jpg
#3802 14 days ago

Thank you for pointing me in the direction of the snubber board. It's almost certainly the culprit. When I removed it to check the solder joints, I found that it had been hacked pretty bad- one of the through hole pads was missing and it had a couple jumper wires connecting different sides of the relay. The relay itself had been replaced.
I just ordered a new board from pinballpcb.com. I'm hoping that does the trick.

I can't believe I didn't think of the beacons before as a possible connection. I played one game earlier where the ball got stuck in the VUK....I reached into the backbox, unplugged the beacon, and it fired instantly.

#3803 9 days ago

Just joined the club today! Game isn't fully working, so I'm excited to dig in. I'll have to find a pic.....

D3A9267A-773B-4AA6-93D6-A34234208BA9 (resized).jpeg
#3804 8 days ago

Does anybody have a high res scan of Hitman and Yag from the top of the PF? Mine are pretty worn.

#3805 8 days ago

Hey all, got a new F-14, so yay! Problem though, it only registers every other ball drain??? No joke, it is dialed in to every other drain, so it won’t pop another ball out to the shooter lane. And if I turn the game off on the one it is supposed to not register, and turn it on, it can’t find the ball. Not sure how it’s possible that it is such a consistent error, but that’s what’s happening. Anyone had this happen on theirs???

#3806 8 days ago

I'm in the process of repairing my playfield and I noticed that a few of my blue arrowheads have some hairline cracks. I've looked on marco and pinball life for them but can't seem to find replacements. Do they exist anywhere?

#3807 7 days ago

I ordered a complete set from planetary pinball supply. A little expensive with shipping and customs though...

https://www.planetarypinball.com/mm5/merchant.mvc?Screen=PROD&Product_Code=PPS-F14-INSERTSET

#3808 7 days ago

WTB Anyone out there have any beacon domes they'd like to sell? Im looking for all 3 but ill take anything you've got. I'm aware marco sells them but i just don't want to pay $32 each for them!

beacondome (resized).jpg
#3809 7 days ago
Quoted from pinplayerinva:

WTB Anyone out there have any beacon domes they'd like to sell? Im looking for all 3 but ill take anything you've got. I'm aware marco sells them but i just don't want to pay $32 each for them![quoted image]

Following the answer on this, also interested. (even though mine also doesn’t have the lighting assembly)

#3810 7 days ago
Quoted from Phantasize:

I ordered a complete set from planetary pinball supply. A little expensive with shipping and customs though...
https://www.planetarypinball.com/mm5/merchant.mvc?Screen=PROD&Product_Code=PPS-F14-INSERTSET

Great, thanks for the link. I ordered a set. Shipping to Canada wasn't too bad via regular mail, 13 bucks.

#3811 7 days ago
Quoted from pinplayerinva:

WTB Anyone out there have any beacon domes they'd like to sell? Im looking for all 3 but ill take anything you've got. I'm aware marco sells them but i just don't want to pay $32 each for them![quoted image]

PM sent.

#3812 5 days ago

Haven’t dug in too deep yet, need to order the manual, but anyone quick know what this is for? It’s blowing and for sure blows when I press start button

image (resized).jpg
#3813 5 days ago

So that fuse is the purple wire that goes to the coils affected, and the top plug of the flipper power board. However all the flippers work just fine.

#3814 5 days ago

It may be the outhole coil that is blowing that fuse when it tries to put a ball in the shooter lane?

#3815 5 days ago
Quoted from northvibe:

So that fuse is the purple wire that goes to the coils affected, and the top plug of the flipper power board. However all the flippers work just fine.

The fuse with the purple/yellow wire is for the 50 volt coils.

#3816 5 days ago
Quoted from shirkle:

Thank you for pointing me in the direction of the snubber board. It's almost certainly the culprit. When I removed it to check the solder joints, I found that it had been hacked pretty bad- one of the through hole pads was missing and it had a couple jumper wires connecting different sides of the relay. The relay itself had been replaced.
I just ordered a new board from pinballpcb.com. I'm hoping that does the trick.
I can't believe I didn't think of the beacons before as a possible connection. I played one game earlier where the ball got stuck in the VUK....I reached into the backbox, unplugged the beacon, and it fired instantly.

Just wanted to follow up on this in case anyone else ever has this particular issue. Again, my VUK wouldn't work specifically, and only, during multiball. It was the snubber board that was bad. I replaced it with one from Pinballpcb.com and the game is finally working 100%.

#3817 5 days ago
Quoted from pinlink:

It may be the outhole coil that is blowing that fuse when it tries to put a ball in the shooter lane?

ahhh... I'll get more fuses. Is that fuse a 2.5amp? I think it is this fuse in the pic, in red. 2.5.

And I see that that ball shooter lane feeder coil could cause it. To test, should I just un-solder the coil or is there a better way to test that.

Quoted from GRUMPY:

The fuse with the purple/yellow wire is for the 50 volt coils.

Thanks! I was tracing wire all over last night and I'm glad you confirmed. I did read some of the pdf manual, but man I love the paper ones

Screen Shot 2019-06-14 at 1.50.17 PM (resized).png
#3818 5 days ago

HA! I just realized I should state the actual issue now that I messed with some stuff last night.

Currently. Power game up, attract mode and coin up works. I coin up, and press start, I hear some coils or things reset. I launch the ball and it just goes around the ramp to the 3rd spot and runs to that lower right lock...then another ball comes out into the shooter lane and does the same. So 2 balls in the lower right lock. Balls wont eject from lower right lock, middle two locks, upper right VUK, the upper left 2 ramp diverters or the kick back on the lower left.

#3819 5 days ago
Quoted from northvibe:

Is that fuse a 2.5amp

Yes, 2.5 slow blow.

#3820 5 days ago
Quoted from northvibe:

I launch the ball and it just goes around the ramp to the 3rd spot and runs to that lower right lock...then another ball comes out into the shooter lane and does the same. So 2 balls in the lower right lock.

Check the switch in the lower right ball lock.

#3821 5 days ago
Quoted from GRUMPY:

Check the switch in the lower right ball lock.

Yeah, all the switches seemed good. No continuity when open, I cleaned one, but all had continuity when closed. I will re-test again. If a switch was stuck though, wouldnt the coil fire and hold?

#3822 5 days ago
Quoted from northvibe:

Yeah, all the switches seemed good. No continuity when open, I cleaned one, but all had continuity when closed. I will re-test again. If a switch was stuck though, wouldnt the coil fire and hold?

Go into switch test mode. From there, press on the lower right lock switch to make sure it is registering. If it is, then go to solenoid test to make sure that solenoid is firing.

#3823 4 days ago
Quoted from pinlink:

Go into switch test mode. From there, press on the lower right lock switch to make sure it is registering. If it is, then go to solenoid test to make sure that solenoid is firing.

HA, I always forget old games have test modes. Thank you, I'll run switch tests.

#3824 4 days ago

This one might be an easy one to get help on.

It’s hard to get a picture of these, but the GI lighting under the playfield that goes up between the 1,2,3,4,5,6 targets, and the lower TOM CAT are out. Is that all controlled on one fuse? I have continuity. There were wires cut and stayed apart on the 1,2,3, so that side wasn’t working but the rest were. I tested touching the wire over and it did work before I soldered it. Now none of them work. Any thoughts?

I am also Still having issues where the ball drains, will kick it over to the switch, but the game doesn’t recognize the drain, and it happens exactly every other time a ball drains. So any help on this one would still be great!

DB184DA4-4152-4C97-99C8-CE256B17AF8F (resized).jpeg
#3825 4 days ago
Quoted from TicTacSeth:

This one might be an easy one to get help on.
It’s hard to get a picture of these, but the GI lighting under the playfield that goes up between the 1,2,3,4,5,6 targets, and the lower TOM CAT are out. Is that all controlled on one fuse? I have continuity. There were wires cut and stayed apart on the 1,2,3, so that side wasn’t working but the rest were. I tested touching the wire over and it did work before I soldered it. Now none of them work. Any thoughts?
I am also Still having issues where the ball drains, will kick it over to the switch, but the game doesn’t recognize the drain, and it happens exactly every other time a ball drains. So any help on this one would still be great![quoted image]

Solved, fuse didn’t look blown at all, but it was.
Solved the second issue too, cracked solder joint.

Last thing to solve is a weak pop bumper.

#3826 4 days ago
Quoted from TicTacSeth:

Solved, fuse didn’t look blown at all, but it was.
Solved the second issue too, cracked solder joint.
Last thing to solve is a weak pop bumper.

Nice work. My pop bumper is less strong than any other game I have but I assume it is because of the tight confines it is in so as not to tear things apart with the ball. It should be a 23-800 which is used alot in this game and is less powerful than Walking Dead's 26-1200.

#3827 4 days ago
Quoted from Gogojohnnyquack:

Nice work. My pop bumper is less strong than any other game I have but I assume it is because of the tight confines it is in so as not to tear things apart with the ball. It should be a 23-800 which is used alot in this game and is less powerful than Walking Dead's 26-1200.

Ah, good to know. I thought it was there to bang the ball around the targets a bit more than it does. It’s not pushing the ball up to them that much.

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 69.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 16.95
€ 3.70
$ 36.99
Eproms
Matt's Basement Arcade
$ 279.95
$ 279.95
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
2,100 (OBO)
Machine - For Sale
Culpeper, VA
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 19.99
Eproms
Matt's Basement Arcade
$ 399.95
$ 279.95
1,500 (OBO)
Machine - For Sale
Atlanta, GA
$ 14.00
Electronics
Yorktown Parts and Equip
$ 279.95
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 221.00
Cabinet Parts
Tilted Pinball
$ 50.00
There are 3827 posts in this topic. You are on page 77 of 77.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside