(Topic ID: 66172)

F14 Tomcat Owners Club Fans Also Welcome.


By Hellfire

6 years ago



Topic Stats

  • 4,079 posts
  • 322 Pinsiders participating
  • Latest reply 1 day ago by GRUMPY
  • Topic is favorited by 131 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,223 images uploaded to this topic. (View topic image gallery).

Screen Shot 2019-11-27 at 12.20.15 PM (resized).png
0A1FAC8F-F8B7-4022-A2F9-427D30D0E3B0 (resized).jpeg
20191026_193510 (resized).jpg
20191025_220604 (resized).jpg
20191025_220544 (resized).jpg
881B8B42-A93A-4236-8EDC-44DD76BB744F (resized).jpeg
02979AB8-B113-40D4-B71A-E29C2AB9CE66 (resized).jpeg
8F68FF0E-4EC1-42C7-8750-6F3C786179CA (resized).jpeg
F66A765B-6CD5-4CEB-9C94-8321AC303173 (resized).jpeg
625D4BB7-2C1C-49E1-8FC6-856F6C0B01E9 (resized).jpeg
DC33FB5C-B7C1-4208-B6A3-6DAE1D0AFC13 (resized).jpeg
B0F64912-39F5-416C-A94D-58595E0350CB (resized).jpeg
04E3C15C-A6E5-48F6-8CCD-00EFCAA125B7 (resized).jpeg
20191012_085151 (resized).jpg
20191012_085132 (resized).jpg
CF00E10A-4C10-4798-9161-2DFFF008B890 (resized).jpeg

There are 4079 posts in this topic. You are on page 59 of 82.
#2901 2 years ago
Quoted from Arcade:

Not exactly sure how to test coil power.

DMM set to 200 volts DC, black lead to ground braid and red lead you check for power at each lug on the coil. Power on both lugs = good power and good coil. Power on one lug = good power and bad coil. No power on either lug = no power, then check both sides of the fuse with the red lead. Power on both sides of the fuse = good power and good fuse.

#2902 2 years ago
Quoted from GRUMPY:

You can do a factory reset also.

Is a factory reset different than resetting to factory settings? I did reset to factory then switched to free play(no help).I can't reach the roms tonight,my sick pup is camped out in front of the machine and it's wedged in between others.

#2903 2 years ago
Quoted from Puffdanny:

Is a factory reset different than resetting to factory settings?

Same thing.

#2904 2 years ago
Quoted from Puffdanny:

I can't reach the roms tonight,my sick pup is camped out in front of the machine

If you remove all 4 balls and put game in switch test, what comes up on the displays.

#2905 2 years ago

In test 05 switch levels nothing with all 4 ball removed,put balls back in and must manually flick them over and as I add more balls I get more trough errors.start game no ball ejects to shooter lane after manually advancing and launching ball it locks into the right side upper lock by pop bumber,ends turn and goes to ball 2.knocked ball out slings work and score as do tomcat targets,pop bumper and spinner.the rescue does not kick as well as Yargov.so it seems all coils are not firing except flippers.

#2906 2 years ago
Quoted from GRUMPY:

DMM set to 200 volts DC, black lead to ground braid and red lead you check for power at each lug on the coil. Power on both lugs = good power and good coil. Power on one lug = good power and bad coil. No power on either lug = no power, then check both sides of the fuse with the red lead. Power on both sides of the fuse = good power and good fuse.

Thanks again.
Leaving for Florida in the morning so I will get back to this next weekend.

#2907 2 years ago

Why are my black rubber shooter tips wearing out so fast on F-14?
These are the ones off Marco Specialties. I can't find any other type online. They all appear to be the same cheap quality. I remember getting one in my Sharkey's Shootout rubber kit that was heavy duty. This is what I need. Can't find them online.

#2908 2 years ago

Finally got mine 100% (as far as I can tell). I wanted to post a quick picture. I put in a pop bumper LED disc from Comet (I think...I ordered it a while ago). It adds a decent amount of light to the upper playfield.

All of the inserts are also colored LED, but I'm not sure if I like that or not. I've always been an incandescent fan, which is what I left in for the GI.

Love the new playfield- it plays so fast and smooth. I'm kind of considering a protector for it just to keep it mint, but that's probably overkill for how little I get to play my games.

IMG_0892 (resized).JPG

#2909 2 years ago

I'm picking up one of these games for $50. A guy came by the shop and does not want it anymore. No details whatsoever.

#2910 2 years ago
Quoted from Tmezel:

I'm picking up one of these games for $50. A guy came by the shop and does not want it anymore. No details whatsoever.

Awesome Tim. Congrats.
Paid $500 for ours Enjoying it a lot.
Fun game to fix up.

#2911 2 years ago
Quoted from Tmezel:

I'm picking up one of these games for $50. A guy came by the shop and does not want it anymore. No details whatsoever.

Mine was considerably more (wow, $50!), but I'm super happy for you. It's nice when stuff like that happens. Enjoy!

#2912 2 years ago
Quoted from Arcade:

Awesome Tim. Congrats.
Paid $500 for ours Enjoying it a lot.
Fun game to fix up.

I've got to say, I'm enjoying the game more than I thought I would. Don't know how long it will last, but it has my attention for a while.

#2913 2 years ago

All my shooter tips come from Titan. I believe they are silicon

#2914 2 years ago
Quoted from nightsearcher:

All my shooter tips come from Titan. I believe they are silicon

They don't sell plunger tips only. You have to buy a kit.

#2915 2 years ago
Quoted from StylesBitchly:

Why are my black rubber shooter tips wearing out so fast on F-14?
These are the ones off Marco Specialties. I can't find any other type online. They all appear to be the same cheap quality. I remember getting one in my Sharkey's Shootout rubber kit that was heavy duty. This is what I need. Can't find them online.

Maybe your just plunging too hard! Lay off the knob a little.. Just kidding..lol How quickly is it wearing down ? I use the lighter grey one and have never had a issue. Pretty sure it came from Marco.

#2917 2 years ago

Not sure what Titan does now, but I bought a bunch separately, same as my rings 1 1/2 to 2 years ago. Surely titan doesn’t just sell kits now. i need to buy some more stock soon

#2918 2 years ago

Found an untested soundboard for this game. PM me if anyone needs one or wants a spare.

#2919 2 years ago
Quoted from RonSS:

Just sayin hello. Picked up a working F14 today.
After a thorough cleaning and some new rubber I'll be in business I hope.
Prepare yourselves for multiple questions!

Welcome to the nuthouse!

#2920 2 years ago

Removed roms and gave them a quick cleaning with alcohol then reseated them and it didn't help

#2921 2 years ago

I will try these white ones, but I thought the black ones would be more durable. They are breaking down in only a couple months. Maybe I got a bad batch. And I am not using any solvents or cleaners on them.
Cheers!

#2922 2 years ago
Quoted from nightsearcher:

Not sure what Titan does now, but I bought a bunch separately, same as my rings 1 1/2 to 2 years ago. Surely titan doesn’t just sell kits now. i need to buy some more stock soon

It looks to be the case now. If you find them sold separately, let me know!

#2923 2 years ago

Alert the media!

I finally landed all three balls! Almost in a row too!

I have my machine set for three ball but, set to get extra balls rather than extra games. It awards an extra ball at 1,700,000. This mode also skips that annoying game match sequence at end of game so you can quickly start a new game after you get boned. I really like this setting the best!

#2924 2 years ago

Nice work styles. You get big points if you land even more during the same multiball. I think my best is around 7 landings during a multiball sequence.

#2925 2 years ago
Quoted from StylesBitchly:

Alert the media!
I finally landed all three balls! Almost in a row too!
I have my machine set for three ball but, set to get extra balls rather than extra games. It awards an extra ball at 1,700,000. This mode also skips that annoying game match sequence at end of game so you can quickly start a new game after you get boned. I really like this setting the best!

Nice shot, ramrod.

#2926 2 years ago

Yes!
Considering my ramrod isn’t what it used to be.

#2927 2 years ago

What was that..... I couldn't hear you.

#2928 2 years ago

Hello people. I regularly follow this thread and enjoy watching problems getting solved. It's awesome to see such knowledgable people giving advice. I now have my own problem that I'm in need of some help.
I finally picked up my tomcat sound board and power supply from a repairman yesterday. When I turn the game on everything worked as it should except the displays. Never had any trouble with them before.
Player one and two are completely scrambled. Player three and four have one or two digits out. When the score scrolls to the left the digit that is out moves with the score and the same scrambled pattern on player one and two scrolls to the left also. I don't think there is a problem with the actual glass display.

Any ideas on what may be causing this would be appreciated.
Cheers.
Boof

IMG_1383 (resized).PNG

#2929 2 years ago

Well my 50 dollar game works and is playable. We were all amazed it actually played with a little help. Needs a lot of work, but it will be enjoyable fixing it up.

#2930 2 years ago

So I've looked at the manual trying to see if I can make a common connection between the problems.I know very little so feel free to correct/educate me.page 27(solenoid table) shows they are on multpile different driver trans so I'm thinking not that.page 29 (switch -matrix table) shows I have multiple problems in column 2&3 says check for short circuit between the row wires . questions,what wires?under the playful and how do I test beyond a visual inspection?I ran another switch test and now the errors are not the same,now we have #14,13,12,11 and 48.tried the auto burn-in and everything works in display,sound and lamp(lamp test just blinks all lights except flashers and lower half of the back box lights for about a minute).then goes to Solenoid test and nothing activates except the slings,pop bumper and diverters.after turning off and back on it powers up and reports no errors unless i go back into test mode.when trying a switch edge test the only thing I can test is the flippers and start button,is this test made for manually activating each thing with the glass off?when inactivate either flipper I get a spinner message.

#2931 2 years ago

My center diagnostic led is rapidly flashing with no interruption

#2932 2 years ago
Quoted from Boof-Ed:

Player one and two are completely scrambled. Player three and four have one or two digits out. When the score scrolls to the left the digit that is out moves with the score and the same scrambled pattern on player one and two scrolls to the left also. I don't think there is a problem with the actual glass display.
Any ideas on what may be causing this would be appreciated.
Cheers.
Boof

Hey Boof-Ed, I looked at my F-14 and you may want to look at your ribbon cable going to the MPU and display, yours appears to be on incorrectly, here's a picture of mine where the displays work fine and I when I put my cable on the same as yours, I also got garbage like you did.

IMG_20171118_142628 (resized).jpg

IMG_20171118_142633 (resized).jpg

#2933 2 years ago

My cable is also the same as slapnuts.looks like you may have an easy fix.

#2934 2 years ago
Quoted from slapnuts77:

Hey Boof-Ed, I looked at my F-14 and you may want to look at your ribbon cable going to the MPU and display, yours appears to be on incorrectly, here's a picture of mine where the displays work fine and I when I put my cable on the same as yours, I also got garbage like you did.

Quoted from Puffdanny:

My cable is also the same as slapnuts.looks like you may have an easy fix.

Thank you. I feel so stupid yet relieved that it was something so simple.

IMG_1386 (resized).PNG

#2935 2 years ago
Quoted from Boof-Ed:

Thank you. I feel so stupid yet relieved that it was something so simple.

Dont feel stupid, tons of people including myself have done the same thing over the years.

#2936 2 years ago
Quoted from Boof-Ed:

Thank you. I feel so stupid yet relieved that it was something so simple.

FYI, I had a Pinscore LED display in mine when I bought it. The digits were messed up with segments out and it turned out to be a weak power source. LED displays run off 5 volts. If you have the original plasma displays, then it's the high voltage section of you power supply. But weak voltage can cause this as well.

#2937 2 years ago

I just dropped a deposit on a TNA ! My first NIB pin. I never thought I would do this.
Between F-14 and this TNA pin, it proves I'm a glutton for punishment!

#2938 2 years ago
Quoted from StylesBitchly:

FYI, I had a Pinscore LED display in mine when I bought it. The digits were messed up with segments out and it turned out to be a weak power source. LED displays run off 5 volts. If you have the original plasma displays, then it's the high voltage section of you power supply. But weak voltage can cause this as well.

Luckily the power supply had just been rebuilt so I could cross that off the problem list.

I do have another issue. The game is playing as it should. After the game ends it's not going through the match sequence. The displays have heads up flashing and that's it. I can start a new game but it doesn't go back into attract mode.
Any ideas?
Thanks again.

#2939 2 years ago

Possibly have the match feature turned off?

#2940 2 years ago
Quoted from Puffdanny:

Possibly have the match feature turned off?

Yes, I have it turned off on mine, but the table lighting still enters attract mode after a game ends. I would restore it to factory settings first and see what it does.

#2941 2 years ago

I'll try restoring factory settings and see what happens.

Update: factory reset didn't change the behaviour.

#2942 2 years ago
Quoted from StylesBitchly:

Between F-14 and this TNA pin, it proves I'm a glutton for punishment!

If you want to go full glutton get a firepower. You work as hard as you can to get multiball and then it last 10 seconds.

#2943 2 years ago
Quoted from Boof-Ed:

Thank you. I feel so stupid yet relieved that it was something so simple.

Glad to hear that fixed it!!

#2944 2 years ago

I have some work to do

IMG_2201 (resized).JPG

IMG_2202 (resized).JPG

#2945 2 years ago

Really hard work but possible... mine look similar before and know it's a Beauty again.
And it's not a BUT reproduction playfield, it's the original.

DSCN0671 (resized).JPG

DSCN1718 (resized).JPG

#2946 2 years ago

Yup, mine is a tad harsh as well. I'm going to try upside down compressed air to remove the mylar, clean, add new insert decals, wax, then apply new mylar. Hope it turns out like yours Averell!

20171112_152641 (resized).jpg

#2947 2 years ago
Quoted from RonSS:

Yup, mine is a tad harsh as well. I'm going to try upside down compressed air to remove the mylar, clean, add new insert decals, wax, then apply new mylar. Hope it turns out like yours Averell!

I thought I read to use a paste of IPA and flour to clean up the inserts?

#2948 2 years ago

I'm not sure what's going on with mine now.
I've only played a few games since the play field swap, so I'm slowly working out the kinks with that.
I just played a game and locked 3 balls. When I shot my 4th ball into the "Release" lane and the upkicker, it releases the other 3 balls, but holds that 4th ball on the upkicker. After draining all 3 balls, it finally kicked it up.

I then replicated this whole thing with the glass off and it did the same thing, but instead of finally kicking the ball up after draining all 3, it just kept giving me another ball in the shooter lane. So, the game never ends.
I had to power off and back on, and when I did that, it kicked it up.
Any idea what's going on here?

With all those lights flashing, I didn't even notice this issue at first. It was only when I shot a ball up there to "land" and it can right back down because the upkivker was already occupied.

#2949 2 years ago

Check the upkicker switch in switch test with a ball.

#2950 2 years ago

This is what happens at the end of a game. All balls are released then game freezes with heads up flashing from left displays to right. Doesn't ever go into attract mode but I can start a new game.

IMG_1391 (resized).JPG

Promoted items from the Pinside Marketplace
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 5.00
Playfield - Decals
Metal-Mods
$ 221.00
Cabinet Parts
Tilted Pinball
$ 17.00
Electronics
Yorktown Parts and Equip
1,700
Machine - For Sale
Pasadena, CA
There are 4079 posts in this topic. You are on page 59 of 82.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside