(Topic ID: 295196)

F14 start issue - solved

By falcon114

1 year ago



Topic Stats

  • 3 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by GaryL66
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider falcon114.
Click here to go back to viewing the entire thread.

#1 1 year ago

Hey folks.

Have an f14 that was working well but has had a lot of dirty switches hat I’ve had to clean and some replaced.

Issue is If I press the game start button it fires all the coils like a ball search, but will not start a game. All balls are present. The game continues to run through attract mode and you can hit the credit butto. Very 5 seconds or so and it will fore the coils again but not start. Is this a ball trough switch issue or worse? Thoughts?

Thanks!
Neal

BAD q49on board. Repaired, problem solved

Promoted items from the Pinside Marketplace
$ 12.00
Electronics
Yorktown Arcade Supply
2,100 (OBO)
Machine - For Sale
Benton, AR
2,500 (OBO)
Machine - For Sale
Portland, ME
5,500 (OBO)
Machine - For Sale
Myrtle Beach, SC
$ 10.00
Playfield - Protection
UpKick Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 19.99
Eproms
Matt's Basement Arcade

You're currently viewing posts by Pinsider falcon114.
Click here to go back to viewing the entire thread.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!