(Topic ID: 295196)

F14 start issue - solved

By falcon114

1 year ago



Topic Stats

  • 3 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by GaryL66
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hey folks.

Have an f14 that was working well but has had a lot of dirty switches hat I’ve had to clean and some replaced.

Issue is If I press the game start button it fires all the coils like a ball search, but will not start a game. All balls are present. The game continues to run through attract mode and you can hit the credit butto. Very 5 seconds or so and it will fore the coils again but not start. Is this a ball trough switch issue or worse? Thoughts?

Thanks!
Neal

BAD q49on board. Repaired, problem solved

#2 1 year ago

I'd go into switch test and check the ball trough switches. If one isn't working the game thinks a ball is missing and won't start.

LTG : )

#3 1 year ago

I’ve got the same issue with my F-14. Go to the switch edge test and see if any of the trough switches register correctly. Mine do not. I’ve disconnected the playfield switch connector at the main board and simulated the ball trough switches with a jumper and it still shows the incorrect switch activated.

Promoted items from the Pinside Marketplace
$ 19.99
Eproms
Matt's Basement Arcade
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 10.00
Playfield - Protection
UpKick Pinball
$ 18.62
Cabinet Parts
Tilted Pinball
$ 85.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 18.95
Eproms
Pinballrom
From: $ 18.00
Apparel - Men
Pinside Shop
$ 35.00
Cabinet - Other
Rocket City Pinball
Wanted
Machine - Wanted
Oakland, CA
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!