F-14 Tomcat MultiBall Sound error issue

(Topic ID: 233501)

F-14 Tomcat MultiBall Sound error issue


By SevenEightyRacer

13 days ago



Topic Stats

  • 21 posts
  • 5 Pinsiders participating
  • Latest reply 4 days ago by SevenEightyRacer
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

50211406_2230015137244777_7149401620323762176_n (resized).jpg
bef6ba81af178698240d05b346b9c0de365cee50.jpeg (resized).jpg
0ee59cfa98dc078baf7d1839b5ef8aa3da171957.jpeg (resized).jpg
a2954c436a29464dbd815a97310e8c61dd9281a0.jpeg (resized).jpg
20190114_105359 (resized).jpg

#1 13 days ago

Hey guys! This is one of my first posts here, and I hope that I cover my bases as I definitely do not want to waste anybodies time today.

I had a bad Hum and missing sound 15 (In sound test) in my F-14 and after checking the easy things (Grounding,Proms) I came to the conclusion that I needed a new sound board. I purchased another one off Ebay that was rebuilt and 100% tested/working.

Got the new board in and Hum went away and now I had sound 15.

So today I decided to really play some F-14 and after about 15 minutes of playing/machine being on and powered up. I got a multi ball. and the music completely stoppped. I have a video below showing what I mean. See here.

Now if I reset the machine it will normally work again like normal, at least until I get another multi ball then its a crap shoot if it works right or not.

I then grabbed a video of the game going through the sound test, which is located here.

So I tried this with both boards, and they are both doing it. So I don't THINK its a sound board issue as I swapped them out and they are both doing this. I also tried initially swapping the chips from one board to the other to see if it made any difference. No dice.

So I would venture a guess that its MPU related rather than sound board, but have no idea where to go from here. I can get MPU board pics if people would like them but some direction on any specific parts/areas they wanted photographed would be helpful.

Thank you guys a ton and hopefully someone can help me.

#2 12 days ago

Hi,
So wasn’t doing this in multi-ball before you swapped boards?
My F-14 started acting up. First thing was recapping the power supply to make sure 5v was good. After that, I noticed a diode was not attached on one of the flippers. Without the diode, using the flipper was causing the machine to do all sorts of weird stuff when I used the flipper. I’m still very much a newb. grumpy any other initial thoughts?

#3 12 days ago

That is... weird. Sounds like the sound processor is just crashing when there are too many sound commands being sent. Try the easiest thing and push down hard on the socketed ICs and roms on the sound board and MPU. I'm amazed how many times that fixes things. Then I'd check the ribbon cables since that can be a point of failure for communication issues. It could also be that the 5V needed to operate the soundboard dips during the multiball sequence because so much is happening it draws just enough current to crash the system.

#4 12 days ago

So I actually recently recapped the power supply as well, since it definitely looked like it needed it. How could I go about verifying that the 5v is enough? any good way to test it? Sorry I am newer to owning these.

Also should I be ordering replacement ribbon cables? I did verify that they are pushed in, and re-seated them. I can try pushing on all of the proms tho and see if that helps/fixes the issue.

Thanks for your help Everyone.

Edit:

So I went out and pushed on all the proms, and re-seated the ribbon cable again. It played pretty good for a few multi balls in a few games, but once it "Warmed up" it started to have the same issue again, and did exactly the same thing. before that it seemed to play a few games fine. I can tell you the seller of the sound board contacted me and asked me to unplug the sound card, and see if the issue is still present, and from what I could tell it actually IS soundboard related, as the alarm wasn't the same but sounded like normal and the rest of the noises worked as I expected them to.

So Ribbon cable, and checking 5V. any good suggestions? I don't have another F-14 to pull parts out of to test really.

#5 12 days ago

Do the caps on the sound board look ok? If you look in the manual, it’ll show the test points on the power supply for 5v. Could be ribbon cable to, so that’s worth checking or replacing. Did you get a set of roms with the replacement board?

#6 11 days ago

The caps were all replaced recently. I bought a YorkTownParts cap kit and replaced them myself. I am looking for a replacement Cable, and I have tried 2 sets of roms.

#7 11 days ago

I’m unavailable until 1/19, but after then I’d could probably stop by with my cable so you can try that. Do all your flipper coils have 2 diodes?

#8 8 days ago

Doing some additional troubleshooting for the Sound board seller.

If I disconnect the 3 wire jumper from MPU to sound board, the issue still occurs. which should indicate that the MPU is OK but rather either the connection from MPU to sound board, the ribbon cable or the sound board itself is bad..

My money is either the ribbon cable, or the connections on the MPU are maybe bad. I guess I gotta pony up and buy a cable from somewhere and see if that resolves my problem. If I reflow the connector points on the MPU, that "should" rule out the connections, right?

Thanks for any help.

Also all of my Flippers have the Diodes.

#9 7 days ago
Quoted from SevenEightyRacer:

If I disconnect the 3 wire jumper from MPU to sound board, the issue still occurs. which should indicate that the MPU is OK but rather either the connection from MPU to sound board, the ribbon cable or the sound board itself is bad..

Does the issue occur with both sound boards the same with the jumper removed? Sounds like its heat related, you really need to confirm that you have the correct voltages (5,12 and neg 12) coming from the power supply. How about a good pic of the cpu board battery area. Besides checking the flipper coil diodes you should check the four coils that kick out the balls for multiball.

#10 6 days ago

Grumpy,

Can you link me (I can't find a thread easily) Where exactly to test for the voltages on the power board AND the sound board to confirm they are getting the correct voltages.

Thanks!

PS/Edit: here is a picture off the board. Ordered a new ribbon cable and harness from the MPU to the sound board just to be sure I cover my bases.

20190114_105359 (resized).jpg

#11 6 days ago

Voltmeter set for DC volts. Black lead stuck under the ground braid. Power on and use the red lead to test. Test point #1 in the pic is 5 volts.

a2954c436a29464dbd815a97310e8c61dd9281a0.jpeg (resized).jpg
#12 6 days ago

Test point #3 should be unregulated 12 volts.

0ee59cfa98dc078baf7d1839b5ef8aa3da171957.jpeg (resized).jpg
#13 6 days ago

Test point #4 is unregulated negative 12 volts.

bef6ba81af178698240d05b346b9c0de365cee50.jpeg (resized).jpg
#14 6 days ago

You need to take a picture of above the battery holder.

#15 6 days ago

So after checking voltages (Thank you Grumpy for the specifics of where to test, I really appreciate it.)

I have

At test point 1 right at start up 4.98 V
At test point 3 I have 12.6
At test point 4 I have -14.8

I am going to venture a guess and say this is most likely my issue. My question is. I have already re-capped the power supply, so I would expect that it is something else on the board, are these all parts I could rebuild and replace or should I save up for a new power supply.

Thanks for the help guys!

50211406_2230015137244777_7149401620323762176_n (resized).jpg
#16 6 days ago

The power supply voltages are fine. I don't see any battery leakage on the board. Does the sound issue happen on both sound boards when the jumper is disconnected?

#17 6 days ago

Yeah the issue was the same between the two sound boards. regardless of eproms/ect between them.

I know that if I disconnected the red rear flasher board, that it seemed to help, and the error out did not happen. I then tried just having 4 of the 6 flashers in that bank in the rear of the PF with bulbs, and it didn't do it as much. Generally I had to be flipping a lot While multi-ball was going off, and only then sometimes would it error out. But most of the time it ran correctly, even if the alarm pitch was a bit off.

This damn game. I partially think it could be the low 5v. I had been told by someone that if its under 5 at the power board, then its even less at the sound board, and if it doesn't get the full 5V there can be issues. Buuuuut I don't claim they are right, nor do I have any idea what it could be. Only reporting my findings. This flasher bulb test was because the Previous owner had mentioned that he years ago owned a proto F-14 and had issues with those bulbs all being in the game, and caused issues. Kind of at a loss. The flasher board for the PF red lights, looked fine. It did appear to have been re-flowed at some point, but no broken traces/ect.

Edit: I also reflowed the entire Power board to see if I saw any difference, but alas. It did not yield any result.

Edit Edit: Going to a shop that has a F-14 they are going to let me swap out boards( i am bringing all three) and we are going to see if any of them make a difference.)

#18 5 days ago

Does the issue show up with out hitting flippers? If it only happens when hitting flippers i would suspect internal crack on one of the flipper diodes.

#19 5 days ago

Issue shows up with or without hitting flippers. I was just trying to see if I was putting as much load as I could on it to see if it would error (If it were power related)

So I went to Nahbour novelty as he has a test bench F-14. With my MPU and Sound board hooked up with my Ribbon (But his 3 wire jumper harness from Sound board to MPU. I know I am stupid, but it was 1.5 hour drive, so I worked with what I had.) I could get the alarm being off tone, and either ringing longer or short than it should, but it would not completely error out like at home. Soooo, he gave me all of the caps near the Sound portion of the system 11 board, and told me that it was a chance it was related to those. I have replaced them, and alas...... Still no dice. I did however get a few things to happen tonight.

I had the game powered on for almost 20 minutes, and had a few games in it. The first... 4 or 5 multi balls I got it worked fine... Then it started to error out just as I was thinking I had fixed it. However, NOW, it happened (Only one during my whole 45 min session) during yagov being shut down, it hung on a note there too.

So I have no clue. Apart from getting another brand new sound board. I have no idea how to test my machine at home.

#20 5 days ago
Quoted from SevenEightyRacer:

I have no idea how to test my machine at home.

It's sounding like your problem is on the cpu board, it's also likely heat related. Try warming up the machine for an hour. Then get it to act up again and while its acting up use a can of air upside down to cool down chips one at a time in the sound portion of the cpu. See if you get it to change at all.

#21 4 days ago

tried different area's including the chips right below the battery. No change what so ever. I appreciate your help Grumpy.

Edit: MPU and sound board have been shipped off, pending repair from lockwhenlit

Promoted items from the Pinside Marketplace
$ 22.00
$ 221.00
Cabinet Parts
Tilted Pinball
$ 14.00
Electronics
Yorktown Parts and Equip
$ 36.99
Eproms
Matt's Basement Arcade
$ 18.99
Eproms
Matt's Basement Arcade
2,850
Machine - For Sale
Evansville, IN
From: $ 69.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 16.95
$ 15.75
Cabinet Parts
Tilted Pinball
€ 3.70
$ 5.00
Playfield - Decals
Metal-Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside