New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 225974)

F-14 Plays music on start up and other questions/ issues


By darcangeloel

2 years ago



Topic Stats

  • 8 posts
  • 2 Pinsiders participating
  • Latest reply 2 years ago by darcangeloel
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

Hi Pinside,

I bought an F-14 a few months back and have been having an awesome time cleaning it up. I have a bit of an odd situation. When I turn on my F-14 I almost immediately get music. It's kind of an odd sound as well. Kind of like circus music. I've also noticed that during game play the dots on the upper displays turn on an off as well (The dots above the commas used to separate the score for readability). For reference I have a rotten dog mpu and a led display (Orange) which came with the game. I also replaced the power supply board with a rottendog power supply board as I was having a lock up issue. I thought this had been resolved but when league came over it reared its head again. Subsequent attempts to reproduce the lock up have failed (Tested every switch, left the game on for hours and nothing, also put it in burn in mode for a while). Does anyone know which chip on the board calls for the music to start playing. I have ordered some replacement chips as they are socketed. My thought is one of them probably just got fried by something at some point.

#2 2 years ago

Afternoon bump

#3 2 years ago

Night time bump

#4 2 years ago

Something went bump during the day

#5 2 years ago

With my Tomcat I initially had issues with music randomly stopping and occasionally multiball not triggering. This was fixed when I replaced the CPU and Sound roms. It sounds like you may have ordered those? If not, they're available on Pinside:

https://pinside.com/pinball/market/shops/1083-matt-s-basement-arcade/01179-f-14-tomcat-pinball-cpu-rom-set
https://pinside.com/pinball/market/shops/1083-matt-s-basement-arcade/01180-f-14-tomcat-pinball-sound-speech-rom-set

What exactly do you mean by lockup? What is not working?

#6 2 years ago
Quoted from atrainn:

With my Tomcat I initially had issues with music randomly stopping and occasionally multiball not triggering. This was fixed when I replaced the CPU and Sound roms. It sounds like you may have ordered those? If not, they're available on Pinside:
https://pinside.com/pinball/market/shops/1083-matt-s-basement-arcade/01179-f-14-tomcat-pinball-cpu-rom-set
https://pinside.com/pinball/market/shops/1083-matt-s-basement-arcade/01180-f-14-tomcat-pinball-sound-speech-rom-set
What exactly do you mean by lockup? What is not working?

Interesting, so the game came with new roms from K's Arcade (Or where ever the rottendog board came from again it came with the machine). However I'm not opposed to buying some new copies of those roms just to see if it will resolve the issue.

Regarding the lock up. It happens almost randomly. The game stays on and the display stop displaying anything (However it is still on) the controlled lamps that are on stay on and the GI stays on. The music normally stops or plays on a loop. The flippers and slingshots continue to work but yeah it basically just sits there until I turn the power off on the game and then turn it back on after which the game plays like normal for a while.

#7 2 years ago
Quoted from darcangeloel:

Interesting, so the game came with new roms from K's Arcade (Or where ever the rottendog board came from again it came with the machine). However I'm not opposed to buying some new copies of those roms just to see if it will resolve the issue.
Regarding the lock up. It happens almost randomly. The game stays on and the display stop displaying anything (However it is still on) the controlled lamps that are on stay on and the GI stays on. The music normally stops or plays on a loop. The flippers and slingshots continue to work but yeah it basically just sits there until I turn the power off on the game and then turn it back on after which the game plays like normal for a while.

Interesting. Have you tested voltages to make sure your wiring harness isn't causing some sort of drop to the CPU board? As for the roms, newly burned roms can be bad from time to time, and the CPU roms are cheap enough that I think it's worth replacing them just to rule it out. Other people on here might have a better idea though.

If might be helpful if you can try to take a video of it locking as well.

#8 2 years ago
Quoted from atrainn:

Interesting. Have you tested voltages to make sure your wiring harness isn't causing some sort of drop to the CPU board? As for the roms, newly burned roms can be bad from time to time, and the CPU roms are cheap enough that I think it's worth replacing them just to rule it out. Other people on here might have a better idea though.
If might be helpful if you can try to take a video of it locking as well.

oddly I can't get it to do it again (Not from lack of trying). That could have just been a fluke although a weird one given how many times it reoccurred. I'll give the new roms a shot as well thanks for the help!

Promoted items from the Pinside Marketplace
2,300
Machine - For Sale
Williamsport, PA
1,600
Machine - For Sale
Suffield, CT
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 39.99
Eproms
Matt's Basement Arcade
From: $ 18.00
Apparel - Men
Pinside Shop
$ 17.00
$ 9.00
Electronics
Yorktown Arcade Supply
$ 19.99
Eproms
Matt's Basement Arcade
$ 5.00
Playfield - Decals
Metal-Mods
1,600 (OBO)
Machine - For Sale
Cumming, GA

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside