New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 260763)

F-14 - 2 lights out


By Geteos

8 months ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 8 months ago by Darscot
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider Geteos.
Click here to go back to viewing the entire thread.

#1 8 months ago

I'm working on an F-14 I picked up last year. I pulled the play field out and cleaned it up, touched up some sections etc.

I got it all back together and for the most part it is working correctly. But I'm having an issue with 2 of the play fields lights that I cannot get to light up, the 1K and the upper blue T.

I tried measuring voltage across the bulb when in flashing test mode and the 1K is fluctuating around 0.4V, the adjacent working bulb is showing up around 1.3V.

The T is reading the same the low voltage.

I'm a bit stumped as to what could be causing the low voltage at these points. I tried swapping out the LEDs for known-working ones to rule out the bulbs.

What should I be looking at next?

Promoted items from the Pinside Marketplace
$ 19.99
Eproms
Matt's Basement Arcade
$ 85.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 50.00
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
2,300
Machine - For Sale
Williamsport, PA
1,600
Machine - For Sale
Suffield, CT
$ 39.99
Eproms
Matt's Basement Arcade
From: $ 18.00
Apparel - Men
Pinside Shop
$ 5.00
Playfield - Decals
Metal-Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 17.00
Trade
Machine - For Trade
Smiley, TX

You're currently viewing posts by Pinsider Geteos.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside