(Topic ID: 326325)

Excalibur Gottlieb 80b doesn't start - working MPU

By joins

1 year ago



Topic Stats

You

Linked Games

#1 1 year ago

Hi guys, I'm currently stuck in excalibur's repair. I fixed the MPU, even tried with a mypinballs MPU, and same result: the pin seems to boot, but when it starts after pressing the start button (it detect coins) it doesn't detects anything else: neither the flippers coils work or any target on the playfield and all the lights turn off.

The following video shows the machine ATM:

I don't have much knowledge in these 80b pins but already did the psu ground mod, fixed 5v power supply and changed some molexs connectors. I don't know what to do next....

A donwside to this repair, is that I still don't have a working alpha numeric display.

#2 1 year ago

did you repin the interconnector? That's usually a major problem

#3 1 year ago

Did you add a ball, and the correct number of balls for the game?

#4 1 year ago

Yep, put 2 balls and it's a working interconnector cable.

4 months later
#5 1 year ago
Quoted from joins:

Yep, put 2 balls and it's a working interconnector cable.

ever figure this out?

Promoted items from Pinside Marketplace and Pinside Shops!
$ 83.00
Electronics
PinballReplacementParts
 
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.