(Topic ID: 283548)

Evel Knievel MPU compatibility

By mikusm

10 months ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 10 months ago by mikusm
  • No one calls this topic a favorite

You

Linked Games

#1 10 months ago

Is a 2nd gen -35 compatible with a -17? Have a bad -17 and a good spare -35. Any help would be appreciated.

#2 10 months ago

It will work, but jumpers may need to be changed, or new ROMS programmed.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside