(Topic ID: 57310)

Elvis Tech help : I did something stupid


By murfe88

7 years ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 7 years ago by Muppet_Man
  • No one calls this topic a favorite

You

Linked Games

#1 7 years ago

Well I picked up a slot machine topper to put on one of my machines. I was using the 5 and 12 volt plug inside the coin door of my Elvis to power on the 5 volts chaser lights on the topper. Really just trying to see if the topper worked as I just got it. I wasn't paying attention and put the ground wire and 5 volts wire from the topper in the 5 and 12 volts on the plug in the coin door. The machine surged then a couple coils started to fire over and over again until I could turn the game off. Well now when I turn the game on all I get is some lights on the playfield and the display lights up Stern pinball. Thats it. I checked the fuses and they all seem good. I have a rottendog driver board in the game.

#2 7 years ago

Sounds like an output driver. Rottendog are pretty helpful. If you tell them what happened, they'll probably give you a fix diagnosis.

Best of luck.

Promoted items from the Pinside Marketplace
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 369.95
Boards
PinSound
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 28.00
Lighting - Other
Rock Custom Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 24.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside