(Topic ID: 252126)

Elvira's House of Horrors - The Owner's Club


By RobertWinter

10 months ago



Topic Stats

  • 4,383 posts
  • 339 Pinsiders participating
  • Latest reply 1 day ago by Charger68
  • Topic is favorited by 159 Pinsiders

You

Topic poll

“Do you currently own other Elvira machines?”

  • This is my frst Elvira machine 148 votes
    58%
  • Also own Elvira and the Party Monsters 18 votes
    7%
  • Also own Scared Stiff 61 votes
    24%
  • I own all three now! 30 votes
    12%

(257 votes)

Topic Gallery

There have been 888 images uploaded to this topic. (View topic image gallery).

20200802_081458 (resized).jpg
20200802_081525 (resized).jpg
20200802_081901 (resized).jpg
house div 2 (resized).jpg
house div (resized).jpg
20200802_080338 (resized).jpg
mun code.gif
image (resized).jpg
elvtruck (resized).png
A4AD6BDC-E418-44CF-8574-805DD663E59F (resized).jpeg
ELVIRA SIDE BLADES 3pst (resized).jpg
instructions (resized).jpg
IMG_20200727_183417627 (resized).jpg
7AF87F8D-E312-44F1-B083-20A9444D2756 (resized).jpeg
1CD5BD90-51B5-42C5-8586-5C6080C37E2D (resized).jpeg
20200725_100128 (resized).jpg

Topic index (key posts)

9 key posts have been marked in this topic (Show topic index)

There are 4383 posts in this topic. You are on page 25 of 88.
#1201 7 months ago
Quoted from splitcms:

Anyone having an issue with their shaker motor on the game? Ran coil test 7 and the shaker shakes but in game I never feel it go off. I apologize if this is already addressed

There is almost no shaker code programmed yet.

#1202 7 months ago

Thank you! Thought I was going crazy

#1203 7 months ago
Quoted from Magicchiz:

Were are all the Mods at? When Munsters came out the Mod couple and Mezel Mods were on it!!!! Come on guys where are the good mods.
Magicchiz

I’ve contacted both. Neither company is planning mods for Elvira.

#1204 7 months ago
Quoted from jfh:

I’ve contacted both. Neither company is planning mods for Elvira.

That’s a shame definitely the potential for a couple of good mods on this game, oh well. If someone can come up with a kickass Elvira based topper that would be a plus.

#1205 7 months ago
Quoted from J85M:

That’s a shame definitely the potential for a couple of good mods on this game, oh well.

such as?

more generally, what are people looking for? We tend to try to make mods that have some interaction with the game and not things to just stick on the playfield. A sign to replace the current plastic crypt sign is underway.

#1206 7 months ago

I made an "Elvira in her car" plastic for mine. A thin sheet metal mounting tab gives it a little flex when the pops are in action. It really doesn't prohibit the view of the ball. I'll also attach the print file I used for any others to DIY.

ecar (resized).jpgelvira car print (resized).jpg
#1207 7 months ago

The Stern Elvira Topper looks like the middle section that says "Deadhead Family Crypt" could rotate/flip up to reveal a different aspect to the topper.
There could be a photo of Elvira (maybe on her couch) that gets revealed if you progress far enough.

Does anyone else think this looks like a possibility?

#1208 7 months ago
Quoted from T7:

The Stern Elvira Topper looks like the middle section that says "Deadhead Family Crypt" could rotate/flip up to reveal a different aspect to the topper.
There could be a photo of Elvira (maybe on her couch) that gets revealed if you progress far enough.
Does anyone else think this looks like a possibility?

Do not expect too much to avoid disappointment.

I would like the gargoils on the topper to pop up (solenoids) when you hit them on the playfield. I am not holding my breath and I am not spending $700 on a topper. For the amount of money the game cost, the topper should have come with the game.

-1
#1209 7 months ago

Not sure if it’s true but I’ve heard from some people in the business. The group that owns elviras rights will sue at any given moment for any little thing.

#1210 7 months ago

Cassandra Petersen owns all her own rights and cuts her own license deals.

#1211 7 months ago
Quoted from MRG:

Take your house off and look for the additional piece of metal seen in this picture, the black oval My game did not have this piece. Contact Chaz if you do not.[quoted image]

Did you get this piece installed? Can you now make the skill shot. Was Chaz aware of this issue?

#1212 7 months ago
Quoted from marspinball:

Quoted from MRG:
Take your house off and look for the additional piece of metal seen in this picture, the black oval My game did not have this piece. Contact Chaz if you do not.[quoted image]

Did you get this piece installed? Can you now make the skill shot. Was Chaz aware of this issue?

Apparently they are. I e-mailed Parts with my game info through the website about that part and got a response. They are sending it to me.

#1213 7 months ago
Quoted from GamerRick:

Quoted from splitcms:
Anyone having an issue with their shaker motor on the game? Ran coil test 7 and the shaker shakes but in game I never feel it go off. I apologize if this is already addressed

There is almost no shaker code programmed yet.

Surely I am not the only one that gets responses from the shaker during the game.

#1214 7 months ago
Quoted from marspinball:

Did you get this piece installed? Can you now make the skill shot. Was Chaz aware of this issue?

Stern is aware of the issue. I have not recieved the part yet. Should be coming soon. The skill shot can not be made without that part. The ball will bounce off and not go to the skill shot. I rigged up some drop dead foam in the mean time to reduce the bounce.

#1215 7 months ago
Quoted from SKWilson:

Surely I am not the only one that gets responses from the shaker during the game.

Shaker motors works during Gargoyles gone crazy mode....

#1216 7 months ago
Quoted from Wakky:

Shaker motors works during Gargoyles gone crazy mode....

That's not the only time. There are a lot of people saying there isn't much shaker code, or they get nothing from the shaker, but mine fires for all mode completions (plus shots leading up to) and super jackpots. I've even posted all of the occurrences of when the shaker fires. I just don't get it. Oh well.

#1217 7 months ago
Quoted from Pinstein:

I made an "Elvira in her car" plastic for mine. A thin sheet metal mounting tab gives it a little flex when the pops are in action. It really doesn't prohibit the view of the ball. I'll also attach the print file I used for any others to DIY.[quoted image][quoted image]

Amazing! Looks great!

#1218 7 months ago

Has anyone received the garage lockup malfunction? Keep getting this every time I hit balls in there and when the balls are supposed to eject for the multi-ball. Thank you

#1219 7 months ago

So... Elvira hit my basment. First Impression - looks beautiful! Light show is great. Love it.

The shot in the house is bit too dominant and since this one is very easy, it should be a bit less important, but it's an early code. I hope code will progress more quickly than on BM66

Got yesterday to Gappa Angry - at least it was lit. Shooting the house should have started it? Correct? Didn't work - Bug?
I came out of the trunk MB with Gappa Angry lit, shot the house multiple times, but didn't get the million or progression. I even started another three ball MB.

#1220 7 months ago

Gappa Angry should work. Very large scores and they increase with each shot made. Could be a bug if something else is going simultaneously.

Attic Multiball - I have encountered no speech from Elvira while she is on the screen when you start the Attic Multiball. Encountered that in both .87 and .88 code. Seems to be a bug.

#1221 7 months ago

Got mine yesterday as well. Fun game! Code is rough around the edges for sure, but you can see the potential.

Mechanically all is working as well so that’s a bonus. Trunk works fine. Super secret skill shot worked etc...

Couple issues/question:

1. The bottom of the left ramp appears to have a big chip on the edge. Can somebody take a look and confirms theirs looks better than this before I bug Stern?

2. The lift ramp hits/lifts the right gargoyle. It appears I need to request that washer as mine doesn’t have one.

3. The gargoyles by the right ramp make a very loud thud when they go off. The ones by house don’t. I know they are supposed to hit the glass but it almost feels like a knocker. Normal?

Thanks!

85349D9C-8350-43AA-BA2C-6F879909B287 (resized).jpeg9E60AFCA-C153-4901-9AB9-4B18B665D1FE (resized).jpeg
#1222 7 months ago
Quoted from GorillaBiscuits:

1. The bottom of the left ramp appears to have a big chip on the edge. Can somebody take a look and confirms theirs looks better than this before I bug Stern?

Mine does not look pretty either... maybe a correction after ramp was manufactured... unfortunately.
Looks look they broke something to avoid stuck balls - just an assumption.
EHOH_Ramp (resized).jpg

#1223 7 months ago
Quoted from protectors:

Mine does not look pretty either... maybe a correction after ramp was manufactured...

Ah, makes sense. Good to know. It’s invisible from players view.

#1224 7 months ago

That's not pretty...

#1225 7 months ago
Quoted from GorillaBiscuits:

It’s invisible from players view.

Yes. You don't see the rough edge while playing. Looks exaggerated in a close up photo from side or front orientation.

If it bothers you, you could take a sanding stick and smooth it carefully and polish for a nicer edge. But really not necessary. You don't see it while playing the game.

You can adjust Gargoyle travel too if you think it hit's the glass too hard.

Enjoy your new game !

#1226 7 months ago

Doesn’t bother me. Just want to make sure it’s standard as it might bother the next person when it comes time to sell, which hopefully won’t be for a long time

Maybe it was interfering with the trunk opening.

But yeah it looks fine see?
FC1F97C6-6B47-481D-9313-72D827A18C02 (resized).jpeg

#1227 7 months ago

Yeah -it's nice, but even more in the dark with the light Show

#1228 7 months ago

Any new mods? Seems there is missing something.
I was thinking of putting a nice coffin lid on top but then the ball cannot pass anymore... Any ideas?

#1229 7 months ago

Evil Dr: "Do I look like the kind of man that goes around murdering women?"
Elvira: "Spoiler alert: Yes you do."

Elvira's response cracks me up every time.

#1230 7 months ago

This has to been discussed, I skimmed but sorry if it has been.

Noticed on location that when the center ramp was doing that thing where it wasnt registering or starting a mode, it WOULD register if you shot the crypt lock target down.

Obviously something needs to be fixed and you guys probably have figured out the fix, but if you're ever playing and chasing a GC and mode starts stop registering, try knocking down that target!

#1231 7 months ago

Hey Elvira owners, do yourselves a favor and cut a little square of Mylar and place it under the metal flap of the front door. I even went a little further and put some adhesive friction rubber on the bottom of the ramp between the rivets. The edge of the metal flap and rivets both make contact with the playfield. Just trying to be proactive. By the way, adding the nylon washer to the ramp really smooths out the ramp's operation.

#1232 7 months ago
Quoted from protectors:

Mine does not look pretty either... maybe a correction after ramp was manufactured... unfortunately.
Looks look they broke something to avoid stuck balls - just an assumption.
[quoted image]

It seems that almost everyone’s ramp hits the right gargoyle that’s just how they assembled all of them. Impossible to move without drilling the playfield. Mine is staying put. Good news is Dennis himself says it’s not to worry about.

#1233 7 months ago

Update on “Go Away” plastic on left side of house:

Although my game is a November build, I had the early version of the plastic (bottom pictures). Replaced it with the correct version (top picture).

My game did have the metal skill shot guide and the nylon ring on the right side of the ramp.
B41ABA32-3CD1-42B4-8841-54546C1EE245 (resized).jpegDE2AE9A5-F6C2-4A12-AD5E-B5C17DE0F50F (resized).jpeg
77530CBD-B4A1-4629-AF05-5CA9C07C30EB (resized).jpeg

#1234 7 months ago

Notes on install of my playfield protector. Thanks to tips from those that have done it.

Took off roof of crypt and removed wood screw holding it down
Removed left metal ramp entrance and both parts of left plastic ramp
Removed right ramp
Disconnected ramp wiring (optos/flashers)
Removed gate at top of shooter lane by right inlane (did not remove opto spinner by crypt)
Removed flippers
Removed house (but did not disconnect from below)
- Remove turret screw and turret top (eye goes front)
- Remove 2 screws on roof by chimneys; remove roof.
- Use a magnetic 9" 1/4" nut driver to remove 4 wood screws the house down through the top of the house. Lift house up and set it on its side on top of the pop bumpers.
Removed sling and lane guide plastics and sling rubbers (not critical, but made fitting much easier)

Checked fit of protector.
Cleaned the playfield with Novus 1.
Cut the protector at the middle of the top.
Took film off back of protector.
Cleaned back of protector with Novus 1
Took film off top of protector rather than fitting it first (because of piece that goes under cellar ramp)
Fitted protector.
Cleaned top of protector with Novus 1
Reverse above steps.

A few notes -

In order to install the protector without cutting it would require removing both the house and house ramp assemblies. I really didn’t think removing the ramp assembly was a good idea so decided to cut the protector (at middle top) and take out a small sliver as others have done. That was the only cut needed in the protector. Unlike another poster the outer return lane by the left sling did not have to be trimmed. Some of the switch cutouts could have fit a little better but none prevented from proper switch operation.

Instead of removing the spinner assembly just bent/maneuvered the protector down the left side and underneath. Take care not to scratch the top side of the protector when you do this as it’s a very tight fit.

There is a small overlap of the protector over the trough entrance but it doesn’t look like an issue. Can cut it if you like as it’s hidden under the apron.

While you are doing this, consider installing sling and inlane plastic protectors and/or boney flippers. I decided against the boney flippers for now because the bare white looks too stark against the playfield. Will probably go with the boney flippers after painting them to look distressed/weathered and with accents that pick up the green of the swan. I did go with purple flipper rubbers though (and replaced the Stern coil stops).

When you are done, enjoy the glossy look of your protected playfield and don’t wince every time the VUK shoots the ball across the playfield!

I don’t want to get into a debate about using playfield protectors, but after putting on on Batman 66 and now Elvira HOH I’m going to put them on any future game I buy NIB unless the quality of the playfield wood, paint and clear coat returns to what we used to see. IMO, very cheap insurance for a new playfield with no impact to game play (or I’m not a good enough player to notice any).

Total time was a little over an hour but probably would be much faster if you have experience tasking off the ramps and the house.

#1235 7 months ago
Quoted from GamerRick:

It see,s that almost everyone’s ramp hits the right gargoyle that’s just how they assembled all of them. Impossible to move without drilling the playfield. Mine is taking put. Good news is Keith himself says it’s not to worry about.

Keith? You mean Dennis?

#1236 7 months ago

Just realized that none of the stand up targets on either side work on my game. Not sure they ever have. Same with the opto spinner. None of them work in switch test; switch gaps look fine. Physical connections at the switches look fine.

Edit: looks like they are all on node 8, connector 12. Will have to find connector 12. Hope it’s the physical connection and not the node board itself.

Edit 2: CN12 connector had gotten pulled loose. Easy fix.

#1237 7 months ago
Quoted from jfh:

Just realized that none of the stand up targets on either side work on my game. Not sure they ever have. Same with the opto spinner. None of them work in switch test; switch gaps look fine. Physical connections look fine. Anyone have any ideas on what to check? (I haven’t looked at the schematics yet)

Must be that plastic couch cover you just put on your game. seriously this has to be is a new proplem for you. The game is unplayable without those targets. It is most likely something simple.

#1238 7 months ago
Quoted from Mad_Dog_Coin_Op:

Must be that plastic couch cover you just put on your game. seriously this has to be is a new proplem for you. The game is unplayable without those targets. It is most likely something simple.

Couch cover. Lol!

Wouldn’t call the game unplayable without them but very annoying at the very least.

#1239 7 months ago
Quoted from jfh:

Couch cover. Lol!
Wouldn’t call the game unplayable without them but very annoying at the very least.

Without them there is no "hand of fate" or "junk in the trunk". I'm hoping you just knocked something loose. A failed node board would suck (but covered under warranty). Please report back your findings.

#1240 7 months ago
Quoted from jfh:

Couch cover. Lol!
Wouldn’t call the game unplayable without them but very annoying at the very least.

Yeah it would be VERY annoying. Gotta go back and see what you F ed up with the "couch cover". Stand up targets are crucial to the game!

#1241 7 months ago
Quoted from Mad_Dog_Coin_Op:

I'm hoping you just knocked something loose. A failed node board would suck (but covered under warranty). Please report back your findings.

After looking at the manual I’m thinking the CN12 connector on node 8 is loose (easy) or that circuit on the node board is bad (not fun). The 7 switches not working are all on that connector. Fortunately I have a spare node board so can check both. Will look at it tomorrow and report back. But whatever it is, I’ll remember it as “the couch cover problem”

#1242 7 months ago
Quoted from jfh:

Keith? You mean Dennis?

Whoops yeah sorry

#1243 7 months ago
Quoted from jfh:

Notes on install of my playfield protector. Thanks to tips from those that have done it.
Took off roof of crypt and removed wood screw holding it down
Removed left metal ramp entrance and both parts of left plastic ramp
Removed right ramp
Disconnected ramp wiring (optos/flashers)
Removed gate at top of shooter lane by right inlane (did not remove opto spinner by crypt)
Removed flippers
Removed house (but did not disconnect from below)
- Remove turret screw and turret top (eye goes front)
- Remove 2 screws on roof by chimneys; remove roof.
- Use a magnetic 9" 1/4" nut driver to remove 4 wood screws the house down through the top of the house. Lift house up and set it on its side on top of the pop bumpers.
Removed sling and lane guide plastics and sling rubbers (not critical, but made fitting much easier)
Checked fit of protector.
Cleaned the playfield with Novus 1.
Cut the protector at the middle of the top.
Took film off back of protector.
Cleaned back of protector with Novus 1
Took film off top of protector rather than fitting it first (because of piece that goes under cellar ramp)
Fitted protector.
Cleaned top of protector with Novus 1
Reverse above steps.
A few notes -
In order to install the protector without cutting it would require removing both the house and house ramp assemblies. I really didn’t think removing the ramp assembly was a good idea so decided to cut the protector (at middle top) and take out a small sliver as others have done. That was the only cut needed in the protector. Unlike another poster the outer return lane by the left sling did not have to be trimmed. Some of the switch cutouts could have fit a little better but none prevented from proper switch operation.
Instead of removing the spinner assembly just bent/maneuvered the protector down the left side and underneath. Take care not to scratch the top side of the protector when you do this as it’s a very tight fit.
There is a small overlap of the protector over the trough entrance but it doesn’t look like an issue. Can cut it if you like as it’s hidden under the apron.
While you are doing this, consider installing sling and inlane plastic protectors and/or boney flippers. I decided against the boney flippers for now because the bare white looks too stark against the playfield. Will probably go with the boney flippers after painting them to look distressed/weathered and with accents that pick up the green of the swan. I did go with purple flipper rubbers though (and replaced the Stern coil stops).
When you are done, enjoy the glossy look of your protected playfield and don’t wince every time the VUK shoots the ball across the playfield!
I don’t want to get into a debate about using playfield protectors, but after putting on on Batman 66 and now Elvira HOH I’m going to put them on any future game I buy NIB unless the quality of the playfield wood, paint and clear coat returns to what we used to see. IMO, very cheap insurance for a new playfield with no impact to game play (or I’m not a good enough player to notice any).
Total time was a little over an hour but probably would be much faster if you have experience tasking off the ramps and the house.

Dear JFH, do you have some wet spots under playfield protector? Does the Novus 1 cleaning prevented them from appearing?

Thank you for all your explanations. Now, I see what I have to do.

#1244 7 months ago
Quoted from frg:

So... Elvira hit my basment. First Impression - looks beautiful! Light show is great. Love it.
The shot in the house is bit too dominant and since this one is very easy, it should be a bit less important, but it's an early code. I hope code will progress more quickly than on BM66
Got yesterday to Gappa Angry - at least it was lit. Shooting the house should have started it? Correct? Didn't work - Bug?
I came out of the trunk MB with Gappa Angry lit, shot the house multiple times, but didn't get the million or progression. I even started another three ball MB.

Well - okay, made my first game after this again.

So the issue is - house shots were not recognized at all
House ramp opto works in test and in game the loop switch left to the ramp does work also in test and in game. What else can I check?

#1245 7 months ago
Quoted from frg:

Well - okay, made my first game after this again.
So the issue is - house shots were not recognized at all
House ramp opto works in test and in game the loop switch left to the ramp does work also in test and in game. What else can I check?

Let me see if I have this straight. The house opto doesn't work at all during the game but does during test? Has it always been like that? How in the world did you complete any haunts to get Gappa Angry queued up? Was new coded loaded up anytime recently? Working in test and not in the game sounds like a corrupt file or slightly misaligned optics. I would start by playing a game with the glass off. Slow shots might register while fast ones don't. If it isn't that, download the most recent code again and reinstall.

#1246 7 months ago
Quoted from frg:

Well - okay, made my first game after this again.
So the issue is - house shots were not recognized at all
House ramp opto works in test and in game the loop switch left to the ramp does work also in test and in game. What else can I check?

similar issue/ symptom here.

game is a mess. At this point I truly believe that the new crappy optos are the culprit (they use a ton in this game).
Power distribution seems to be different in game vs in test mode so it make it completely impossible to diagnose.

#1247 7 months ago

To clarify… the issue started first when I wanted to start Gappa Angry afew day ago. I did not Play any game later. Today I started the first game ever since.
So this is not a Gappa Angry issue but an issue to recognize the house shot at all.

The opto worke in the test… in the game game also, since I get 30 Points when the opto is operated (with ball or any other "tool"), but I don not get "the shoot" e.g. start house mode.

What else is needed other than the house ramp opto? If nothing else than it is not a switch/opto problem...

#1248 7 months ago
Quoted from jfh:

After looking at the manual I’m thinking the CN12 connector on node 8 is loose (easy) or that circuit on the node board is bad (not fun). The 7 switches not working are all on that connector. Fortunately I have a spare node board so can check both. Will look at it tomorrow and report back. But whatever it is, I’ll remember it as “the couch cover problem”

Couch cover problem was an easy fix. Suspect it happened when moving the support bracket to change the left coil stop as the bracket is right over node 8.

1C59BD6B-5BBC-4A59-B444-D7C0CA1EC7B5 (resized).jpeg
#1249 7 months ago
Quoted from Peanuts:

Dear JFH, do you have some wet spots under playfield protector? Does the Novus 1 cleaning prevented them from appearing?

I didn’t see any spots or discoloring today. Will report back if they show up.

I did have spotting after I put the protector on Batman but pretty sure that’s because I waxed the playfield before applying the protector which is not recommended.

#1250 7 months ago

Something else is going on for those with the opto issues, especially if they are working in test. The very first thing I would do is a full code reinstall (load everything, not just changed code). The second thing I would do is make sure there is no play in mounting (i.e. the screws are tight).

Promoted items from the Pinside Marketplace
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
7,899
Machine - For Sale
West Chicago, IL
$ 26.50
There are 4383 posts in this topic. You are on page 25 of 88.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside