(Topic ID: 252126)

Elvira's House of Horrors - The Owner's Club


By RobertWinter

9 months ago



Topic Stats

  • 4,045 posts
  • 326 Pinsiders participating
  • Latest reply 7 hours ago by Rdoyle1978
  • Topic is favorited by 147 Pinsiders

You

Topic poll

“Do you currently own other Elvira machines?”

  • This is my frst Elvira machine 142 votes
    57%
  • Also own Elvira and the Party Monsters 18 votes
    7%
  • Also own Scared Stiff 60 votes
    24%
  • I own all three now! 29 votes
    12%

(249 votes)

Topic Gallery

There have been 818 images uploaded to this topic. (View topic image gallery).

20200521_213551 (resized).jpg
3A056D96-ABA7-45A4-97B9-C2E2A7316583 (resized).jpeg
smoke.gif
Untitled-1 (resized).jpg
not cut house (resized).jpg
cut house (resized).jpg
20200625_180219 (resized).jpg
20200625_180156 (resized).jpg
20200625_180234 (resized).jpg
IMG_7396 (resized).jpg
15940976619144602989167211163253.jpg
15940973585791307581887367200895 (resized).jpg
elvira (resized).jpg
20200706_144446 (resized).jpg
20200706_144659 (resized).jpg
FF5B6337-3AD7-45D7-BDB2-9DC519964EFD (resized).jpeg

Topic index (key posts)

7 key posts have been marked in this topic (Show topic index)

There are 4045 posts in this topic. You are on page 22 of 81.
#1051 7 months ago

I‘ve played my first game on my Elvira LE Today:

Wooowwwwwww what a fantastic game. The flow and ways are amazing.

#1052 7 months ago
Quoted from Whysnow:

Can an owner do a test for me PLEASE?
Trying to diagnose an issue that has come about post 0.87 code install where the center ramp flap goes into UP position during a game, ball ends, and ramps stays in up position.
Power cycling does nothing, starting a new game does nothing. The ramp stays in UP position untill someone goes into settings and puts it back down.
I can find no issues with switches and no issues with the physical mech. The game functions fine in test mode for me and I can lower or raise ramp in test.
What I would like for an owner to test...
Turn on your game
Go into test mode, move ramp to up position.
Turn off game while in UP position.
Wait
Turn game back on and tell me what happens with the ramp. i.e. does it go down? does it go down, then up? what happens?
Then, star t a game and tell me if ramp goes down (if it did not do so on reboot already)
thanks, in advance!

I bet your game thinks there is something in the backdoor and it is trying to clear it. That is where I would check. Also, does your game have the nylon washers installed on both sides of the ramp to keep it true? That was a build tweak implemented about a month after the first games shipped. I can run the tests for you later if still needed.

#1053 7 months ago
Quoted from Mad_Dog_Coin_Op:

I bet your game thinks there is something in the backdoor and it is trying to clear it. That is where I would check. Also, does your game have the nylon washers installed on both sides of the ramp to keep it true? That was a build tweak implemented about a month after the first games shipped. I can run the tests for you later if still needed.

thanks for the idea

Can you also take a photo of the nylon washers to show me what I should be looking for?
Appreciate it!

Our game was an expo game so guessing it does not have these washers.

#1054 7 months ago
Quoted from Whysnow:

thanks for the idea
Can you also take a photo of the nylon washers to show me what I should be looking for?
Appreciate it!
Our game was an expo game so guessing it does not have these washers.

Here is a screenshot of an earlier post on this thread. If you’re missing them call up Stern and get a set. I did but haven’t installed them yet. It simply keeps the ramp running true.
174CF7E2-74F7-4888-B31C-52EC969A4E2D (resized).png

#1055 7 months ago

Yeah mine was missing that nylon washer and Stern sent me one, it actually only needs to be on the right side of the ramp. My distributer dude came by and installed it, no ramp issues since. To install in he had to remove the roof of the house, then he used a long magnetic tool to remove four screws that hold the house to the playfield. After that the whole house can be shifted out of the way to get access to the screw and bar that controls the ramp. Unscrew that, install washer, put everything back.

#1056 7 months ago
Quoted from legui:

Hi all,
Just finished unboxing.
Serial: E297363
#036/400
Anti airball plastic installed.
Now it's time to update code and play!
Unpleasant dream...
[quoted image]

Could you kindly post a photo of the anti air ball plastic?

Our game arrives tomorrow!

#1057 7 months ago
Quoted from pinballaddicted:

Could you kindly post a photo of the anti air ball plastic?
Our game arrives tomorrow!

They are sold in the Pinside Market. Search for it there. The ad shows a couple nice photos of it installed. I recommend the purchase.

#1058 7 months ago
Quoted from Mad_Dog_Coin_Op:

They are sold in the Pinside Market. Search for it there. The ad shows a couple nice photos of it installed. I recommend the purchase.

Thanks very much for that, I will have a look.

We normally make them ourselves until we can get a nicely made one. I cannot stand air balls!

#1059 7 months ago
Quoted from Mad_Dog_Coin_Op:

Here is a screenshot of an earlier post on this thread. If you’re missing them call up Stern and get a set. I did but haven’t installed them yet. It simply keeps the ramp running true.
[quoted image]

Quoted from Reality_Studio:

Yeah mine was missing that nylon washer and Stern sent me one, it actually only needs to be on the right side of the ramp. My distributer dude came by and installed it, no ramp issues since. To install in he had to remove the roof of the house, then he used a long magnetic tool to remove four screws that hold the house to the playfield. After that the whole house can be shifted out of the way to get access to the screw and bar that controls the ramp. Unscrew that, install washer, put everything back.

Thanks both!

Just confirmed, no nylon washer.

Will request it now.

really appreciate the help!

#1060 7 months ago

I have a problem with the crypt where it occasionally gets into a mode where you go from closed to the skull instead of from closed to the open ball lock. Once it is in the skull mode it will detect hits via the optics and omit a sound, but won’t trigger anything. It stays stuck for the entirety of that players game. If you switch to the next player it will repeat the cycle. The only thing that has fixed it is for me to go into the diagnostics and use the flippers to roll back to closed, then restart the game.

Anyone else seeing weirdness here?

#1061 7 months ago
Quoted from Aniraf:

I have a problem with the crypt where it occasionally gets into a mode where you go from closed to the skull instead of from closed to the open ball lock. Once it is in the skull mode it will detect hits via the optics and omit a sound, but won’t trigger anything. It stays stuck for the entirety of that players game. If you switch to the next player it will repeat the cycle. The only thing that has fixed it is for me to go into the diagnostics and use the flippers to roll back to closed, then restart the game.
Anyone else seeing weirdness here?

Seeing almost the same thing.
Getting 2 & 3 Balls struck in the Crypt.
With 2 or 3 Balls being stacked on top of one another.

IMG_20191204_002047 (resized).jpgIMG_20191204_002057 (resized).jpg
#1062 7 months ago

Doesn't kick anything out until the 4th Ball search.
SUCKS as it usually times out whatever Mode you're in waiting on the 4th Ball search.

#1063 7 months ago

I have had a different issue with the trunk. Balls immediately kick out when dropping into the trunk and do not lock.

Trunk Multiball - On my game the lid opens but ball one does not lock when dropped into the trunk and immediately kicks out .
In switch test, opto for ball two lock is fine. Ball one lock test is ok in switch test also. Any balls going in the trunk are immediately kicked out.

I placed game setting #129 to disable trunk diverter to Yes, and I can get trunk multiball to play without the trunk lid operating and can go through sequence of combination light targets and running one ball through the left ramp and repeating again with the three combination light targets and running through the ramp again - trunk multiball is then awarded and begins. Balls just don't go in to the trunk with game setting #129 set to Yes. But you do play the trunk multiball in normal fashion minus dropping into the trunk and locking. Trunk lid stays closed while building up to the multiball.

As the trunk lock switches test ok I reported it as a bug to Stern.

#1064 7 months ago
Quoted from Pin_-_K:

Seeing almost the same thing.
Getting 2 & 3 Balls struck in the Crypt.
With 2 or 3 Balls being stacked on top of one another.[quoted image][quoted image]

FYI - that's not the crypt. You are having an issue with balls stuck in the trunk.

#1065 7 months ago
Quoted from NoQuarters:

I have had a different issue with the trunk. Balls immediately kick out when dropping into the trunk and do not lock.
Trunk Multiball - On my game the lid opens but ball one does not lock when dropped into the trunk and immediately kicks out .
In switch test, opto for ball two lock is fine. Ball one lock test is ok in switch test also. Any balls going in the trunk are immediately kicked out.
I placed game setting #129 to disable trunk diverter to Yes, and I can get trunk multiball to play without the trunk lid operating and can go through sequence of combination light targets and running one ball through the left ramp and repeating again with the three combination light targets and running through the ramp again - trunk multiball is then awarded and begins. Balls just don't go in to the trunk with game setting #129 set to Yes. But you do play the trunk multiball in normal fashion minus dropping into the trunk and locking. Trunk lid stays closed while building up to the multiball.
As the trunk lock switches test ok I reported it as a bug to Stern.

Make sure the screws on the side of the trunk are tight or the lid will not operate properly. I had all sorts of problems with the trunk holding balls and not ejecting. The first ball that enters the trunk is too close to the coil and the second ball can not fall behind it to push the first ball forward. I had to modify the ball guide by bending it so the first ball falls in and is not touching the coil/plunger. That way the second ball can enter the trunk and push the first ball forward. I have no idea if this was the way the trunk was designed, as mine never worked without my modifying. I would really appreciate it if someone who has a working trunk could take a picture from up above with the first ball sitting in the trunk, so I can see if my game is missing something.

#1066 7 months ago

Also check the hinge screws inside the trunk along with the screw that connects the large bar (plunger rod) to the lid. Remove the 2 small screws from the side panel of trunk. Access from there. Check to make sure they haven't started coming loose. My trunk worked fine then started having the balls stacking up / getting stuck. Turns out the screws inside came loose. Once they were tight again the hangups stopped. Worth a shot.

#1067 7 months ago

Ok - I will check screws at the trunk again. I did check the outside ones when I set the game up and they were tight.

I'll take a look at the inside ones. (Sethman) EDIT @ Sethman - I checked screw inside it was tight too. No loose screws.

On my game the lid was popping open fine and the first ball would drop in, but then it would immediately kick out as the coil plunger would fire.

Quoted from Indusguys:

I had to modify the ball guide by bending it so the first ball falls in and is not touching the coil/plunger.

@Idusguys - maybe that "ball guide" is my issue as when that first ball falls in it looked like it was resting close or on that plunger - maybe that is why it fired out immediately.... ??

#1068 7 months ago

Added some interactive purple lighting behind the house to accent the artwork. The red you see is the stock game lighting from the front of the house

Screenshot_20191204-101702 (resized).png
#1069 7 months ago

Very cheap mod that turns out just great

13BEAB84-2D48-4D59-8486-4B626D6DAF92 (resized).jpeg
#1070 7 months ago
Quoted from Pin_-_K:

Seeing almost the same thing.
Getting 2 & 3 Balls struck in the Crypt.
With 2 or 3 Balls being stacked on top of one another.[quoted image][quoted image]

I'm having this problem too, but I think it was already reported by others so I just assumed it was known. The issue I am referring to is on the crypt (other side). My issue is more similar to whysnow's in that it acts like the state is being reported incorrectly via the code. So for example when it is in position 1, the game thinks it is in position 2.

Link to whysnow comment (https://pinside.com/pinball/forum/topic/elvira-s-house-of-horrors-the-owner-s-club/page/21#post-5333256)

#1071 7 months ago
Quoted from Indusguys:

Make sure the screws on the side of the trunk are tight or the lid will not operate properly. I had all sorts of problems with the trunk holding balls and not ejecting. The first ball that enters the trunk is too close to the coil and the second ball can not fall behind it to push the first ball forward. I had to modify the ball guide by bending it so the first ball falls in and is not touching the coil/plunger. That way the second ball can enter the trunk and push the first ball forward. I have no idea if this was the way the trunk was designed, as mine never worked without my modifying. I would really appreciate it if someone who has a working trunk could take a picture from up above with the first ball sitting in the trunk, so I can see if my game is missing something.

more ... " I would really appreciate it if someone who has a working trunk could take a picture from up above with the first ball sitting in the trunk, so I can see if my game is missing something."

Yes - photos of somebody's game with a fully working trunk with that first ball sitting in the trunk could be helpful.
Assuming everybody is on latest code of .87

#1073 7 months ago
Quoted from Lermods:

Modified LED backbox Mod...much clearer detail and color. On our website and pinside shop tomorrow.[quoted image]

Looks pretty good, I am interested! Not sure why it can’t be on the website today .

#1074 7 months ago

Added some trees into my Elvira, I think it really adds to the creepiness.

2FD1667F-193B-4649-A94A-75A852AE8FB9 (resized).jpegFEE2AD54-AB2B-4E65-A536-7DD6A871F5CF (resized).jpeg349BCB4C-BB80-4654-B679-A1F80E732C1B (resized).jpeg58F81BFB-BF31-4415-9DF0-423C3DDC5172 (resized).jpeg
#1075 7 months ago

LE #69 lands in Sydney Australia! Been waiting a long time... Game plays fantastic, loving it.

26DFD313-9E79-44CE-800A-43100EC2592A (resized).jpeg3CAABD94-9B92-4BCD-B680-4CA0A2C5F136 (resized).jpeg
#1076 7 months ago

2 euro mod. Easy to reverse. Not exactly the same car, but it will do for now
Oh forgot to mention before, serial E297367, LE 40, so it seems they are made by number anyway, and nr plaques are not random (as I was told before)

3F81D37E-1F5E-4638-AED6-3F832A480E34 (resized).jpegD6BF0F8B-B504-41A2-9F8D-152B272E41F1 (resized).jpeg
#1077 7 months ago

What trees are you using?

#1078 7 months ago

Purple slings and flipper rubbers

13D6964D-5ED0-4F73-8125-BF61452EC7A7 (resized).jpeg
-1
#1079 7 months ago

Anyone having issues where the 2 gargoyles in front of the dead head hit the playfield glass really hard ?

#1080 7 months ago
Quoted from Wakky:

Anyone having issues where the 2 gargoyles in front of the dead head hit the playfield glass really hard ?

All four of the gargoyles are supposed to hit the glass.

#1082 7 months ago
Quoted from Aurium:

Added some trees into my Elvira, I think it really adds to the creepiness.[quoted image][quoted image][quoted image][quoted image]

Where did you get the trees?

#1083 7 months ago

Earlier in this thread a couple of us asked to see a picture of the trunk open and one ball sitting in the trunk. Could someone please post this picture as it would help me figure out my problem.

#1084 7 months ago
Quoted from Indusguys:

Earlier in this thread a couple of us asked to see a picture of the trunk open and one ball sitting in the trunk. Could someone please post this picture as it would help me figure out my problem.

Information on trunk issues and fixes appreciated along with photos of the mech if yours is operating properly. Also note if you are on .87 code and trunk is functioning correctly. Thanks

#1085 7 months ago
Quoted from jfh:

What trees are you using?

Asking myself the same question...

#1086 7 months ago

Just picked mine up. Can’t wait to play.

#1087 7 months ago
Quoted from NoQuarters:

Information on trunk issues and fixes appreciated along with photos of the mech if yours is operating properly. Also note if you are on .87 code and trunk is functioning correctly. Thanks

I am on .87 code and all my switches are working fine, as mentioned earlier my first ball enters trunk and locks fine, but second ball enters and does not push first ball forward. I am wondering if I could get a picture of a properly working trunk with one ball in it?

#1088 7 months ago
Quoted from Indusguys:

I am on .87 code and all my switches are working fine, as mentioned earlier my first ball enters trunk and locks fine, but second ball enters and does not push first ball forward. I am wondering if I could get a picture of a properly working trunk with one ball in it?

I also have this problem. Put trunk virtual lock now in the menu so I can play the game without interruptions. I hope software can fix this.

#1089 7 months ago
Quoted from gawcol:

I also have this problem. Put trunk virtual lock now in the menu so I can play the game without interruptions. I hope software can fix this.

I had to bend the ball guide and I didn’t do a great job but it works for now. I could only get one of the screws to line up at the end of the job. Here is a picture also of the ball guide before digging into my play field upon receiving the game. Could someone else please post a picture similar to the first one I took.
9EA29A43-5D05-4EF5-AABE-CF6A31FC1465 (resized).jpegBD0CC2B1-2689-4C8F-8C4E-86CA9F33CF35 (resized).jpeg

#1090 7 months ago

I don’t know why that picture is upside down sorry about that here is what the playfield looks like after moving ball guide.

160C0012-AC72-463D-82DD-C5760FA258DF (resized).jpeg
#1091 7 months ago

LE 155 has arrived! Beautiful looking game

15755771732607395622487499572705 (resized).jpg15755771992134867200753791392906 (resized).jpg
#1092 7 months ago
Quoted from zwartepanter:

Asking myself the same question...

This is where I got the trees from

amazon.com link »

#1093 7 months ago
Quoted from pinballaddicted:

LE 155 has arrived! Beautiful looking game[quoted image][quoted image]

Nice combo, I have Xenon too!

robertwinter - You've got my LE number wrong in the first post. It's 69 - very important number!

#1094 7 months ago
Quoted from Mar:

Nice combo, I have Xenon too!
robertwinter - You've got my LE number wrong in the first post. It's 69 - very important number!

Two very sexy ladies! Xenon is only visiting. We are doing her up for a friend of ours.

I love you LE number. Did you request especially or just lucky?

#1095 7 months ago
Quoted from Mar:

Nice combo, I have Xenon too!
robertwinter - You've got my LE number wrong in the first post. It's 69 - very important number!

Fixed!

#1096 7 months ago
Quoted from pinballaddicted:

Two very sexy ladies! Xenon is only visiting. We are doing her up for a friend of ours.
I love you LE number. Did you request especially or just lucky?

Requested it specifically. I didn't think I'd get it to be honest, but I guess I did put my 'expression of interest' in about a year ago...

#1097 7 months ago
Quoted from Mar:

Requested it specifically. I didn't think I'd get it to be honest, but I guess I did put my 'expression of interest' in about a year ago...

That is awesome! Enjoy.

#1098 7 months ago
Quoted from SKWilson:

All four of the gargoyles are supposed to hit the glass.

Incorrect . They are not suppose to hit the glass that hard causing damage . Where is it noted they are supposed to hit the glass ?

#1099 7 months ago

Played mine 20 mins.... and then the ramp screw flew off. I think I found all the parts. Anyone find a easy way of putting this back on yet. Wish I had some Keebler’s elves

#1100 7 months ago
Quoted from Wakky:

Incorrect . They are not suppose to hit the glass that hard causing damage . Where is it noted they are supposed to hit the glass ?

They are supposed to hit the glass. Scared stiff is the same way. You can add rubber rings on the bottom or other limiting actions to stop it. Raise the play field and take a look at the mech. I highly doubt the gargoyles can damage the glass.

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 183.97
Cabinet - Armor And Blades
Pinball-Mods.com
$ 12.95
$ 399.95
There are 4045 posts in this topic. You are on page 22 of 81.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside