(Topic ID: 207571)

Elektra Squawk and Talk board problem/Questions

By igo4rams

6 years ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 6 years ago by igo4rams
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 6 years ago

I have worked out most the the sound problems on my Elektra Squawk and Talk board but one. First let me say, someone in the recent past did some work on this board (new caps, looks like new eproms and new U16) not bad work. Was missing all sounds intermittently, that was a bad fuse on power board for the GI lighting. Problem: Missing some phrases (speech) maybe two or three not sure. When I push the test button on the ST board I hear one phrase that is missing. Now I did a lot of reading and checking, man is there some deep info out there. I don't have a lot of high tech tools, no scope, just a volt meter so please keep that in mind. This board may not be the original board and because of the work done on it, I am thinking "jumpers". I am finding mixed info out there. I found a site that says if speech is required install J and remove H I have H jumped and not J. then another site says make these jumps for: Elektra C, E, G, Q, S, U, W, Y, BB, D, H, DD, N, EE, and L or K also found all the EE jumpers are cut but that may because the board has a ay-3-8912 chip in U12 because one site says: If U12 is present, remove EE jumpers (5 of them) if not present install EE jumpers (5 of them). Board sounds great, I think all background sounds are there and most speech is there, just missing a few. Is it possible that Elektra should have both the EE jumpers and an ay-3-8912 chip in U12 and what about jumpers J and H? Yes, self test button # 18 is on 3 and yes, Mpu sw #30 is on. Now that I said that, that is one of the phrases that is missing: "Prepare for the Gamma Dimension" Not doing a thing till I hear back. Oh, I have a Alltek MPU Thanks

#2 6 years ago

igo4ams;

When we first picked up our Elektra it appeared to have a few missing phrases. We reset the pot for the speech on the squawk/talk board and picked up the phrases that are in the lower registers of the male voice - I believe reset balanced out the background pulse/volume/speech and we were able to hear missing phrases like "Cruising on Alpha", "Will you return?", and one related to the 3rd level, maybe about time expired.

Our Elektra also sports an Alltek Ultimate MPU (really like that board), switches relative to sound are set to liberal so all feature and background sounds, as well as attract are enabled.

FWIW

graab

#3 6 years ago

Reset the pot? Not sure what you mean.

#4 6 years ago

pot = potentiometer. There are two potentiometers (dials) on the board, one controls the volume directly on the board, rather than the remote control inside the coin door. The other little potentiometer/dial on the board, adjusts the clock speed that affects squawk/voice clarity - i.e., clears up the garble. On some boards when you start adjusting that value and you turn it all way up it can make the generally deep voice start to sound like Mickey Mouse.

#5 6 years ago

Thanks for the clarification, that is what I thought. I am thinking it could be the eproms. The phrase that is missing does play when the test button is pushed but not during game play. Does anyone know where to down load the eproms for Elektra Squawk and Talk board?

#6 6 years ago
Quoted from igo4rams:

Thanks for the clarification, that is what I thought. I am thinking it could be the eproms. The phrase that is missing does play when the test button is pushed but not during game play. Does anyone know where to down load the eproms for Elektra Squawk and Talk board?

www.ipdb.org/machine.cgi?id=778

#7 6 years ago
Quoted from igo4rams:

I am thinking it could be the eproms. The phrase that is missing does play when the test button is pushed but not during game play.

If the speech phrases are working is test mode then the EPROMs are more than likely good since valid speech data is being retrieved.

PinWiki says the EE jumpers should not be installed:
http://www.pinwiki.com/wiki/index.php?title=Bally/Stern#Squawk_.26_Talk_Jumper_Settings

This pic on IPDB shows the AY-3-8912 is installed so the EE jumpers must be cut/removed. If you connect them you disable the AY-3-8912 and will lose other sound effects.
http://www.ipdb.org/showpic.pl?id=778&picno=40647

If you can tell us the model of the ROM chips on the S&T board, then we can tell you how to set the jumpers for them. Pictures of the board/ROMs will help.

More than likely you have a connector problem - have you confirmed that you have proper continuity of the sound select signals between the MPU board and the sound board?
Specifically:
MPU J4 Pin 4 to sound board J1 Pin 1
MPU J4 Pin 3 to sound board J1 Pin 2
MPU J4 Pin 2 to sound board J1 Pin 3
MPU J4 Pin 1 to sound board J1 Pin 4
MPU J4 Pin 10 to sound board J1 Pin 12

#8 6 years ago

Thanks, I think you may be right on the roms. I will check the connections.

Promoted items from Pinside Marketplace and Pinside Shops!
$ 18.95
Eproms
Pinballrom
 
$ 90.00
$ 10.00
$ 44.99
Cabinet - Shooter Rods
Pinball Shark
 
3,100 (OBO)
Machine - For Sale
O'fallon, MO
Wanted
Machine - Wanted
Brooklyn, NY
$ 33.95
Eproms
Pinballrom
 
From: $ 14.00
Electronics
Third Coast Pinball
 
$ 18.00
Electronics
Yorktown Arcade Supply
 
$ 30.00
Lighting - Led
Pinballrom
 
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/elektra-squawk-and-talk-board-problemquestions and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.